about summary refs log tree commit diff
path: root/lib/attrsets.nix
diff options
context:
space:
mode:
authorColin Arnott <colin@urandom.co.uk>2023-01-30 21:22:02 +0000
committerColin Arnott <colin@urandom.co.uk>2023-01-30 23:53:44 +0000
commit6ff66fcbd70c7d588bbf6e3b2cd41aa7d8a62fd2 (patch)
tree2514e62f38e786c506c5cd461d592f4291f1557c /lib/attrsets.nix
parent24525805b68d83b5f578db887040303c069fa710 (diff)
downloadnixlib-6ff66fcbd70c7d588bbf6e3b2cd41aa7d8a62fd2.tar
nixlib-6ff66fcbd70c7d588bbf6e3b2cd41aa7d8a62fd2.tar.gz
nixlib-6ff66fcbd70c7d588bbf6e3b2cd41aa7d8a62fd2.tar.bz2
nixlib-6ff66fcbd70c7d588bbf6e3b2cd41aa7d8a62fd2.tar.lz
nixlib-6ff66fcbd70c7d588bbf6e3b2cd41aa7d8a62fd2.tar.xz
nixlib-6ff66fcbd70c7d588bbf6e3b2cd41aa7d8a62fd2.tar.zst
nixlib-6ff66fcbd70c7d588bbf6e3b2cd41aa7d8a62fd2.zip
lib: standardise attrset type syntax
There are a number of different syntaxes used for attrset type
signatures in our doc strings, this change standardises upon one that
uses :: for specifying attribute type, and ; terminators to be
consistent with nix syntax. There are no bugs in the functions
themselves, just that different syntaxes may confuse new users.
Diffstat (limited to 'lib/attrsets.nix')
-rw-r--r--lib/attrsets.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/lib/attrsets.nix b/lib/attrsets.nix
index 1a51225a80ed..30952651adf4 100644
--- a/lib/attrsets.nix
+++ b/lib/attrsets.nix
@@ -168,7 +168,7 @@ rec {
        ] { a.b.c = 0; }
        => { a = { b = { d = 1; }; }; x = { y = "xy"; }; }
 
-    Type: updateManyAttrsByPath :: [{ path :: [String], update :: (Any -> Any) }] -> AttrSet -> AttrSet
+    Type: updateManyAttrsByPath :: [{ path :: [String]; update :: (Any -> Any); }] -> AttrSet -> AttrSet
   */
   updateManyAttrsByPath = let
     # When recursing into attributes, instead of updating the `path` of each
@@ -414,7 +414,7 @@ rec {
        => { name = "some"; value = 6; }
 
      Type:
-       nameValuePair :: String -> Any -> { name :: String, value :: Any }
+       nameValuePair :: String -> Any -> { name :: String; value :: Any; }
   */
   nameValuePair =
     # Attribute name
@@ -449,7 +449,7 @@ rec {
        => { foo_x = "bar-a"; foo_y = "bar-b"; }
 
      Type:
-       mapAttrs' :: (String -> Any -> { name = String; value = Any }) -> AttrSet -> AttrSet
+       mapAttrs' :: (String -> Any -> { name :: String; value :: Any; }) -> AttrSet -> AttrSet
   */
   mapAttrs' =
     # A function, given an attribute's name and value, returns a new `nameValuePair`.
@@ -649,7 +649,7 @@ rec {
 
      Example:
        zipAttrsWith (name: values: values) [{a = "x";} {a = "y"; b = "z";}]
-       => { a = ["x" "y"]; b = ["z"] }
+       => { a = ["x" "y"]; b = ["z"]; }
 
      Type:
        zipAttrsWith :: (String -> [ Any ] -> Any) -> [ AttrSet ] -> AttrSet
@@ -664,7 +664,7 @@ rec {
 
      Example:
        zipAttrs [{a = "x";} {a = "y"; b = "z";}]
-       => { a = ["x" "y"]; b = ["z"] }
+       => { a = ["x" "y"]; b = ["z"]; }
 
      Type:
        zipAttrs :: [ AttrSet ] -> AttrSet