about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorRobert Hensing <robert@roberthensing.nl>2022-06-09 11:37:08 +0200
committerRobert Hensing <robert@roberthensing.nl>2022-07-10 13:35:54 +0200
commit62314ccc17684bcc9310f3b380cffe15bae177d6 (patch)
treec868421f46157358b72749d31d0490c4944dab2c /flake.nix
parent711e653a65300652f680aa9aa7e26b609f7d232e (diff)
downloadnixlib-62314ccc17684bcc9310f3b380cffe15bae177d6.tar
nixlib-62314ccc17684bcc9310f3b380cffe15bae177d6.tar.gz
nixlib-62314ccc17684bcc9310f3b380cffe15bae177d6.tar.bz2
nixlib-62314ccc17684bcc9310f3b380cffe15bae177d6.tar.lz
nixlib-62314ccc17684bcc9310f3b380cffe15bae177d6.tar.xz
nixlib-62314ccc17684bcc9310f3b380cffe15bae177d6.tar.zst
nixlib-62314ccc17684bcc9310f3b380cffe15bae177d6.zip
flake.lib.nixosSystem: Allow nixpkgs.system to be set instead
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 8c0403adc4a3..f78c75128731 100644
--- a/flake.nix
+++ b/flake.nix
@@ -26,6 +26,11 @@
                 ".${final.substring 0 8 (self.lastModifiedDate or self.lastModified or "19700101")}.${self.shortRev or "dirty"}";
               system.nixos.revision = final.mkIf (self ? rev) self.rev;
             } ];
+          } // lib.optionalAttrs (! args?system) {
+            # Allow system to be set modularly in nixpkgs.system.
+            # We set it to null, to remove the "legacy" entrypoint's
+            # non-hermetic default.
+            system = null;
           });
       });