about summary refs log tree commit diff
path: root/doc/doc-support/default.nix
diff options
context:
space:
mode:
authorGraham Christensen <graham@grahamc.com>2019-07-04 08:23:39 -0400
committerGraham Christensen <graham@grahamc.com>2019-07-04 09:07:47 -0400
commitcd6bf8aa00962766e4db9f26e36848b6be8dd096 (patch)
treebdcca190ea7a29c855f8ac63735566dc1f775ade /doc/doc-support/default.nix
parentddfe184efcc2152b741bc0a8eee3dea12c4cb2f8 (diff)
downloadnixlib-cd6bf8aa00962766e4db9f26e36848b6be8dd096.tar
nixlib-cd6bf8aa00962766e4db9f26e36848b6be8dd096.tar.gz
nixlib-cd6bf8aa00962766e4db9f26e36848b6be8dd096.tar.bz2
nixlib-cd6bf8aa00962766e4db9f26e36848b6be8dd096.tar.lz
nixlib-cd6bf8aa00962766e4db9f26e36848b6be8dd096.tar.xz
nixlib-cd6bf8aa00962766e4db9f26e36848b6be8dd096.tar.zst
nixlib-cd6bf8aa00962766e4db9f26e36848b6be8dd096.zip
docs: use a single nix-build for all the generate function docs
Diffstat (limited to 'doc/doc-support/default.nix')
-rw-r--r--doc/doc-support/default.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/doc/doc-support/default.nix b/doc/doc-support/default.nix
new file mode 100644
index 000000000000..93f6287d4b09
--- /dev/null
+++ b/doc/doc-support/default.nix
@@ -0,0 +1,14 @@
+{ pkgs ? (import ../.. {}), nixpkgs ? { }}:
+let
+  locationsXml = import ./lib-function-locations.nix { inherit pkgs nixpkgs; };
+  functionDocs = import ./lib-function-docs.nix { inherit locationsXml pkgs; };
+in pkgs.runCommand "doc-support" {}
+''
+  mkdir result
+  (
+    cd result
+    ln -s ${locationsXml} ./function-locations.xml
+    ln -s ${functionDocs} ./function-docs
+  )
+  mv result $out
+''