about summary refs log tree commit diff
path: root/doc/default.nix
diff options
context:
space:
mode:
authorAlejandro Sanchez Medina <alejandrosanchzmedina@gmail.com>2023-07-13 11:16:28 +0200
committerShahar "Dawn" Or <mightyiampresence@gmail.com>2023-07-25 17:00:51 +0700
commit13aeddb926677e6becbc322a46c613a4899ceb4d (patch)
tree63af5765513d22ecf5f17f44eca0ac3f74066373 /doc/default.nix
parent821c72743ceae44bdd09718d47cab98fd5fd90af (diff)
downloadnixlib-13aeddb926677e6becbc322a46c613a4899ceb4d.tar
nixlib-13aeddb926677e6becbc322a46c613a4899ceb4d.tar.gz
nixlib-13aeddb926677e6becbc322a46c613a4899ceb4d.tar.bz2
nixlib-13aeddb926677e6becbc322a46c613a4899ceb4d.tar.lz
nixlib-13aeddb926677e6becbc322a46c613a4899ceb4d.tar.xz
nixlib-13aeddb926677e6becbc322a46c613a4899ceb4d.tar.zst
nixlib-13aeddb926677e6becbc322a46c613a4899ceb4d.zip
nixpkgs manual: extract some build paths
Co-authored-by: Shahar "Dawn" Or <mightyiampresence@gmail.com>
Diffstat (limited to 'doc/default.nix')
-rw-r--r--doc/default.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/doc/default.nix b/doc/default.nix
index 8efa406ec1ea..f4270ae856d5 100644
--- a/doc/default.nix
+++ b/doc/default.nix
@@ -3,6 +3,8 @@ let
   inherit (pkgs) lib;
   inherit (lib) hasPrefix removePrefix;
 
+  common = import ./common.nix;
+
   lib-docs = import ./doc-support/lib-function-docs.nix {
     inherit pkgs nixpkgs;
     libsets = [
@@ -132,15 +134,15 @@ in pkgs.stdenv.mkDerivation {
   '';
 
   installPhase = ''
-    dest="$out/share/doc/nixpkgs"
+    dest="$out/${common.outputPath}"
     mkdir -p "$(dirname "$dest")"
     mv out "$dest"
-    mv "$dest/index.html" "$dest/manual.html"
+    mv "$dest/index.html" "$dest/${common.indexPath}"
 
     cp ${epub} "$dest/nixpkgs-manual.epub"
 
     mkdir -p $out/nix-support/
-    echo "doc manual $dest manual.html" >> $out/nix-support/hydra-build-products
+    echo "doc manual $dest ${common.indexPath}" >> $out/nix-support/hydra-build-products
     echo "doc manual $dest nixpkgs-manual.epub" >> $out/nix-support/hydra-build-products
   '';
 }