about summary refs log tree commit diff
path: root/doc/builders/packages/emacs.xml
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2019-10-30 11:03:55 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2019-10-30 11:17:14 +0100
commitaad81ec8cd158a9e11f4d35fc6022d1300fcb4c6 (patch)
treeb947a433a8365601ef7758d13029d638a83fd5fb /doc/builders/packages/emacs.xml
parentacfc517a80ba4e53508fc38a09dd293aeb487cd2 (diff)
downloadnixlib-aad81ec8cd158a9e11f4d35fc6022d1300fcb4c6.tar
nixlib-aad81ec8cd158a9e11f4d35fc6022d1300fcb4c6.tar.gz
nixlib-aad81ec8cd158a9e11f4d35fc6022d1300fcb4c6.tar.bz2
nixlib-aad81ec8cd158a9e11f4d35fc6022d1300fcb4c6.tar.lz
nixlib-aad81ec8cd158a9e11f4d35fc6022d1300fcb4c6.tar.xz
nixlib-aad81ec8cd158a9e11f4d35fc6022d1300fcb4c6.tar.zst
nixlib-aad81ec8cd158a9e11f4d35fc6022d1300fcb4c6.zip
nixpkgs manual: fix white space and indentation
Diffstat (limited to 'doc/builders/packages/emacs.xml')
-rw-r--r--doc/builders/packages/emacs.xml34
1 files changed, 17 insertions, 17 deletions
diff --git a/doc/builders/packages/emacs.xml b/doc/builders/packages/emacs.xml
index a9a26882c9cd..9cce7c40863a 100644
--- a/doc/builders/packages/emacs.xml
+++ b/doc/builders/packages/emacs.xml
@@ -1,14 +1,14 @@
 <section xmlns="http://docbook.org/ns/docbook"
          xmlns:xlink="http://www.w3.org/1999/xlink"
          xml:id="sec-emacs">
-  <title>Emacs</title>
+ <title>Emacs</title>
 
-  <section xml:id="sec-emacs-config">
-   <title>Configuring Emacs</title>
+ <section xml:id="sec-emacs-config">
+  <title>Configuring Emacs</title>
 
-   <para>
-    The Emacs package comes with some extra helpers to make it easier to configure. <varname>emacsWithPackages</varname> allows you to manage packages from ELPA. This means that you will not have to install that packages from within Emacs. For instance, if you wanted to use <literal>company</literal>, <literal>counsel</literal>, <literal>flycheck</literal>, <literal>ivy</literal>, <literal>magit</literal>, <literal>projectile</literal>, and <literal>use-package</literal> you could use this as a <filename>~/.config/nixpkgs/config.nix</filename> override:
-   </para>
+  <para>
+   The Emacs package comes with some extra helpers to make it easier to configure. <varname>emacsWithPackages</varname> allows you to manage packages from ELPA. This means that you will not have to install that packages from within Emacs. For instance, if you wanted to use <literal>company</literal>, <literal>counsel</literal>, <literal>flycheck</literal>, <literal>ivy</literal>, <literal>magit</literal>, <literal>projectile</literal>, and <literal>use-package</literal> you could use this as a <filename>~/.config/nixpkgs/config.nix</filename> override:
+  </para>
 
 <screen>
 {
@@ -26,9 +26,9 @@
 }
 </screen>
 
-   <para>
-    You can install it like any other packages via <command>nix-env -iA myEmacs</command>. However, this will only install those packages. It will not <literal>configure</literal> them for us. To do this, we need to provide a configuration file. Luckily, it is possible to do this from within Nix! By modifying the above example, we can make Emacs load a custom config file. The key is to create a package that provide a <filename>default.el</filename> file in <filename>/share/emacs/site-start/</filename>. Emacs knows to load this file automatically when it starts.
-   </para>
+  <para>
+   You can install it like any other packages via <command>nix-env -iA myEmacs</command>. However, this will only install those packages. It will not <literal>configure</literal> them for us. To do this, we need to provide a configuration file. Luckily, it is possible to do this from within Nix! By modifying the above example, we can make Emacs load a custom config file. The key is to create a package that provide a <filename>default.el</filename> file in <filename>/share/emacs/site-start/</filename>. Emacs knows to load this file automatically when it starts.
+  </para>
 
 <screen>
 {
@@ -108,13 +108,13 @@ cp ${myEmacsConfig} $out/share/emacs/site-lisp/default.el
 }
 </screen>
 
-   <para>
-    This provides a fairly full Emacs start file. It will load in addition to the user's presonal config. You can always disable it by passing <command>-q</command> to the Emacs command.
-   </para>
+  <para>
+   This provides a fairly full Emacs start file. It will load in addition to the user's presonal config. You can always disable it by passing <command>-q</command> to the Emacs command.
+  </para>
 
-   <para>
-    Sometimes <varname>emacsWithPackages</varname> is not enough, as this package set has some priorities imposed on packages (with the lowest priority assigned to Melpa Unstable, and the highest for packages manually defined in <filename>pkgs/top-level/emacs-packages.nix</filename>). But you can't control this priorities when some package is installed as a dependency. You can override it on per-package-basis, providing all the required dependencies manually - but it's tedious and there is always a possibility that an unwanted dependency will sneak in through some other package. To completely override such a package you can use <varname>overrideScope'</varname>.
-   </para>
+  <para>
+   Sometimes <varname>emacsWithPackages</varname> is not enough, as this package set has some priorities imposed on packages (with the lowest priority assigned to Melpa Unstable, and the highest for packages manually defined in <filename>pkgs/top-level/emacs-packages.nix</filename>). But you can't control this priorities when some package is installed as a dependency. You can override it on per-package-basis, providing all the required dependencies manually - but it's tedious and there is always a possibility that an unwanted dependency will sneak in through some other package. To completely override such a package you can use <varname>overrideScope'</varname>.
+  </para>
 
 <screen>
 overrides = self: super: rec {
@@ -127,5 +127,5 @@ overrides = self: super: rec {
   dante
 ])
 </screen>
-  </section>
-</section>
\ No newline at end of file
+ </section>
+</section>