about summary refs log tree commit diff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..54677a8
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,13 @@
+# SPDX-FileCopyrightText: 2022 Alyssa Ross <hi@alyssa.is>
+# SPDX-License-Identifier: EUPL-1.2
+
+project('hydrasect', 'rust', 'c',
+  default_options : ['rust_std=2021', 'warning_level=3'])
+
+c_lib = static_library('hydrasect', 'tmpfd.c')
+
+executable('hydrasect-search', 'hydrasect-search.rs', install : true)
+
+test('Rust unit tests', executable('hydrasect-search-test', 'hydrasect-search.rs',
+  link_with : c_lib,
+  rust_args : '--test'))