about summary refs log tree commit diff
path: root/config/git/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'config/git/config.nix')
-rw-r--r--config/git/config.nix55
1 files changed, 55 insertions, 0 deletions
diff --git a/config/git/config.nix b/config/git/config.nix
new file mode 100644
index 000000000000..88fa7220fe4d
--- /dev/null
+++ b/config/git/config.nix
@@ -0,0 +1,55 @@
+''
+[core]
+    attributesfile = ${./attributes}
+    excludesfile = ${./ignore}
+[user]
+    name = Alyssa Ross
+    email = hi@alyssa.is
+[alias]
+    ignore = "!gi() { curl -L -s https://www.gitignore.io/api/$@ ;}; gi"
+    unbranch = "!git branch --sort -HEAD --merged | sed 1d | xargs git branch -d"
+[push]
+    default = current
+[merge]
+    conflictstyle = diff3
+    tool = opendiff
+[color "branch"]
+    current = yellow reverse
+    local = yellow
+    remote = green
+[color "diff"]
+    meta = yellow bold
+    frag = magenta bold
+    old = red bold
+    new = green bold
+[color "status"]
+    added = yellow
+    changed = green
+    untracked = cyan
+[commit]
+    gpgsign = true
+    verbose = true
+[help]
+    autocorrect = 1
+[filter "lfs"]
+    smudge = git-lfs smudge -- %f
+    required = true
+    clean = git-lfs clean -- %f
+[diff]
+    compactionHeuristic = true
+    renameLimit = 0
+    wsErrorHighlight = all
+[credential]
+    helper = osxkeychain
+[hub]
+    protocol = ssh
+[branch]
+    autosetuprebase = always
+[diff "plist"]
+    textconv = /usr/bin/plutil -convert xml1 -o -
+[format]
+    pretty = format:%Cred%h %C(magenta)%G? %Cgreen(%ar)%Creset -%C(bold red)%d%Creset %s %C(bold blue)<%aN>%Creset
+[grep]
+    lineNumber = true
+    patternType = perl
+''