about summary refs log tree commit diff
path: root/modules/server/git/default.nix
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2024-04-05 10:54:42 +0200
committerAlyssa Ross <hi@alyssa.is>2024-04-05 11:02:05 +0200
commitc75bba822a0feee47da115cd30febb4f4f84c4ed (patch)
tree22afc2e534a294f76e4ad208d2a2bc9b3232797a /modules/server/git/default.nix
parent70d1111946728b627ff6b97e7ac435ba43628a44 (diff)
downloadnixlib-c75bba822a0feee47da115cd30febb4f4f84c4ed.tar
nixlib-c75bba822a0feee47da115cd30febb4f4f84c4ed.tar.gz
nixlib-c75bba822a0feee47da115cd30febb4f4f84c4ed.tar.bz2
nixlib-c75bba822a0feee47da115cd30febb4f4f84c4ed.tar.lz
nixlib-c75bba822a0feee47da115cd30febb4f4f84c4ed.tar.xz
nixlib-c75bba822a0feee47da115cd30febb4f4f84c4ed.tar.zst
nixlib-c75bba822a0feee47da115cd30febb4f4f84c4ed.zip
Drop mdDoc
This is being removed in Nixpkgs.
Diffstat (limited to 'modules/server/git/default.nix')
-rw-r--r--modules/server/git/default.nix16
1 files changed, 8 insertions, 8 deletions
diff --git a/modules/server/git/default.nix b/modules/server/git/default.nix
index 523715a363d9..bce947bfd430 100644
--- a/modules/server/git/default.nix
+++ b/modules/server/git/default.nix
@@ -15,35 +15,35 @@ let
     options = {
       branch = mkOption {
         default = "main";
-        description = mdDoc "Branch to be the repository's HEAD";
+        description = "Branch to be the repository's HEAD";
         type = types.str;
       };
 
       description = mkOption {
-        description = mdDoc "Description of the repository.";
+        description = "Description of the repository.";
         type = types.str;
       };
 
       config = mkOption {
-        description = mdDoc "Git configuration for the repository.";
+        description = "Git configuration for the repository.";
         type = types.attrs;
         default = {};
       };
 
       hooks = mkOption {
-        description = mdDoc "Git hooks for the repository.";
+        description = "Git hooks for the repository.";
         type = with types; attrsOf (listOf path);
         default = {};
       };
 
       owner = mkOption {
-        description = mdDoc "Name of the user to own the git repository.";
+        description = "Name of the user to own the git repository.";
         type = types.str;
         default = "-";
       };
 
       group = mkOption {
-        description = mdDoc "Name of the group for the git repository.";
+        description = "Name of the group for the git repository.";
         type = types.str;
         default = "-";
       };
@@ -52,13 +52,13 @@ let
 in {
   options.declarative-git = {
     repositories = mkOption {
-      description = mdDoc "Repositories to manage declaratively.";
+      description = "Repositories to manage declaratively.";
       type = types.attrsOf (types.submodule repoOpts);
       default = {};
     };
 
     hooks = mkOption {
-      description = mdDoc "Git hooks to apply to all declarative repositories.";
+      description = "Git hooks to apply to all declarative repositories.";
       type = with types; attrsOf (listOf path);
       default = {};
     };