summary refs log tree commit diff
path: root/release/live/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'release/live/default.nix')
-rw-r--r--release/live/default.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/release/live/default.nix b/release/live/default.nix
index 66bba26..c36c34b 100644
--- a/release/live/default.nix
+++ b/release/live/default.nix
@@ -2,7 +2,8 @@
 # SPDX-FileCopyrightText: 2021-2022 Alyssa Ross <hi@alyssa.is>
 # SPDX-FileCopyrightText: 2022 Unikie
 
-{ config ? import ../../nix/eval-config.nix {} }: config.pkgs.callPackage (
+import ../../nix/eval-config.nix ({ config, src, ... }:
+config.pkgs.callPackage (
 
 { stdenvNoCC, cryptsetup, dosfstools, jq, mtools, util-linux, stdenv
 , systemd }:
@@ -22,7 +23,7 @@ in
 stdenvNoCC.mkDerivation {
   name = "spectrum-live.img";
 
-  inherit (config) src;
+  inherit src;
   sourceRoot = "source/release/live";
 
   nativeBuildInputs = [ cryptsetup dosfstools jq mtools util-linux ];
@@ -46,4 +47,4 @@ stdenvNoCC.mkDerivation {
 
   passthru = { inherit rootfs; };
 }
-) {}
+) {})