summary refs log tree commit diff
path: root/host/initramfs/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/initramfs/shell.nix')
-rw-r--r--host/initramfs/shell.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/host/initramfs/shell.nix b/host/initramfs/shell.nix
new file mode 100644
index 0000000..02aa685
--- /dev/null
+++ b/host/initramfs/shell.nix
@@ -0,0 +1,10 @@
+# SPDX-License-Identifier: EUPL-1.2
+# SPDX-FileCopyrightText: 2021-2022 Alyssa Ross <hi@alyssa.is>
+
+{ pkgs ? import <nixpkgs> {} }:
+
+with pkgs;
+
+(import ./live.nix { inherit pkgs; }).overrideAttrs ({ ... }: {
+  OVMF_FD = "${OVMF.fd}/FV/OVMF.fd";
+})