summary refs log tree commit diff
path: root/host/initramfs/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/initramfs/shell.nix')
-rw-r--r--host/initramfs/shell.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/host/initramfs/shell.nix b/host/initramfs/shell.nix
index 42da6a4..cbd2c60 100644
--- a/host/initramfs/shell.nix
+++ b/host/initramfs/shell.nix
@@ -1,16 +1,17 @@
 # SPDX-License-Identifier: MIT
 # SPDX-FileCopyrightText: 2021-2022 Alyssa Ross <hi@alyssa.is>
 
-{ pkgs ? import <nixpkgs> {} }:
+{ config ? import ../../nix/eval-config.nix {} }:
 
 let
+  inherit (config) pkgs;
   inherit (pkgs.lib) cleanSource cleanSourceWith;
 
   extfs = pkgs.pkgsStatic.callPackage ./extfs.nix {
-    inherit pkgs;
+    inherit config;
   };
-  rootfs = import ../rootfs { inherit pkgs; };
-  initramfs = import ./. { inherit pkgs rootfs; };
+  rootfs = import ../rootfs { inherit config; };
+  initramfs = import ./. { inherit config rootfs; };
 in
 
 with pkgs;