summary refs log tree commit diff
path: root/tests/openssh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/openssh.nix')
-rw-r--r--tests/openssh.nix22
1 files changed, 11 insertions, 11 deletions
diff --git a/tests/openssh.nix b/tests/openssh.nix
index 0e8bd3e2b9d7..5818c9d6cebb 100644
--- a/tests/openssh.nix
+++ b/tests/openssh.nix
@@ -2,33 +2,33 @@
 
 {
   nodes = {
-  
-    server = 
+
+    server =
       { config, pkgs, ... }:
-      
+
       {
         services.openssh.enable = true;
       };
-      
-    client = 
+
+    client =
       { config, pkgs, ... }: { };
-      
+
   };
-  
+
   testScript = ''
     startAll;
-    
+
     my $key=`${pkgs.openssh}/bin/ssh-keygen -t dsa -f key -N ""`;
 
     $server->waitForJob("sshd");
-    
+
     $server->mustSucceed("mkdir -m 700 /root/.ssh");
     $server->copyFileFromHost("key.pub", "/root/.ssh/authorized_keys");
-    
+
     $client->mustSucceed("mkdir -m 700 /root/.ssh");
     $client->copyFileFromHost("key", "/root/.ssh/id_dsa");
     $client->mustSucceed("chmod 600 /root/.ssh/id_dsa");
-    
+
     $client->waitForJob("network-interfaces");
     $client->mustSucceed("ssh -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no server 'echo hello world'");
   '';