summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/python-packages.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index f6ad5d2a8974..5550b09645eb 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -10202,6 +10202,12 @@ let
     buildInputs = [ pkgs.gfortran self.nose ];
     propagatedBuildInputs = [ support.openblas ];
 
+    # This patch removes the test of large file support, which takes forever
+    # and can cause the machine to run out of disk space when run.
+    patchPhase = ''
+      patch -p0 < ${../development/python-modules/numpy-no-large-files.patch}
+    '';
+
     meta = {
       description = "Scientific tools for Python";
       homepage = "http://numpy.scipy.org/";