about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/admin/mycli/default.nix1
-rw-r--r--pkgs/tools/compression/lz4/default.nix10
-rw-r--r--pkgs/tools/compression/lz4/install-on-freebsd.patch54
-rw-r--r--pkgs/tools/misc/bepasty/default.nix3
-rw-r--r--pkgs/tools/networking/pirate-get/default.nix4
5 files changed, 7 insertions, 65 deletions
diff --git a/pkgs/tools/admin/mycli/default.nix b/pkgs/tools/admin/mycli/default.nix
index bd0f051bd845..1a85bf21b224 100644
--- a/pkgs/tools/admin/mycli/default.nix
+++ b/pkgs/tools/admin/mycli/default.nix
@@ -7,7 +7,6 @@ with python.pkgs;
 buildPythonApplication rec {
   pname = "mycli";
   version = "1.6.0";
-  name = "${pname}-${version}";
 
   src = fetchPypi {
     inherit pname version;
diff --git a/pkgs/tools/compression/lz4/default.nix b/pkgs/tools/compression/lz4/default.nix
index 04c83fa03fcf..7e29ee2b856a 100644
--- a/pkgs/tools/compression/lz4/default.nix
+++ b/pkgs/tools/compression/lz4/default.nix
@@ -2,13 +2,13 @@
 
 stdenv.mkDerivation rec {
   name = "lz4-${version}";
-  version = "131";
+  version = "1.8.2";
 
   src = fetchFromGitHub {
-    sha256 = "1bhvcq8fxxsqnpg5qa6k3nsyhq0nl0iarh08sqzclww27hlpyay2";
-    rev = "r${version}";
+    sha256 = "0xbjbjrvgzypk8dnldakir06gb8m946d064lxx0qc4ky6m8n9hn2";
+    rev = "v${version}";
     repo = "lz4";
-    owner = "Cyan4973";
+    owner = "lz4";
   };
 
   outputs = [ "out" "dev" ];
@@ -22,8 +22,6 @@ stdenv.mkDerivation rec {
   doCheck = false; # tests take a very long time
   checkTarget = "test";
 
-  patches = [ ./install-on-freebsd.patch ] ;
-
   postInstall = "rm $out/lib/*.a";
 
   meta = with stdenv.lib; {
diff --git a/pkgs/tools/compression/lz4/install-on-freebsd.patch b/pkgs/tools/compression/lz4/install-on-freebsd.patch
deleted file mode 100644
index 12a2bf72f4ed..000000000000
--- a/pkgs/tools/compression/lz4/install-on-freebsd.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-diff --git a/Makefile b/Makefile
-index d1b0d0c..f8d6a2d 100644
---- a/Makefile
-+++ b/Makefile
-@@ -80,8 +80,6 @@ clean:
- 
- 
- #------------------------------------------------------------------------
--#make install is validated only for Linux, OSX, kFreeBSD and Hurd targets
--ifneq (,$(filter $(shell uname),Linux Darwin GNU/kFreeBSD GNU))
- 
- install:
- 	@cd $(LZ4DIR); $(MAKE) -e install
-@@ -129,4 +127,3 @@ examples:
- prg-travis:
- 	@cd $(PRGDIR); $(MAKE) -e test-travis
- 
--endif
-diff --git a/lib/Makefile b/lib/Makefile
-index 02ddd3b..26ed18f 100644
---- a/lib/Makefile
-+++ b/lib/Makefile
-@@ -80,8 +80,6 @@ clean:
- 
- 
- #------------------------------------------------------------------------
--#make install is validated only for Linux, OSX, kFreeBSD and Hurd targets
--ifneq (,$(filter $(shell uname),Linux Darwin GNU/kFreeBSD GNU))
- 
- liblz4.pc: liblz4.pc.in Makefile
- 	@echo creating pkgconfig
-@@ -114,4 +112,3 @@ uninstall:
- 	@[ -f $(DESTDIR)$(INCLUDEDIR)/lz4frame.h ] && rm -f $(DESTDIR)$(INCLUDEDIR)/lz4frame.h
- 	@echo lz4 libraries successfully uninstalled
- 
--endif
-diff --git a/programs/Makefile b/programs/Makefile
-index f422902..6943363 100644
---- a/programs/Makefile
-+++ b/programs/Makefile
-@@ -113,8 +113,6 @@ clean:
- 
- 
- #------------------------------------------------------------------------
--#make install is validated only for Linux, OSX, kFreeBSD and Hurd targets
--ifneq (,$(filter $(shell uname),Linux Darwin GNU/kFreeBSD GNU))
- 
- install: lz4 lz4c
- 	@echo Installing binaries
-@@ -307,4 +305,3 @@ test-mem: lz4 datagen fuzzer frametest fullbench
- test-mem32: lz4c32 datagen
- # unfortunately, valgrind doesn't seem to work with non-native binary. If someone knows how to do a valgrind-test on a 32-bits exe with a 64-bits system...
- 
--endif
diff --git a/pkgs/tools/misc/bepasty/default.nix b/pkgs/tools/misc/bepasty/default.nix
index f69f654cda3d..ae88b7e99c65 100644
--- a/pkgs/tools/misc/bepasty/default.nix
+++ b/pkgs/tools/misc/bepasty/default.nix
@@ -10,7 +10,6 @@ with python.pkgs;
 buildPythonPackage rec {
   pname = "bepasty";
   version = "0.4.0";
-  name = "${pname}-${version}";
 
   propagatedBuildInputs = [
     flask
@@ -39,4 +38,4 @@ buildPythonPackage rec {
     license = lib.licenses.mit;
     maintainers = [ lib.maintainers.makefu ];
   };
-}
\ No newline at end of file
+}
diff --git a/pkgs/tools/networking/pirate-get/default.nix b/pkgs/tools/networking/pirate-get/default.nix
index 6e50b11568e6..8e05e49962cd 100644
--- a/pkgs/tools/networking/pirate-get/default.nix
+++ b/pkgs/tools/networking/pirate-get/default.nix
@@ -5,13 +5,13 @@ with python3Packages;
 buildPythonApplication rec {
   name = "${pname}-${version}";
   pname = "pirate-get";
-  version = "0.2.12";
+  version = "0.2.13";
 
   doCheck = false;
 
   src = fetchPypi {
     inherit pname version;
-    sha256 = "1q6hvavj0gswgw3x756h18nmmpnxlgg08qvxphpbzlwd43xrnza3";
+    sha256 = "c5b159e02067136d3157d56061958a50e997a078510e4403bb7de40217833f3f";
   };
 
   propagatedBuildInputs = [ colorama veryprettytable beautifulsoup4 ];