about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/appdata-tools/default.nix25
-rw-r--r--pkgs/tools/networking/cutter/default.nix22
2 files changed, 47 insertions, 0 deletions
diff --git a/pkgs/tools/misc/appdata-tools/default.nix b/pkgs/tools/misc/appdata-tools/default.nix
new file mode 100644
index 000000000000..acacc4db15f8
--- /dev/null
+++ b/pkgs/tools/misc/appdata-tools/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchurl, pkgconfig, autoconf, automake, m4
+, intltool, glib, libsoup, gdk_pixbuf }:
+
+stdenv.mkDerivation rec {
+  version = "0_1_7";
+  name = "appdata_tools-${version}";
+
+  src = fetchurl {
+    url = "https://github.com/hughsie/appdata-tools/archive/appdata_tools_${version}.tar.gz";
+    sha256 = "1bzqg4gy8gqhbk2qjizsm0b78li9mv84fb3d8qwfpxh7c7p360x8";
+  };
+
+  buildInputs = [ pkgconfig autoconf automake m4 intltool glib
+                  libsoup gdk_pixbuf ];
+
+  configureScript = "./autogen.sh";
+
+  meta = with stdenv.lib; {
+    homepage = "http://people.freedesktop.org/~hughsient/appdata";
+    description = "CLI designed to validate AppData descriptions for standards compliance and to the style guide";
+    platforms = platforms.linux;
+    license = licenses.gpl2;
+    maintainers = with maintainers; [ lethalman ];
+  };
+}
diff --git a/pkgs/tools/networking/cutter/default.nix b/pkgs/tools/networking/cutter/default.nix
new file mode 100644
index 000000000000..5d383f072102
--- /dev/null
+++ b/pkgs/tools/networking/cutter/default.nix
@@ -0,0 +1,22 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+  name = "cutter-1.03";
+
+  src = fetchurl {
+    url = "http://www.digitage.co.uk/digitage/files/cutter/${name}.tgz";
+    md5 = "50093db9b64277643969ee75b83ebbd1";
+  };
+
+  installPhase = ''
+    install -D -m 0755 cutter $out/bin/tcp-cutter
+  '';
+
+  meta = with stdenv.lib; {
+    description = "TCP/IP Connection cutting on Linux Firewalls and Routers";
+    homepage = http://www.digitage.co.uk/digitage/software/linux-security/cutter;
+    license = licenses.gpl2;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.offline ];
+  };
+}