about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/admin/salt/default.nix13
-rw-r--r--pkgs/tools/filesystems/bcachefs-tools/default.nix28
-rw-r--r--pkgs/tools/misc/fwup/default.nix36
-rw-r--r--pkgs/tools/misc/fwup/fix-testrunner-darwin.patch25
4 files changed, 96 insertions, 6 deletions
diff --git a/pkgs/tools/admin/salt/default.nix b/pkgs/tools/admin/salt/default.nix
index f4267833b765..7fdef68f30f7 100644
--- a/pkgs/tools/admin/salt/default.nix
+++ b/pkgs/tools/admin/salt/default.nix
@@ -1,5 +1,5 @@
 {
-  stdenv, fetchurl, python2Packages, openssl,
+  stdenv, python2Packages, openssl,
 
   # Many Salt modules require various Python modules to be installed,
   # passing them in this array enables Salt to find them.
@@ -7,12 +7,13 @@
 }:
 
 python2Packages.buildPythonApplication rec {
-  name = "salt-${version}";
-  version = "2016.11.4";
+  pname = "salt";
+  version = "2016.11.5";
+  name = "${pname}-${version}";
 
-  src = fetchurl {
-    url = "mirror://pypi/s/salt/${name}.tar.gz";
-    sha256 = "0pvn0pkndwx81xkpah14awz4rg9zhkpl4bhn3hlrin1zinr0jhgv";
+  src = python2Packages.fetchPypi {
+    inherit pname version;
+    sha256 = "1gpq6s87vy782z4b5h6s7zwndcxnllbdr2wldxr9hyp4lfj2f55q";
   };
 
   propagatedBuildInputs = with python2Packages; [
diff --git a/pkgs/tools/filesystems/bcachefs-tools/default.nix b/pkgs/tools/filesystems/bcachefs-tools/default.nix
new file mode 100644
index 000000000000..42fe0b7ce342
--- /dev/null
+++ b/pkgs/tools/filesystems/bcachefs-tools/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, pkgs, fetchgit, pkgconfig, attr, libuuid, libscrypt, libsodium, keyutils, liburcu, zlib, libaio }:
+
+stdenv.mkDerivation rec {
+  name = "bcachefs-tools-unstable-2016-05-13";
+
+  src = fetchgit {
+    url = "https://evilpiepirate.org/git/bcachefs-tools.git";
+    rev = "565b4a74d6c25c78b0d2b82d9529595fc6269308";
+    sha256 = "1wnis26hq67vxqkxzck6wm6caq4c1rfmy9blmmgkzlhdd2nzisbx";
+  };
+
+  buildInputs = [ pkgconfig attr libuuid libscrypt libsodium keyutils liburcu zlib libaio ];
+
+  preConfigure = ''
+    substituteInPlace cmd_migrate.c --replace /usr/include/dirent.h ${stdenv.glibc.dev}/include/dirent.h
+  '';
+
+  installFlags = [ "PREFIX=$(out)" ];
+
+  meta = with stdenv.lib; {
+    description = "Tool for managing bcachefs filesystems";
+    homepage = "http://bcachefs.org/";
+    license = licenses.gpl2;
+    maintainers = with maintainers; [ davidak ];
+    platforms = platforms.linux;
+  };
+}
+
diff --git a/pkgs/tools/misc/fwup/default.nix b/pkgs/tools/misc/fwup/default.nix
new file mode 100644
index 000000000000..5d2b96d3261a
--- /dev/null
+++ b/pkgs/tools/misc/fwup/default.nix
@@ -0,0 +1,36 @@
+{ stdenv, lib, fetchFromGitHub, autoreconfHook, makeWrapper, pkgconfig
+, zlib, lzma, bzip2, mtools, dosfstools, zip, unzip, libconfuse, libsodium
+, libarchive, darwin, coreutils }:
+
+stdenv.mkDerivation rec {
+  name = "fwup-${version}";
+  version = "0.14.2";
+
+  src = fetchFromGitHub {
+    owner = "fhunleth";
+    repo = "fwup";
+    rev = "v${version}";
+    sha256 = "0ddyiprq4qnqpdhh48bivl8c5yrh21p4r99qs0d1rjiwx5h9p21l";
+  };
+
+  doCheck = true;
+  patches = lib.optional stdenv.isDarwin [ ./fix-testrunner-darwin.patch ];
+
+  nativeBuildInputs = [ pkgconfig autoreconfHook makeWrapper ];
+  buildInputs = [ zlib lzma bzip2 libconfuse libsodium libarchive ]
+    ++ lib.optionals stdenv.isDarwin [
+      darwin.apple_sdk.frameworks.DiskArbitration
+    ];
+  propagatedBuildInputs = [ zip unzip mtools dosfstools coreutils ];
+
+  # segfaults on darwin without
+  NIX_LDFLAGS = lib.optional stdenv.isDarwin "-F/System/Library/Frameworks";
+
+  meta = with stdenv.lib; {
+    description = "Configurable embedded Linux firmware update creator and runner";
+    homepage = https://github.com/fhunleth/fwup;
+    license = licenses.asl20;
+    maintainers = [ maintainers.georgewhewell ];
+    platforms = platforms.all;
+  };
+}
diff --git a/pkgs/tools/misc/fwup/fix-testrunner-darwin.patch b/pkgs/tools/misc/fwup/fix-testrunner-darwin.patch
new file mode 100644
index 000000000000..b04b436ff5b1
--- /dev/null
+++ b/pkgs/tools/misc/fwup/fix-testrunner-darwin.patch
@@ -0,0 +1,25 @@
+diff --git a/tests/common-orig.sh b/tests/common.sh
+index 1f2673f..79dcf74 100755
+--- a/tests/common-orig.sh
++++ b/tests/common.sh
+@@ -21,20 +21,6 @@ else
+ fi
+ 
+ case "$HOST_OS" in
+-    Darwin)
+-	# BSD stat
+-        STAT_FILESIZE_FLAGS="-f %z"
+-
+-	# Not -d?
+-        BASE64_DECODE=-D
+-
+-        READLINK=/usr/local/bin/greadlink
+-        [ -e $READLINK ] || ( echo "Please run 'brew install coreutils' to install greadlink"; exit 1 )
+-        [ -e /usr/local/bin/mdir ] || ( echo "Please run 'brew install mtools' to install mdir"; exit 1 )
+-
+-        FSCK_FAT=fsck_msdos
+-        TIMEOUT=gtimeout
+-        ;;
+     FreeBSD|NetBSD|OpenBSD|DragonFly)
+ 	# BSD stat
+         STAT_FILESIZE_FLAGS="-f %z"