about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/ttyplot/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/tools/misc/ttyplot/default.nix b/pkgs/tools/misc/ttyplot/default.nix
new file mode 100644
index 000000000000..9fdac0b8b9cc
--- /dev/null
+++ b/pkgs/tools/misc/ttyplot/default.nix
@@ -0,0 +1,30 @@
+{ stdenv, fetchFromGitHub, ncurses }:
+stdenv.mkDerivation rec {
+  name = "ttyplot-${version}";
+  version = "1.0";
+
+  src = fetchFromGitHub {
+    owner = "tenox7";
+    repo = "ttyplot";
+    rev = version;
+    sha256 = "1i54hw7fad42gdlrlqg7s0vhsq01yxzdi2s0r3svwbb1sr7ynzn1";
+  };
+
+  buildInputs = [ ncurses ];
+
+  buildPhase = ''
+   ${stdenv.cc}/bin/cc ./ttyplot.c -lncurses -o ttyplot
+  '';
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp ttyplot $out/bin/
+  '';
+
+  meta = with stdenv.lib; {
+    description = "a simple general purpose plotting utility for tty with data input from stdin.";
+    homepage = https://github.com/tenox7/ttyplot;
+    license = licenses.unlicense;
+    maintainers = with maintainers; [ lassulus ];
+  };
+}