about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/admin/cli53/default.nix30
-rw-r--r--pkgs/tools/archivers/unrar/default.nix4
-rw-r--r--pkgs/tools/misc/aptly/default.nix8
-rw-r--r--pkgs/tools/misc/aptly/deps.nix245
-rw-r--r--pkgs/tools/misc/coreutils/default.nix3
-rw-r--r--pkgs/tools/misc/libcpuid/default.nix19
-rw-r--r--pkgs/tools/misc/moreutils/default.nix6
-rw-r--r--pkgs/tools/networking/mtr/default.nix2
-rw-r--r--pkgs/tools/networking/openvpn/default.nix7
-rw-r--r--pkgs/tools/package-management/librepo/default.nix8
-rw-r--r--pkgs/tools/security/sudo/default.nix4
-rw-r--r--pkgs/tools/security/vulnix/requirements.nix2
-rw-r--r--pkgs/tools/system/stress/default.nix2
13 files changed, 49 insertions, 291 deletions
diff --git a/pkgs/tools/admin/cli53/default.nix b/pkgs/tools/admin/cli53/default.nix
index 4e284c461932..23c35dab57c0 100644
--- a/pkgs/tools/admin/cli53/default.nix
+++ b/pkgs/tools/admin/cli53/default.nix
@@ -1,27 +1,21 @@
-{ stdenv, buildGoPackage, fetchFromGitHub }:
+{ lib, python2Packages, fetchurl }:
 
-buildGoPackage rec {
+python2Packages.buildPythonApplication rec {
   name = "cli53-${version}";
-  version = "0.8.8";
+  version = "0.4.4";
 
-  goPackagePath = "github.com/barnybug/cli53";
-
-  src = fetchFromGitHub {
-    owner = "barnybug";
-    repo = "cli53";
-    rev = version;
-    sha256 = "1hbx64rn25qzp2xlfwv8xaqyfcax9b6pl30j9vciw7cb346i84gc";
+  src = fetchurl {
+    url = "mirror://pypi/c/cli53/${name}.tar.gz";
+    sha256 = "0s9jzigq6a16m2c3qklssx2lz16cf13g5zh80vh24kxazaxqzbig";
   };
 
-  buildPhase = ''
-    pushd go/src/${goPackagePath}/cmd/cli53
-    go get .
-    popd
-  '';
-
-  goDeps = ./deps.nix;
+  propagatedBuildInputs = with python2Packages; [
+    argparse
+    boto
+    dns
+  ];
 
-  meta = with stdenv.lib; {
+  meta = with lib; {
     description = "CLI tool for the Amazon Route 53 DNS service";
     homepage = https://github.com/barnybug/cli53;
     license = licenses.mit;
diff --git a/pkgs/tools/archivers/unrar/default.nix b/pkgs/tools/archivers/unrar/default.nix
index 0086891da299..a1454229a1c8 100644
--- a/pkgs/tools/archivers/unrar/default.nix
+++ b/pkgs/tools/archivers/unrar/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   name = "unrar-${version}";
-  version = "5.4.5";
+  version = "5.5.5";
 
   src = fetchurl {
     url = "http://www.rarlab.com/rar/unrarsrc-${version}.tar.gz";
-    sha256 = "0v3rz2245bp2nh4115ysqv34vqlrpln9y11fnlzqj8i46f2caw74";
+    sha256 = "1vv1s1pa0pf1r0h7dw89ha9y68x7hdm82csnkh6ms0igrcwkhmd4";
   };
 
   postPatch = ''
diff --git a/pkgs/tools/misc/aptly/default.nix b/pkgs/tools/misc/aptly/default.nix
index ccb13f2e42ca..2398d9019dc3 100644
--- a/pkgs/tools/misc/aptly/default.nix
+++ b/pkgs/tools/misc/aptly/default.nix
@@ -2,21 +2,21 @@
 
 let
 
-  version = "0.9.7";
+  version = "1.0.1";
   rev = "v${version}";
 
   aptlySrc = fetchFromGitHub {
     inherit rev;
     owner = "smira";
     repo = "aptly";
-    sha256 = "0j1bmqdah4i83r2cf8zcq87aif1qg90yasgf82yygk3hj0gw1h00";
+    sha256 = "0rqxdhy2mlwndxhqb447gz626q92zd09rpvhysr2g1rx9nxa039p";
   };
 
   aptlyCompletionSrc = fetchFromGitHub {
     rev = version;
     owner = "aptly-dev";
     repo = "aptly-bash-completion";
-    sha256 = "1yz3pr2jfczqv81as2q3cizwywj5ksw76vi15xlbx5njkjp4rbm4";
+    sha256 = "0dkc4z687yk912lpv8rirv0nby7iny1zgdvnhdm5b47qmjr1sm5q";
   };
 
 in
@@ -27,12 +27,10 @@ buildGoPackage {
   src = aptlySrc;
 
   goPackagePath = "github.com/smira/aptly";
-  goDeps = ./deps.nix;
 
   nativeBuildInputs = [ makeWrapper ];
 
   postInstall = ''
-    rm $bin/bin/man
     mkdir -p $bin/share/bash-completion/completions
     ln -s ${aptlyCompletionSrc}/aptly $bin/share/bash-completion/completions
     wrapProgram "$bin/bin/aptly" \
diff --git a/pkgs/tools/misc/aptly/deps.nix b/pkgs/tools/misc/aptly/deps.nix
deleted file mode 100644
index f0163f34ae8b..000000000000
--- a/pkgs/tools/misc/aptly/deps.nix
+++ /dev/null
@@ -1,245 +0,0 @@
-[
-    {
-      goPackagePath = "github.com/AlekSi/pointer";
-      fetch = {
-        type = "git";
-        url = https://github.com/AlekSi/pointer.git;
-        rev = "5f6d527dae3d678b46fbb20331ddf44e2b841943";
-        sha256 = "127n71d8y1d8hxv9fq9z1midw3vk5xa6aq45gffjvwabx4cgha1l";
-      };
-    }
-    {
-      goPackagePath = "github.com/awalterschulze/gographviz";
-      fetch = {
-        type = "git";
-        url = https://github.com/awalterschulze/gographviz.git;
-        rev = "20d1f693416d9be045340150094aa42035a41c9e";
-        sha256 = "1q4796nzanikqmz77jdc2xrq30n93w6ljcfsbhij3yj3s698bcaf";
-      };
-    }
-    {
-      goPackagePath = "github.com/aws/aws-sdk-go";
-      fetch = {
-        type = "git";
-        url = https://github.com/aws/aws-sdk-go.git;
-        rev = "a170e9cb76475a0da7c0326a13cc2b39e9244b3b";
-        sha256 = "0z7pgb9q0msvdkrvjwi95cbl9k9w8f3n2liwkl6fli0nx9jyamqw";
-      };
-    }
-    {
-      goPackagePath = "github.com/cheggaaa/pb";
-      fetch = {
-        type = "git";
-        url = https://github.com/cheggaaa/pb.git;
-        rev = "2c1b74620cc58a81ac152ee2d322e28c806d81ed";
-        sha256 = "148fv6a0ranzcc1lv4v5lmvgbfx05dhzpwsg8vxi9ggn51n496ny";
-      };
-    }
-    {
-      goPackagePath = "github.com/DisposaBoy/JsonConfigReader";
-      fetch = {
-        type = "git";
-        url = https://github.com/DisposaBoy/JsonConfigReader.git;
-        rev = "33a99fdf1d5ee1f79b5077e9c06f955ad356d5f4";
-        sha256 = "1rq7hp1xk8lzvn9bv9jfkszw8p2qia8prvrx540gb2y93jw9i847";
-      };
-    }
-    {
-      goPackagePath = "github.com/gin-gonic/gin";
-      fetch = {
-        type = "git";
-        url = https://github.com/gin-gonic/gin.git;
-        rev = "b1758d3bfa09e61ddbc1c9a627e936eec6a170de";
-        sha256 = "0y3v5vi68xafcvz9yz6ffww96xs2qalklnaab7vrwpax3brlkipk";
-      };
-    }
-    {
-      goPackagePath = "github.com/go-ini/ini";
-      fetch = {
-        type = "git";
-        url = https://github.com/go-ini/ini.git;
-        rev = "afbd495e5aaea13597b5e14fe514ddeaa4d76fc3";
-        sha256 = "0xi8zr9qw38sdbv95c2ip31yczbm4axdvmj3ljyivn9xh2nbxfia";
-      };
-    }
-    {
-      goPackagePath = "github.com/jlaffaye/ftp";
-      fetch = {
-        type = "git";
-        url = https://github.com/jlaffaye/ftp.git;
-        rev = "fec71e62e457557fbe85cefc847a048d57815d76";
-        sha256 = "08ivzsfswgl4xlr6wmqpbf77jclh8ivhwxlhj59allp27lic1kgm";
-      };
-    }
-    {
-      goPackagePath = "github.com/jmespath/go-jmespath";
-      fetch = {
-        type = "git";
-        url = https://github.com/jmespath/go-jmespath.git;
-        rev = "0b12d6b521d83fc7f755e7cfc1b1fbdd35a01a74";
-        sha256 = "1vv6hph8j6xgv7gwl9vvhlsaaqsm22sxxqmgmldi4v11783pc1ld";
-      };
-    }
-    {
-      goPackagePath = "github.com/julienschmidt/httprouter";
-      fetch = {
-        type = "git";
-        url = https://github.com/julienschmidt/httprouter.git;
-        rev = "46807412fe50aaceb73bb57061c2230fd26a1640";
-        sha256 = "0mvzjpzlb1gkb6lp0nwni3vid6fw33dkzl6s9gj7gp2wsbwzcdhd";
-      };
-    }
-    {
-      goPackagePath = "github.com/mattn/go-shellwords";
-      fetch = {
-        type = "git";
-        url = https://github.com/mattn/go-shellwords.git;
-        rev = "c7ca6f94add751566a61cf2199e1de78d4c3eee4";
-        sha256 = "1714ca0p0mwijck0vxdssizxyjjjki1dpc5bl51ayw5sa7s6d4n2";
-      };
-    }
-    {
-      goPackagePath = "github.com/mkrautz/goar";
-      fetch = {
-        type = "git";
-        url = https://github.com/mkrautz/goar.git;
-        rev = "282caa8bd9daba480b51f1d5a988714913b97aad";
-        sha256 = "0b6nmgyh5lmm8d1psm5yqqmshkqi87di1191c9q95z1gkkfi16b2";
-      };
-    }
-    {
-      goPackagePath = "github.com/mxk/go-flowrate";
-      fetch = {
-        type = "git";
-        url = https://github.com/mxk/go-flowrate.git;
-        rev = "cca7078d478f8520f85629ad7c68962d31ed7682";
-        sha256 = "0zqs39923ja0yypdmiqk6x8pgmfs3ms5x5sl1dqv9z6zyx2xy541";
-      };
-    }
-    {
-      goPackagePath = "github.com/ncw/swift";
-      fetch = {
-        type = "git";
-        url = https://github.com/ncw/swift.git;
-        rev = "384ef27c70645e285f8bb9d02276bf654d06027e";
-        sha256 = "1is9z6pbn55yr5b7iizfyi8y19nc9xprd87cwab4i54bxkqqp5hg";
-      };
-    }
-    {
-      goPackagePath = "github.com/smira/go-aws-auth";
-      fetch = {
-        type = "git";
-        url = https://github.com/smira/go-aws-auth.git;
-        rev = "0070896e9d7f4f9f2d558532b2d896ce2239992a";
-        sha256 = "0ic7fgpgr8n1gvhwab1isbm82azy8kb9bzjxsch5i2dpvnz03rvh";
-      };
-    }
-    {
-      goPackagePath = "github.com/smira/go-xz";
-      fetch = {
-        type = "git";
-        url = https://github.com/smira/go-xz.git;
-        rev = "0c531f070014e218b21f3cfca801cc992d52726d";
-        sha256 = "1wpgw8y6xjyf75dfcirx58cr1c277avdb6hr7xvcddhcfn01qzma";
-      };
-    }
-    {
-      goPackagePath = "github.com/smira/commander";
-      fetch = {
-        type = "git";
-        url = https://github.com/smira/commander.git;
-        rev = "f408b00e68d5d6e21b9f18bd310978dafc604e47";
-        sha256 = "0gzhxjni17qq0z4zhakjrp98qd0qmf6wlyrx5xwwsqgh07nyzssa";
-      };
-    }
-    {
-      goPackagePath = "github.com/smira/flag";
-      fetch = {
-        type = "git";
-        url = https://github.com/smira/flag.git;
-        rev = "357ed3e599ffcbd4aeaa828e1d10da2df3ea5107";
-        sha256 = "0wh77lz7z23rs9mbyi89l28i16gp1zx2312zxs4ngqdvjvinsiri";
-      };
-    }
-    {
-      goPackagePath = "github.com/smira/go-ftp-protocol";
-      fetch = {
-        type = "git";
-        url = https://github.com/smira/go-ftp-protocol.git;
-        rev = "066b75c2b70dca7ae10b1b88b47534a3c31ccfaa";
-        sha256 = "1az9p44fa7bcw92ywcyrqch2j1781b96rpid2qggyp3nhjivx8rx";
-      };
-    }
-    {
-      goPackagePath = "github.com/smira/go-uuid";
-      fetch = {
-        type = "git";
-        url = https://github.com/smira/go-uuid.git;
-        rev = "ed3ca8a15a931b141440a7e98e4f716eec255f7d";
-        sha256 = "1vasidfa2pqrawk4zm5bqsi5q7f3qx3xm159hs36r0h0kj0c7sz4";
-      };
-    }
-    {
-      goPackagePath = "github.com/smira/lzma";
-      fetch = {
-        type = "git";
-        url = https://github.com/smira/lzma.git;
-        rev = "7f0af6269940baa2c938fabe73e0d7ba41205683";
-        sha256 = "0ka8mbyg2dj076aslbi1hiahw5n5gjyn7s4w3x4ws9ak5chw5zif";
-      };
-    }
-    {
-      goPackagePath = "github.com/golang/snappy";
-      fetch = {
-        type = "git";
-        url = https://github.com/golang/snappy.git;
-        rev = "723cc1e459b8eea2dea4583200fd60757d40097a";
-        sha256 = "0bprq0qb46f5511b5scrdqqzskqqi2z8b4yh3216rv0n1crx536h";
-      };
-    }
-    {
-      goPackagePath = "github.com/syndtr/goleveldb";
-      fetch = {
-        type = "git";
-        url = https://github.com/syndtr/goleveldb.git;
-        rev = "917f41c560270110ceb73c5b38be2a9127387071";
-        sha256 = "0ybpcizg2gn3ln9rycqbaqlclci3k2q8mipcwq7927ym113d7q32";
-      };
-    }
-    {
-      goPackagePath = "github.com/ugorji/go";
-      fetch = {
-        type = "git";
-        url = https://github.com/ugorji/go.git;
-        rev = "71c2886f5a673a35f909803f38ece5810165097b";
-        sha256 = "157f24xnkhclrjwwa1b7lmpj112ynlbf7g1cfw0c657iqny5720j";
-      };
-    }
-    {
-      goPackagePath = "github.com/vaughan0/go-ini";
-      fetch = {
-        type = "git";
-        url = https://github.com/vaughan0/go-ini.git;
-        rev = "a98ad7ee00ec53921f08832bc06ecf7fd600e6a1";
-        sha256 = "1l1isi3czis009d9k5awsj4xdxgbxn4n9yqjc1ac7f724x6jacfa";
-      };
-    }
-    {
-      goPackagePath = "github.com/wsxiaoys/terminal";
-      fetch = {
-        type = "git";
-        url = https://github.com/wsxiaoys/terminal.git;
-        rev = "5668e431776a7957528361f90ce828266c69ed08";
-        sha256 = "0dirblp3lwijsrx590qfp8zn5xspkjzq7ihkv05806mpncg5ivxd";
-      };
-    }
-    {
-      goPackagePath = "golang.org/x/crypto";
-      fetch = {
-        type = "git";
-        url = https://go.googlesource.com/crypto.git;
-        rev = "a7ead6ddf06233883deca151dffaef2effbf498f";
-        sha256 = "0gyvja1kh6xkxy7mg5y72zpvmi6hfix34kmzg4sry1x7bycw3dfc";
-      };
-    }
-]
diff --git a/pkgs/tools/misc/coreutils/default.nix b/pkgs/tools/misc/coreutils/default.nix
index 71fc791872f8..42f8e74df313 100644
--- a/pkgs/tools/misc/coreutils/default.nix
+++ b/pkgs/tools/misc/coreutils/default.nix
@@ -32,6 +32,9 @@ stdenv.mkDerivation rec {
     sed '2i echo Skipping cp sparse test && exit 0' -i ./tests/cp/sparse.sh
     sed '2i echo Skipping rm deep-2 test && exit 0' -i ./tests/rm/deep-2.sh
     sed '2i echo Skipping du long-from-unreadable test && exit 0' -i ./tests/du/long-from-unreadable.sh
+    sed '2i echo Skipping chmod setgid test && exit 0' -i ./tests/chmod/setgid.sh
+    substituteInPlace ./tests/install/install-C.sh \
+      --replace 'mode3=2755' 'mode3=1755'
   '';
 
   outputs = [ "out" "info" ];
diff --git a/pkgs/tools/misc/libcpuid/default.nix b/pkgs/tools/misc/libcpuid/default.nix
index e26533d46429..410ab4543123 100644
--- a/pkgs/tools/misc/libcpuid/default.nix
+++ b/pkgs/tools/misc/libcpuid/default.nix
@@ -1,5 +1,5 @@
 { stdenv
-, fetchgit
+, fetchFromGitHub
 , libtool
 , automake
 , autoconf
@@ -7,18 +7,19 @@
 }:
 stdenv.mkDerivation rec {
   name = "libcpuid-${version}";
-  version = "0.2.2";
+  version = "0.4.0";
 
-  src = fetchgit {
-    url = https://github.com/anrieff/libcpuid.git;
-    rev = "535ec64dd9d8df4c5a8d34b985280b58a5396fcf";
-    sha256 = "1j9pg7fyvqhr859k5yh8ccl9jjx65c7rrsddji83qmqyg0vp1k1a";
+  src = fetchFromGitHub {
+    owner = "anrieff";
+    repo = "libcpuid";
+    rev = "v${version}";
+    sha256 = "136kv6m666f7s18mim0vdbzqvs4s0wvixa12brj9p3kmfbx48bw7";
   };
 
   patchPhase = ''
     libtoolize
     autoreconf --install
- '';
+  '';
 
   configurePhase = ''
     mkdir -p Install
@@ -45,12 +46,12 @@ stdenv.mkDerivation rec {
 
     mkdir -p $out
     sed -i -re "s#(prefix=).*Install#\1$out#g" Install/lib/pkgconfig/libcpuid.pc
- 
+
     cp -r Install/* $out
     cp -r tests $out
   '';
 
-  buildInputs = [
+  nativeBuildInputs = [
     libtool
     automake
     autoconf
diff --git a/pkgs/tools/misc/moreutils/default.nix b/pkgs/tools/misc/moreutils/default.nix
index 51ac3249fed8..dbb80067e6db 100644
--- a/pkgs/tools/misc/moreutils/default.nix
+++ b/pkgs/tools/misc/moreutils/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchgit, libxml2, libxslt, docbook-xsl, docbook_xml_dtd_44, perl, IPCRun, TimeDate, TimeDuration, makeWrapper }:
+{ stdenv, fetchgit, libxml2, libxslt, docbook-xsl, docbook_xml_dtd_44, perl, IPCRun, TimeDate, TimeDuration, makeWrapper, darwin }:
 
 with stdenv.lib;
 stdenv.mkDerivation rec {
@@ -15,10 +15,12 @@ stdenv.mkDerivation rec {
     substituteInPlace Makefile --replace /usr/share/xml/docbook/stylesheet/docbook-xsl ${docbook-xsl}/xml/xsl/docbook
   '';
 
-  buildInputs = [ libxml2 libxslt docbook-xsl docbook_xml_dtd_44 makeWrapper ];
+  buildInputs = [ libxml2 libxslt docbook-xsl docbook_xml_dtd_44 makeWrapper ]
+    ++ optional stdenv.isDarwin darwin.cctools;
 
   propagatedBuildInputs = [ perl IPCRun TimeDate TimeDuration ];
 
+  buildFlags = "CC=cc";
   installFlags = "PREFIX=$(out)";
 
   postInstall = "wrapProgram $out/bin/chronic --prefix PERL5LIB : $PERL5LIB";
diff --git a/pkgs/tools/networking/mtr/default.nix b/pkgs/tools/networking/mtr/default.nix
index 666bb4942a9f..03a0c99c4213 100644
--- a/pkgs/tools/networking/mtr/default.nix
+++ b/pkgs/tools/networking/mtr/default.nix
@@ -14,6 +14,8 @@ stdenv.mkDerivation rec {
     sha256 = "17zi99n8bdqrwrnbfyjn327jz4gxx287wrq3vk459c933p34ff8r";
   };
 
+  preConfigure = "substituteInPlace Makefile.in --replace ' install-exec-hook' ''";
+
   configureFlags = optionalString (!withGtk) "--without-gtk";
 
   nativeBuildInputs = [ autoreconfHook pkgconfig ];
diff --git a/pkgs/tools/networking/openvpn/default.nix b/pkgs/tools/networking/openvpn/default.nix
index f2741e2b7243..78f21e78277d 100644
--- a/pkgs/tools/networking/openvpn/default.nix
+++ b/pkgs/tools/networking/openvpn/default.nix
@@ -8,14 +8,15 @@ with stdenv.lib;
 
 stdenv.mkDerivation rec {
   name = "openvpn-${version}";
-  version = "2.4.2";
+  version = "2.4.3";
 
   src = fetchurl {
     url = "http://swupdate.openvpn.net/community/releases/${name}.tar.xz";
-    sha256 = "1ydzy5i7yaifz0v1ivrckksvm0nkkx5sia3g5y5b1xkx9cw4yp6z";
+    sha256 = "0w85915nvdws1n1zsn8zcy9wg23jsx782nvrx1a3x4mqlmkn3a3s";
   };
 
-  buildInputs = [ lzo openssl pkgconfig ]
+  nativeBuildInputs = [ pkgconfig ];
+  buildInputs = [ lzo openssl ]
                   ++ optionals stdenv.isLinux [ pam systemd iproute ]
                   ++ optional pkcs11Support pkcs11helper;
 
diff --git a/pkgs/tools/package-management/librepo/default.nix b/pkgs/tools/package-management/librepo/default.nix
index 4b9b593655b7..99a5013e217e 100644
--- a/pkgs/tools/package-management/librepo/default.nix
+++ b/pkgs/tools/package-management/librepo/default.nix
@@ -1,14 +1,14 @@
 { stdenv, fetchFromGitHub, cmake, python2, pkgconfig, expat, glib, pcre, openssl, curl, check, attr, gpgme }:
 
 stdenv.mkDerivation rec {
-  version = "1.7.18";
+  version = "1.7.20";
   name = "librepo-${version}";
 
   src = fetchFromGitHub {
     owner  = "rpm-software-management";
     repo   = "librepo";
     rev    = name;
-    sha256 = "05iqx2kvfqsskb2r3n5p8f91i4gd4pbw6nh30pn532mgab64cvxk";
+    sha256 = "17fgj2wifn2qxmh1p285fbwys0xbvwbnmxsdfvqyr5njpyl2s99h";
   };
 
   patchPhase = ''
@@ -16,7 +16,9 @@ stdenv.mkDerivation rec {
       --replace ' ''${PYTHON_INSTALL_DIR}' " $out/lib/python2.7/site-packages"
   '';
 
-  buildInputs = [ cmake python2 pkgconfig expat glib pcre openssl curl check attr gpgme ];
+  nativeBuildInputs = [ cmake pkgconfig ];
+
+  buildInputs = [ python2 expat glib pcre openssl curl check attr gpgme ];
 
   # librepo/fastestmirror.h includes curl/curl.h, and pkg-config specfile refers to others in here
   propagatedBuildInputs = [ curl gpgme expat ];
diff --git a/pkgs/tools/security/sudo/default.nix b/pkgs/tools/security/sudo/default.nix
index 840d24f6e67d..6f662206350f 100644
--- a/pkgs/tools/security/sudo/default.nix
+++ b/pkgs/tools/security/sudo/default.nix
@@ -4,14 +4,14 @@
 }:
 
 stdenv.mkDerivation rec {
-  name = "sudo-1.8.20p1";
+  name = "sudo-1.8.20p2";
 
   src = fetchurl {
     urls =
       [ "ftp://ftp.sudo.ws/pub/sudo/${name}.tar.gz"
         "ftp://ftp.sudo.ws/pub/sudo/OLD/${name}.tar.gz"
       ];
-    sha256 = "07fvh8qy0l1h93lccc625f48d8yp0pkp5rjjykq13pb07ar0x64y";
+    sha256 = "1na5likm1srnd1g5sjx7b0543sczw0yppacyqsazfdg9b48awhmx";
   };
 
   prePatch = ''
diff --git a/pkgs/tools/security/vulnix/requirements.nix b/pkgs/tools/security/vulnix/requirements.nix
index c1cbf9c4d3b0..280fc2279b47 100644
--- a/pkgs/tools/security/vulnix/requirements.nix
+++ b/pkgs/tools/security/vulnix/requirements.nix
@@ -26,7 +26,7 @@ rec {
       url = "https://pypi.python.org/packages/52/b3/a96d62711a26d8cfbe546519975dc9ed54d2eb50b3238d2e6de045764796/ZConfig-3.1.0.tar.gz";
       sha256 = "c21fa3a073a56925a8098036d46717392994a92cffea1b3cda3176b70c0a842e";
     };
-    propagatedBuildInputs = [ pythonPackages.zope_testrunner ];
+    propagatedBuildInputs = with pythonPackages; [ zope_testrunner ];
     meta = with stdenv.lib; {
       homepage = "";
       license = licenses.zpt21;
diff --git a/pkgs/tools/system/stress/default.nix b/pkgs/tools/system/stress/default.nix
index 52cfd4dde74e..5a4734328ff9 100644
--- a/pkgs/tools/system/stress/default.nix
+++ b/pkgs/tools/system/stress/default.nix
@@ -11,6 +11,6 @@ stdenv.mkDerivation rec {
   meta = with stdenv.lib; {
     description = "Simple workload generator for POSIX systems. It imposes a configurable amount of CPU, memory, I/O, and disk stress on the system";
     license = licenses.gpl2;
-    platforms = platforms.linux;
+    platforms = platforms.unix;
   };
 }