about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/backup/bup/default.nix2
-rw-r--r--pkgs/tools/filesystems/bcachefs-tools/default.nix28
-rw-r--r--pkgs/tools/networking/tcpreplay/default.nix31
-rw-r--r--pkgs/tools/security/keybase-gui/default.nix4
4 files changed, 62 insertions, 3 deletions
diff --git a/pkgs/tools/backup/bup/default.nix b/pkgs/tools/backup/bup/default.nix
index 0d60930b1fb4..ae8752aa7c12 100644
--- a/pkgs/tools/backup/bup/default.nix
+++ b/pkgs/tools/backup/bup/default.nix
@@ -58,7 +58,7 @@ stdenv.mkDerivation rec {
       Capable of doing *fast* incremental backups of virtual machine images.
     '';
 
-    platforms = platforms.linux;
+    platforms = platforms.linux ++ platforms.darwin;
     maintainers = with maintainers; [ muflax ];
   };
 }
diff --git a/pkgs/tools/filesystems/bcachefs-tools/default.nix b/pkgs/tools/filesystems/bcachefs-tools/default.nix
new file mode 100644
index 000000000000..42fe0b7ce342
--- /dev/null
+++ b/pkgs/tools/filesystems/bcachefs-tools/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, pkgs, fetchgit, pkgconfig, attr, libuuid, libscrypt, libsodium, keyutils, liburcu, zlib, libaio }:
+
+stdenv.mkDerivation rec {
+  name = "bcachefs-tools-unstable-2016-05-13";
+
+  src = fetchgit {
+    url = "https://evilpiepirate.org/git/bcachefs-tools.git";
+    rev = "565b4a74d6c25c78b0d2b82d9529595fc6269308";
+    sha256 = "1wnis26hq67vxqkxzck6wm6caq4c1rfmy9blmmgkzlhdd2nzisbx";
+  };
+
+  buildInputs = [ pkgconfig attr libuuid libscrypt libsodium keyutils liburcu zlib libaio ];
+
+  preConfigure = ''
+    substituteInPlace cmd_migrate.c --replace /usr/include/dirent.h ${stdenv.glibc.dev}/include/dirent.h
+  '';
+
+  installFlags = [ "PREFIX=$(out)" ];
+
+  meta = with stdenv.lib; {
+    description = "Tool for managing bcachefs filesystems";
+    homepage = "http://bcachefs.org/";
+    license = licenses.gpl2;
+    maintainers = with maintainers; [ davidak ];
+    platforms = platforms.linux;
+  };
+}
+
diff --git a/pkgs/tools/networking/tcpreplay/default.nix b/pkgs/tools/networking/tcpreplay/default.nix
new file mode 100644
index 000000000000..236faa067ade
--- /dev/null
+++ b/pkgs/tools/networking/tcpreplay/default.nix
@@ -0,0 +1,31 @@
+{ stdenv, fetchurl, libpcap, tcpdump }:
+
+stdenv.mkDerivation rec {
+  name = "tcpreplay-${version}";
+  version = "4.2.5";
+
+  src = fetchurl {
+    url = "https://github.com/appneta/tcpreplay/releases/download/v${version}/tcpreplay-${version}.tar.gz";
+    sha256 = "1mw9r97blczm70rjf7p83sd1fxpzdzfvsbnjsc0m3nz16jz2c44l";
+  };
+
+  buildInputs = [ libpcap ];
+
+  configureFlags = [
+    "--disable-local-libopts"
+    "--disable-libopts-install"
+    "--enable-dynamic-link"
+    "--enable-shared"
+    "--enable-tcpreplay-edit"
+    "--with-libpcap=${libpcap}"
+    "--with-tcpdump=${tcpdump}/bin"
+  ];
+
+  meta = with stdenv.lib; {
+    description = "A suite of utilities for editing and replaying network traffic";
+    homepage = http://tcpreplay.appneta.com/;
+    license = with licenses; [ bsd3 gpl3 ];
+    maintainers = with maintainers; [ eleanor ];
+    platforms = platforms.linux;
+  };
+}
diff --git a/pkgs/tools/security/keybase-gui/default.nix b/pkgs/tools/security/keybase-gui/default.nix
index b1d8181da65b..636b955ddfc2 100644
--- a/pkgs/tools/security/keybase-gui/default.nix
+++ b/pkgs/tools/security/keybase-gui/default.nix
@@ -36,10 +36,10 @@ let
 in
 stdenv.mkDerivation rec {
   name = "keybase-gui-${version}";
-  version = "1.0.18-20170209170023.17b641d";
+  version = "1.0.23-20170519175207.d6c5e9e";
   src = fetchurl {
     url = "https://s3.amazonaws.com/prerelease.keybase.io/linux_binaries/deb/keybase_${version}_amd64.deb";
-    sha256 = "01mr6hyzs208g3ankl4swikna66n85xzn7ig4k7p6hxmnnvplgb3";
+    sha256 = "14nylwpd64ngx1kdb4pk2laghslx9872fb2a9jgkbgbgnan5nkmm";
   };
   phases = ["unpackPhase" "installPhase" "fixupPhase"];
   unpackPhase = ''