summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/hid-listen/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/tools/misc/hid-listen/default.nix b/pkgs/tools/misc/hid-listen/default.nix
new file mode 100644
index 000000000000..0695fb915e96
--- /dev/null
+++ b/pkgs/tools/misc/hid-listen/default.nix
@@ -0,0 +1,24 @@
+{ stdenv, fetchzip }:
+stdenv.mkDerivation rec {
+  name = "hid-listen";
+  version = "1.01";
+
+  src = fetchzip {
+    name = "hid_listen_${version}";
+    url = "https://www.pjrc.com/teensy/hid_listen_${version}.zip";
+    sha256 = "0sd4dvi39fl4vy880mg531ryks5zglfz5mdyyqr7x6qv056ffx9w";
+  };
+
+  installPhase = ''
+    mkdir -p $out/bin
+    mv ./hid_listen $out/bin/$hid_listen
+  '';
+
+  meta = with stdenv.lib; {
+    description = "A tool thats prints debugging information from usb HID devices";
+    homepage = https://www.pjrc.com/teensy/hid_listen.html;
+    license = licenses.gpl3;
+    maintainers = with maintainers; [ tomsmeets ];
+    platforms = platforms.all;
+  };
+}