summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/t1utils/default.nix28
-rw-r--r--pkgs/tools/package-management/nix-prefetch-scripts/default.nix33
-rw-r--r--pkgs/tools/security/pass/default.nix8
-rw-r--r--pkgs/tools/system/ansible/default.nix37
4 files changed, 104 insertions, 2 deletions
diff --git a/pkgs/tools/misc/t1utils/default.nix b/pkgs/tools/misc/t1utils/default.nix
new file mode 100644
index 000000000000..607674051549
--- /dev/null
+++ b/pkgs/tools/misc/t1utils/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+  name = "t1utils-1.38";
+
+  src = fetchurl {
+    url = "http://www.lcdf.org/type/${name}.tar.gz";
+    sha256 = "1pnxpjabjyzfjrp319wsq4acxw99c8nnsaalbz7nwamj8kkim7zw";
+  };
+
+  meta = with stdenv.lib; {
+    description = "Collection of simple Type 1 font manipulation programs";
+    longDescription = ''
+      t1utils is a collection of simple type-1 font manipulation programs.
+      Together, they allow you to convert between PFA (ASCII) and PFB (binary)
+      formats, disassemble PFA or PFB files into human-readable form,
+      reassemble them into PFA or PFB format. Additionally you can extract font
+      resources from a Macintosh font file or create a Macintosh Type 1 font
+      file from a PFA or PFB font.
+    '';
+    homepage = http://www.lcdf.org/type/;
+    # README from tarball says "BSD-like" and points to non-existing LICENSE
+    # file...
+    license = "BSD-like";
+    platforms = platforms.linux;
+    maintainers = [ maintainers.bjornfor ];
+  };
+}
diff --git a/pkgs/tools/package-management/nix-prefetch-scripts/default.nix b/pkgs/tools/package-management/nix-prefetch-scripts/default.nix
new file mode 100644
index 000000000000..d7210b2f616b
--- /dev/null
+++ b/pkgs/tools/package-management/nix-prefetch-scripts/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, makeWrapper, git, subversion, mercurial, bazaar, cvs }:
+
+stdenv.mkDerivation {
+  name = "nix-prefetch-scripts";
+
+  buildInputs = [ makeWrapper ];
+
+  phases = [ "installPhase" "fixupPhase" ];
+  installPhase = ''
+    mkdir -p $out/bin
+    function copyScript {
+      local name=nix-prefetch-$1;
+      local src=$2;
+      local exe=$3/bin;
+      cp $src $out/bin/$name;
+      wrapProgram $out/bin/$name --suffix PATH : "$exe"
+    }
+
+    copyScript "hg" ${../../../build-support/fetchhg/nix-prefetch-hg} ${mercurial}
+    copyScript "git" ${../../../build-support/fetchgit/nix-prefetch-git} ${git}
+    copyScript "svn" ${../../../build-support/fetchsvn/nix-prefetch-svn} ${subversion}
+    copyScript "bzr" ${../../../build-support/fetchbzr/nix-prefetch-bzr} ${bazaar}
+    copyScript "cvs" ${../../../build-support/fetchcvs/nix-prefetch-cvs} ${cvs}
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Collection of all the nix-prefetch-* scripts which may be used to obtain source hashes";
+    maintainers = with maintainers; [ bennofs ];
+    platforms = with stdenv.lib.platforms; unix;
+    # Quicker to build than to download, I hope
+    hydraPlatforms = [];
+  };
+}
\ No newline at end of file
diff --git a/pkgs/tools/security/pass/default.nix b/pkgs/tools/security/pass/default.nix
index 505bdd2efc86..d3e2c50991a1 100644
--- a/pkgs/tools/security/pass/default.nix
+++ b/pkgs/tools/security/pass/default.nix
@@ -1,6 +1,10 @@
 { stdenv, fetchurl
 , coreutils, gnused, getopt, pwgen, git, tree, gnupg
-, makeWrapper }:
+, makeWrapper
+, withX ? false, xclip ? null
+}:
+
+assert withX -> xclip != null;
 
 stdenv.mkDerivation rec {
   version = "1.6.2";
@@ -51,6 +55,6 @@ stdenv.mkDerivation rec {
 
     # Ensure all dependencies are in PATH
     wrapProgram $out/bin/pass \
-      --prefix PATH : "${coreutils}/bin:${gnused}/bin:${getopt}/bin:${gnupg}/bin:${git}/bin:${tree}/bin:${pwgen}/bin"
+      --prefix PATH : "${coreutils}/bin:${gnused}/bin:${getopt}/bin:${gnupg}/bin:${git}/bin:${tree}/bin:${pwgen}/bin${if withX then ":${xclip}/bin" else ""}"
   '';
 }
diff --git a/pkgs/tools/system/ansible/default.nix b/pkgs/tools/system/ansible/default.nix
new file mode 100644
index 000000000000..7d96092a3ceb
--- /dev/null
+++ b/pkgs/tools/system/ansible/default.nix
@@ -0,0 +1,37 @@
+{ stdenv, fetchurl, pythonPackages, python }:
+
+pythonPackages.buildPythonPackage rec {
+  version = "1.6.1";		    
+  name = "ansible-${version}";
+  namePrefix = "";
+  
+  src = fetchurl {
+    url = "https://github.com/ansible/ansible/archive/v${version}.tar.gz";
+    sha256 = "1iz1q2h0zll4qsxk0pndc59knasw663kv53sm21q57qz7lf30q9z";
+  };
+
+  prePatch = ''
+    sed -i "s,\/usr\/share\/ansible\/,$out/share/ansible," lib/ansible/constants.py 
+  '';
+
+  doCheck = false;
+  dontStrip = true;
+  dontPatchELF = true;
+  dontPatchShebangs = true;
+
+  propagatedBuildInputs = with pythonPackages; [
+    paramiko jinja2 pyyaml httplib2 boto
+  ];
+
+  postFixup = ''
+      wrapPythonProgramsIn $out/bin "$out $pythonPath"
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = "http://www.ansible.com";
+    description = "A simple automation tool";
+    license = licenses.gpl3;
+    maintainers = [ maintainers.joamaki ];
+    platforms = platforms.linux; # Only tested on Linux
+  };
+}