summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/envsubst/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/pkgs/tools/misc/envsubst/default.nix b/pkgs/tools/misc/envsubst/default.nix
new file mode 100644
index 000000000000..86f78af25603
--- /dev/null
+++ b/pkgs/tools/misc/envsubst/default.nix
@@ -0,0 +1,22 @@
+{ lib, fetchFromGitHub, buildGoPackage }:
+
+buildGoPackage rec {
+  name = "envsubst-${version}";
+  version = "1.1.0";
+
+  goPackagePath = "github.com/a8m/envsubst";
+  src = fetchFromGitHub {
+    owner = "a8m";
+    repo = "envsubst";
+    rev = "v${version}";
+    sha256 = "1d6nipagjn40n6iw1p3r489l2km5xjd5db9gbh1vc5sxc617l7yk";
+  };
+
+  meta = with lib; {
+    description = "Environment variables substitution for Go";
+    homepage = https://github.com/a8m/envsubst;
+    license = licenses.mit;
+    platforms = platforms.all;
+    maintainers = with maintainers; [ nicknovitski ];
+  };
+}