summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/filesystems/sshfs-fuse/default.nix1
-rw-r--r--pkgs/tools/networking/sshpass/default.nix7
-rw-r--r--pkgs/tools/networking/ssmtp/default.nix1
-rw-r--r--pkgs/tools/security/sshuttle/default.nix1
4 files changed, 7 insertions, 3 deletions
diff --git a/pkgs/tools/filesystems/sshfs-fuse/default.nix b/pkgs/tools/filesystems/sshfs-fuse/default.nix
index 6d95d5ee12b5..8202328b4c4e 100644
--- a/pkgs/tools/filesystems/sshfs-fuse/default.nix
+++ b/pkgs/tools/filesystems/sshfs-fuse/default.nix
@@ -29,6 +29,7 @@ stdenv.mkDerivation rec {
     inherit (src.meta) homepage;
     description = "FUSE-based filesystem that allows remote filesystems to be mounted over SSH";
     platforms = platforms.linux;
+    license = licenses.gpl2;
     maintainers = with maintainers; [ primeos ];
   };
 }
diff --git a/pkgs/tools/networking/sshpass/default.nix b/pkgs/tools/networking/sshpass/default.nix
index aedb89ce4891..94221a359c1d 100644
--- a/pkgs/tools/networking/sshpass/default.nix
+++ b/pkgs/tools/networking/sshpass/default.nix
@@ -9,10 +9,11 @@ stdenv.mkDerivation rec {
     sha256 = "0q7fblaczb7kwbsz0gdy9267z0sllzgmf0c7z5c9mf88wv74ycn6";
   };
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = https://sourceforge.net/projects/sshpass/;
     description = "Non-interactive ssh password auth";
-    maintainers = [ stdenv.lib.maintainers.madjar ];
-    platforms = stdenv.lib.platforms.unix;
+    license = licenses.gpl2;
+    maintainers = [ maintainers.madjar ];
+    platforms = platforms.unix;
   };
 }
diff --git a/pkgs/tools/networking/ssmtp/default.nix b/pkgs/tools/networking/ssmtp/default.nix
index 031f32b53626..5f6e955f8e4d 100644
--- a/pkgs/tools/networking/ssmtp/default.nix
+++ b/pkgs/tools/networking/ssmtp/default.nix
@@ -33,6 +33,7 @@ stdenv.mkDerivation {
 
   meta = with stdenv.lib; {
     platforms = platforms.linux;
+    license = licenses.gpl2;
     maintainers = with maintainers; [ basvandijk ];
   };
 }
diff --git a/pkgs/tools/security/sshuttle/default.nix b/pkgs/tools/security/sshuttle/default.nix
index c3bf4f69a46d..ac21097a09f5 100644
--- a/pkgs/tools/security/sshuttle/default.nix
+++ b/pkgs/tools/security/sshuttle/default.nix
@@ -45,6 +45,7 @@ python3Packages.buildPythonApplication rec {
       target network (though it does require Python 2 at both ends).
       Works with Linux and Mac OS and supports DNS tunneling.
     '';
+    license = licenses.gpl2;
     maintainers = with maintainers; [ domenkozar ];
     platforms = platforms.unix;
   };