summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/X11/dex/default.nix9
-rw-r--r--pkgs/tools/admin/aws-env/default.nix26
-rw-r--r--pkgs/tools/admin/aws-env/deps.nix12
-rw-r--r--pkgs/tools/compression/lz4/default.nix4
-rw-r--r--pkgs/tools/graphics/asymptote/default.nix11
-rw-r--r--pkgs/tools/graphics/fbv/default.nix25
-rw-r--r--pkgs/tools/graphics/gnuplot/default.nix4
-rw-r--r--pkgs/tools/graphics/vips/default.nix24
-rw-r--r--pkgs/tools/inputmethods/triggerhappy/default.nix23
-rw-r--r--pkgs/tools/misc/coreutils/default.nix2
-rw-r--r--pkgs/tools/misc/systrayhelper/default.nix41
-rw-r--r--pkgs/tools/misc/systrayhelper/deps.nix102
-rw-r--r--pkgs/tools/misc/teamocil/Gemfile2
-rw-r--r--pkgs/tools/misc/teamocil/Gemfile.lock13
-rw-r--r--pkgs/tools/misc/teamocil/default.nix17
-rw-r--r--pkgs/tools/misc/teamocil/gemset.nix10
-rwxr-xr-xpkgs/tools/misc/teamocil/update10
-rw-r--r--pkgs/tools/misc/vdirsyncer/default.nix2
-rw-r--r--pkgs/tools/networking/inadyn/default.nix4
-rw-r--r--pkgs/tools/networking/netsniff-ng/default.nix4
-rw-r--r--pkgs/tools/networking/openssh/default.nix7
-rw-r--r--pkgs/tools/networking/pcapfix/default.nix4
-rw-r--r--pkgs/tools/networking/tinc/default.nix4
-rw-r--r--pkgs/tools/networking/tinc/pre.nix4
-rw-r--r--pkgs/tools/networking/unbound/default.nix4
-rw-r--r--pkgs/tools/package-management/packagekit/default.nix4
-rw-r--r--pkgs/tools/system/plan9port/builder.sh3
-rw-r--r--pkgs/tools/system/plan9port/default.nix30
-rw-r--r--pkgs/tools/system/plan9port/fontsrv.patch14
-rw-r--r--pkgs/tools/text/gnupatch/default.nix2
-rw-r--r--pkgs/tools/typesetting/scdoc/default.nix11
-rw-r--r--pkgs/tools/typesetting/tex/texlive/combine.nix13
32 files changed, 373 insertions, 72 deletions
diff --git a/pkgs/tools/X11/dex/default.nix b/pkgs/tools/X11/dex/default.nix
index fd0c0503de9f..9387c62c2a51 100644
--- a/pkgs/tools/X11/dex/default.nix
+++ b/pkgs/tools/X11/dex/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub, python3 }:
+{ stdenv, fetchFromGitHub, python3, fetchpatch }:
 
 stdenv.mkDerivation rec {
   program = "dex";
@@ -16,6 +16,13 @@ stdenv.mkDerivation rec {
   nativeBuildInputs = [ python3.pkgs.sphinx ];
   makeFlags = [ "PREFIX=$(out)" "VERSION=$(version)" ];
 
+  patches = [
+    (fetchpatch {
+      url = https://github.com/jceb/dex/commit/107358ddf5e1ca4fa56ef1a7ab161dc3b6adc45a.patch;
+      sha256 = "06dfkfzxp8199by0jc5wim8g8qw38j09dq9p6n9w4zaasla60pjq";
+    })
+  ];
+
   meta = with stdenv.lib; {
     description = "A program to generate and execute DesktopEntry files of the Application type";
     homepage = https://github.com/jceb/dex;
diff --git a/pkgs/tools/admin/aws-env/default.nix b/pkgs/tools/admin/aws-env/default.nix
new file mode 100644
index 000000000000..19f149b02274
--- /dev/null
+++ b/pkgs/tools/admin/aws-env/default.nix
@@ -0,0 +1,26 @@
+{ stdenv, buildGoPackage, fetchFromGitHub, lib }:
+
+buildGoPackage rec {
+  pname = "aws-env";
+  version = "0.4";
+  name = "${pname}-${version}";
+  rev = "v${version}";
+
+  goPackagePath = "github.com/Droplr/aws-env";
+
+  src = fetchFromGitHub {
+    owner = "Droplr";
+    repo = pname;
+    inherit rev;
+    sha256 = "0pw1qz1nn0ig90p8d8c1qcwsdz0m9w63ib07carhh86gw55425j7";
+  };
+
+  goDeps = ./deps.nix;
+
+  meta = with lib; {
+    description = "Secure way to handle environment variables in Docker and envfile with AWS Parameter Store";
+    homepage = "https://github.com/Droplr/aws-env";
+    license = licenses.mit;
+    maintainers = with maintainers; [ srhb ];
+  };
+}
diff --git a/pkgs/tools/admin/aws-env/deps.nix b/pkgs/tools/admin/aws-env/deps.nix
new file mode 100644
index 000000000000..891a6ecb5962
--- /dev/null
+++ b/pkgs/tools/admin/aws-env/deps.nix
@@ -0,0 +1,12 @@
+# This file was generated by https://github.com/kamilchm/go2nix v1.2.1
+[
+  {
+    goPackagePath = "github.com/aws/aws-sdk-go";
+    fetch = {
+      type = "git";
+      url = "https://github.com/aws/aws-sdk-go";
+      rev = "5f03c87445c9dcd6aa831a76a77170919265aa97";
+      sha256 = "146rwinw2x4r0f2pixv62b7mmhvnnfvvjmfaj6dqjxrhp0imcxdi";
+    };
+  }
+]
diff --git a/pkgs/tools/compression/lz4/default.nix b/pkgs/tools/compression/lz4/default.nix
index 7e29ee2b856a..1cd4c30a3886 100644
--- a/pkgs/tools/compression/lz4/default.nix
+++ b/pkgs/tools/compression/lz4/default.nix
@@ -2,10 +2,10 @@
 
 stdenv.mkDerivation rec {
   name = "lz4-${version}";
-  version = "1.8.2";
+  version = "1.8.3";
 
   src = fetchFromGitHub {
-    sha256 = "0xbjbjrvgzypk8dnldakir06gb8m946d064lxx0qc4ky6m8n9hn2";
+    sha256 = "0lq00yi7alr9aip6dw0flykzi8yv7z43aay177n86spn9qms7s3g";
     rev = "v${version}";
     repo = "lz4";
     owner = "lz4";
diff --git a/pkgs/tools/graphics/asymptote/default.nix b/pkgs/tools/graphics/asymptote/default.nix
index a0bf0a434471..102ffae5f9d0 100644
--- a/pkgs/tools/graphics/asymptote/default.nix
+++ b/pkgs/tools/graphics/asymptote/default.nix
@@ -1,4 +1,4 @@
-{stdenv, fetchurl
+{stdenv, fetchurl, fetchpatch
   , freeglut, ghostscriptX, imagemagick, fftw
   , boehmgc, libGLU, libGL, mesa_noglu, ncurses, readline, gsl, libsigsegv
   , python, zlib, perl, texLive, texinfo, xz
@@ -33,6 +33,15 @@ stdenv.mkDerivation {
     inherit (s) url sha256;
   };
 
+  patches = [
+    # Remove when updating from 2.47 to 2.48
+    # Compatibility with BoehmGC 7.6.8
+    (fetchpatch {
+      url = "https://github.com/vectorgraphics/asymptote/commit/38a59370dc5ac720c29e1424614a10f7384b943f.patch";
+      sha256 = "0c3d11hzxxaqh24kfw9y8zvlid54kk40rx2zajx7jwl12gga05s1";
+    })
+  ];
+
   preConfigure = ''
     export HOME="$PWD"
     patchShebangs .
diff --git a/pkgs/tools/graphics/fbv/default.nix b/pkgs/tools/graphics/fbv/default.nix
new file mode 100644
index 000000000000..c7fab1710672
--- /dev/null
+++ b/pkgs/tools/graphics/fbv/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchurl, getopt, libjpeg, libpng12, libungif }:
+
+stdenv.mkDerivation rec {
+  name = "fbv-1.0b";
+
+  src = fetchurl {
+    url = "http://s-tech.elsat.net.pl/fbv/${name}.tar.gz";
+    sha256 = "0g5b550vk11l639y8p5sx1v1i6ihgqk0x1hd0ri1bc2yzpdbjmcv";
+  };
+
+  buildInputs = [ getopt libjpeg libpng12 libungif ];
+
+  enableParallelBuilding = true;
+
+  preInstall = ''
+    mkdir -p $out/{bin,man/man1}
+  '';
+
+  meta = with stdenv.lib; {
+    description = "View pictures on a linux framebuffer device";
+    homepage = http://s-tech.elsat.net.pl/fbv/;
+    license = licenses.gpl2;
+    maintainers = with maintainers; [ peterhoeg ];
+  };
+}
diff --git a/pkgs/tools/graphics/gnuplot/default.nix b/pkgs/tools/graphics/gnuplot/default.nix
index f2be9fafc605..8de7ca3262cf 100644
--- a/pkgs/tools/graphics/gnuplot/default.nix
+++ b/pkgs/tools/graphics/gnuplot/default.nix
@@ -19,11 +19,11 @@ let
   withX = libX11 != null && !aquaterm && !stdenv.isDarwin;
 in
 stdenv.mkDerivation rec {
-  name = "gnuplot-5.2.4";
+  name = "gnuplot-5.2.5";
 
   src = fetchurl {
     url = "mirror://sourceforge/gnuplot/${name}.tar.gz";
-    sha256 = "1jvh8xmd2cvrhlsg88kxwh55wkwx31sg50v1n59slfippl0g058m";
+    sha256 = "1ajw8xcb1kg2vy8n3rhrz71knjr2yivfavv9lqqzvp1dwv6b5783";
   };
 
   nativeBuildInputs = [ makeWrapper pkgconfig texinfo ] ++ lib.optional withQt qttools;
diff --git a/pkgs/tools/graphics/vips/default.nix b/pkgs/tools/graphics/vips/default.nix
index e2688e930cf6..489442e4c2a4 100644
--- a/pkgs/tools/graphics/vips/default.nix
+++ b/pkgs/tools/graphics/vips/default.nix
@@ -1,24 +1,34 @@
-{ stdenv, fetchurl, pkgconfig, glib, libxml2, expat,
+{ stdenv, pkgconfig, glib, libxml2, expat,
   fftw, orc, lcms, imagemagick, openexr, libtiff, libjpeg, libgsf, libexif,
   ApplicationServices,
-  python27, libpng ? null
+  python27, libpng ? null,
+  fetchFromGitHub,
+  autoreconfHook,
+  gtk-doc,
+  gobjectIntrospection,
 }:
 
 stdenv.mkDerivation rec {
   name = "vips-${version}";
-  version = "8.6.5";
+  version = "8.7.0";
 
-  src = fetchurl {
-    url = "https://github.com/jcupitt/libvips/releases/download/v${version}/${name}.tar.gz";
-    sha256 = "1nymm4vzscb68aifin9q742ff64b4k4ddppq1060w8hf6h7ay0l7";
+  src = fetchFromGitHub {
+    owner = "libvips";
+    repo = "libvips";
+    rev = "v${version}";
+    sha256 = "1dwcpmpqbgb9lkajnqv50mrsn97mxbxpq6b5aya7fgfkgdnrs9sw";
   };
 
-  nativeBuildInputs = [ pkgconfig ];
+  nativeBuildInputs = [ pkgconfig autoreconfHook gtk-doc gobjectIntrospection ];
   buildInputs = [ glib libxml2 fftw orc lcms
     imagemagick openexr libtiff libjpeg
     libgsf libexif python27 libpng expat ]
     ++ stdenv.lib.optional stdenv.isDarwin ApplicationServices;
 
+  autoreconfPhase = ''
+    ./autogen.sh
+  '';
+
   meta = with stdenv.lib; {
     homepage = http://www.vips.ecs.soton.ac.uk;
     description = "Image processing system for large images";
diff --git a/pkgs/tools/inputmethods/triggerhappy/default.nix b/pkgs/tools/inputmethods/triggerhappy/default.nix
index 719d86b3a389..ec8ac8845597 100644
--- a/pkgs/tools/inputmethods/triggerhappy/default.nix
+++ b/pkgs/tools/inputmethods/triggerhappy/default.nix
@@ -1,26 +1,23 @@
-{ stdenv, fetchurl, perl }:
+{ stdenv, fetchFromGitHub, pkgconfig, perl, systemd }:
 
 stdenv.mkDerivation rec {
   name = "triggerhappy-${version}";
   version = "0.5.0";
 
-  src = fetchurl {
-    url = "https://github.com/wertarbyte/triggerhappy/archive/release/${version}.tar.gz";
-    sha256 = "af0fc196202f2d35153be401769a9ad9107b5b6387146cfa8895ae9cafad631c";
+  src = fetchFromGitHub {
+    owner = "wertarbyte";
+    repo = "triggerhappy";
+    rev = "release/${version}";
+    sha256 = "0gb1qhrxwq7i5abd408d01a2dpf28nr1fph1fg7w7n0i5i1nnk90";
   };
 
-  buildInputs = [ perl ];
-  installFlags = [ "DESTDIR=$(out)" ];  
+  nativeBuildInputs = [ pkgconfig perl ];
+  buildInputs = [ systemd ];
 
-  postPatch = ''
-    substituteInPlace Makefile --replace "/usr/" "/"
-    substituteInPlace Makefile --replace "/sbin/" "/bin/"
-  '';
+  makeFlags = [ "PREFIX=$(out)" "BINDIR=$(out)/bin" ];
 
   postInstall = ''
     install -D -m 644 -t "$out/etc/triggerhappy/triggers.d" "triggerhappy.conf.examples"
-    install -D -m 644 -t "$out/usr/lib/systemd/system" "systemd/triggerhappy.service" "systemd/triggerhappy.socket"
-    install -D -m 644 -t "$out/usr/lib/udev/rules.d" "udev/triggerhappy-udev.rules"
   '';
 
   meta = with stdenv.lib; {
@@ -34,6 +31,6 @@ stdenv.mkDerivation rec {
     homepage = https://github.com/wertarbyte/triggerhappy/;
     license = licenses.gpl3Plus;
     platforms = platforms.linux;
-    maintainers = [ maintainers.taha ];
+    maintainers = with maintainers; [ jfrankenau taha ];
   };
 }
diff --git a/pkgs/tools/misc/coreutils/default.nix b/pkgs/tools/misc/coreutils/default.nix
index 582f8d8f05f9..e94f255f7224 100644
--- a/pkgs/tools/misc/coreutils/default.nix
+++ b/pkgs/tools/misc/coreutils/default.nix
@@ -26,7 +26,7 @@ stdenv.mkDerivation rec {
   patches = optional stdenv.hostPlatform.isCygwin ./coreutils-8.23-4.cygwin.patch;
 
   # The test tends to fail on btrfs and maybe other unusual filesystems.
-  postPatch = optionalString (!stdenv.hostPlatform.isDarwin) ''
+  postPatch = ''
     sed '2i echo Skipping dd sparse test && exit 0' -i ./tests/dd/sparse.sh
     sed '2i echo Skipping cp sparse test && exit 0' -i ./tests/cp/sparse.sh
     sed '2i echo Skipping rm deep-2 test && exit 0' -i ./tests/rm/deep-2.sh
diff --git a/pkgs/tools/misc/systrayhelper/default.nix b/pkgs/tools/misc/systrayhelper/default.nix
new file mode 100644
index 000000000000..e812d6799fea
--- /dev/null
+++ b/pkgs/tools/misc/systrayhelper/default.nix
@@ -0,0 +1,41 @@
+{ stdenv, pkgconfig, libappindicator-gtk3, buildGoPackage, fetchFromGitHub }:
+
+buildGoPackage rec {
+  name = "systrayhelper-${version}";
+  version = "0.0.3";
+  rev = "0953942245566bf358ba937af840947100380e15";
+
+  goPackagePath = "github.com/ssbc/systrayhelper";
+
+  src = fetchFromGitHub {
+    inherit rev;
+    owner = "ssbc";
+    repo = "systrayhelper";
+    sha256 = "12xmzcw94in4m1hl4hbfdsbvkkaqrljgb67b95m1qwkkjak3q9g6";
+  };
+
+  goDeps = ./deps.nix;
+
+  # re date: https://github.com/NixOS/nixpkgs/pull/45997#issuecomment-418186178
+  # > .. keep the derivation deterministic. Otherwise, we would have to rebuild it every time.
+  buildFlagsArray = [ ''-ldflags=
+    -X main.version=v${version}
+    -X main.commit=${rev}
+    -X main.date="nix-byrev"
+    -s
+    -w
+  '' ];
+
+  nativeBuildInputs = [ pkgconfig libappindicator-gtk3 ];
+  buildInputs = [ libappindicator-gtk3 ];
+
+  meta = with stdenv.lib; {
+    description = "A systray utility written in go, using json over stdio for control and events";
+    homepage    = "https://github.com/ssbc/systrayhelper";
+    maintainers = with maintainers; [ cryptix ];
+    license     = licenses.mit;
+    # It depends on the inputs, i guess? not sure about solaris, for instance. go supports it though
+    # I hope nix can figure this out?! ¯\\_(ツ)_/¯
+    platforms   = platforms.all;
+  };
+}
diff --git a/pkgs/tools/misc/systrayhelper/deps.nix b/pkgs/tools/misc/systrayhelper/deps.nix
new file mode 100644
index 000000000000..67ec6662d984
--- /dev/null
+++ b/pkgs/tools/misc/systrayhelper/deps.nix
@@ -0,0 +1,102 @@
+# file generated from Gopkg.lock using dep2nix (https://github.com/nixcloud/dep2nix)
+[
+  {
+    goPackagePath  = "github.com/getlantern/context";
+    fetch = {
+      type = "git";
+      url = "https://github.com/getlantern/context";
+      rev =  "624d99b1798d7c5375ea1d3ca4c5b04d58f7c775";
+      sha256 = "09yf9x6478a5z01hybr98zwa8ax3fx7l6wwsvdkxp3fdg9dqm13b";
+    };
+  }
+  {
+    goPackagePath  = "github.com/getlantern/errors";
+    fetch = {
+      type = "git";
+      url = "https://github.com/getlantern/errors";
+      rev =  "e24b7f4ff7c70be59bbefca6b7695d68cda8b399";
+      sha256 = "1wshagslgl3r07gniq0g55cqgi1j1gk0yrri5ywjz7wm8da42qcr";
+    };
+  }
+  {
+    goPackagePath  = "github.com/getlantern/golog";
+    fetch = {
+      type = "git";
+      url = "https://github.com/getlantern/golog";
+      rev =  "cca714f7feb5df8e455f409b549d384441ac4578";
+      sha256 = "0gnf30n38zkx356cqc6jdv1kbzy59ddqhqndwrxsm2n2zc3b5p7q";
+    };
+  }
+  {
+    goPackagePath  = "github.com/getlantern/hex";
+    fetch = {
+      type = "git";
+      url = "https://github.com/getlantern/hex";
+      rev =  "083fba3033ad473db3dd31c9bb368473d37581a7";
+      sha256 = "18q6rypmcqmcwlfzrrdcz08nff0a289saplvd9y3ifnfcqdw3j77";
+    };
+  }
+  {
+    goPackagePath  = "github.com/getlantern/hidden";
+    fetch = {
+      type = "git";
+      url = "https://github.com/getlantern/hidden";
+      rev =  "d52a649ab33af200943bb599898dbdcfdbc94cb7";
+      sha256 = "0133qmp4sjq8da5di3459vc5g5nqbpqra0f558zd95js3fdmkmsi";
+    };
+  }
+  {
+    goPackagePath  = "github.com/getlantern/ops";
+    fetch = {
+      type = "git";
+      url = "https://github.com/getlantern/ops";
+      rev =  "37353306c90844c8e0591956f56611f46299d202";
+      sha256 = "0q8j2963jqf3p7fcnsfinkvz71mfylrkk2xjar775zjx5a23sa5i";
+    };
+  }
+  {
+    goPackagePath  = "github.com/getlantern/systray";
+    fetch = {
+      type = "git";
+      url = "https://github.com/getlantern/systray";
+      rev =  "3fd1443dac5c8297999189fe28d5836b2b075b66";
+      sha256 = "1sb11n27zy8xmq0lvrpqikb53425jvwl5617cp201va6iwk1hgnh";
+    };
+  }
+  {
+    goPackagePath  = "github.com/go-stack/stack";
+    fetch = {
+      type = "git";
+      url = "https://github.com/go-stack/stack";
+      rev =  "2fee6af1a9795aafbe0253a0cfbdf668e1fb8a9a";
+      sha256 = "0wk25751ryyvxclyp8jdk5c3ar0cmfr8lrjb66qbg4808x66b96v";
+    };
+  }
+  {
+    goPackagePath  = "github.com/oxtoacart/bpool";
+    fetch = {
+      type = "git";
+      url = "https://github.com/oxtoacart/bpool";
+      rev =  "4e1c5567d7c2dd59fa4c7c83d34c2f3528b025d6";
+      sha256 = "01kk6dhkz96yhp3p5v2rjwq8mbrwrdsn6glqw7jp4h7g5za7yi95";
+    };
+  }
+  {
+    goPackagePath  = "github.com/pkg/errors";
+    fetch = {
+      type = "git";
+      url = "https://github.com/pkg/errors";
+      rev =  "c059e472caf75dbe73903f6521a20abac245b17f";
+      sha256 = "07xg8ym776j2w0k8445ii82lx8yz358cp1z96r739y13i1anqdzi";
+    };
+  }
+  {
+    goPackagePath  = "golang.org/x/sys";
+    fetch = {
+      type = "git";
+      url = "https://go.googlesource.com/sys";
+      rev =  "d0be0721c37eeb5299f245a996a483160fc36940";
+      sha256 = "081wyvfnlf842dqg03raxfz6lldlxpmyh1prix9lmrrm65arxb12";
+    };
+  }
+]
diff --git a/pkgs/tools/misc/teamocil/Gemfile b/pkgs/tools/misc/teamocil/Gemfile
new file mode 100644
index 000000000000..046ba3d536e0
--- /dev/null
+++ b/pkgs/tools/misc/teamocil/Gemfile
@@ -0,0 +1,2 @@
+source 'https://rubygems.org'
+gem 'teamocil'
diff --git a/pkgs/tools/misc/teamocil/Gemfile.lock b/pkgs/tools/misc/teamocil/Gemfile.lock
new file mode 100644
index 000000000000..419c2ae49d31
--- /dev/null
+++ b/pkgs/tools/misc/teamocil/Gemfile.lock
@@ -0,0 +1,13 @@
+GEM
+  remote: https://rubygems.org/
+  specs:
+    teamocil (1.4.2)
+
+PLATFORMS
+  ruby
+
+DEPENDENCIES
+  teamocil
+
+BUNDLED WITH
+   1.16.3
diff --git a/pkgs/tools/misc/teamocil/default.nix b/pkgs/tools/misc/teamocil/default.nix
new file mode 100644
index 000000000000..2215e4d4fee7
--- /dev/null
+++ b/pkgs/tools/misc/teamocil/default.nix
@@ -0,0 +1,17 @@
+{ lib, bundlerEnv, ruby }:
+
+bundlerEnv rec {
+  inherit ruby;
+  pname = "teamocil";
+  gemdir = ./.;
+
+  meta = with lib; {
+    description     = "A simple tool used to automatically create windows and panes in tmux with YAML files";
+    homepage        = https://github.com/remiprev/teamocil;
+    license         = licenses.mit;
+    platforms       = platforms.all;
+    maintainers     = with maintainers; [
+      zachcoyle 
+    ];
+  };
+}
diff --git a/pkgs/tools/misc/teamocil/gemset.nix b/pkgs/tools/misc/teamocil/gemset.nix
new file mode 100644
index 000000000000..f363d62b6d68
--- /dev/null
+++ b/pkgs/tools/misc/teamocil/gemset.nix
@@ -0,0 +1,10 @@
+{
+  teamocil = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "1l5f33faipb45xx7ds67s7dqgvjlljlcxgpgig4pg8p002vg06r2";
+      type = "gem";
+    };
+    version = "1.4.2";
+  };
+}
\ No newline at end of file
diff --git a/pkgs/tools/misc/teamocil/update b/pkgs/tools/misc/teamocil/update
new file mode 100755
index 000000000000..58a7bd4a4539
--- /dev/null
+++ b/pkgs/tools/misc/teamocil/update
@@ -0,0 +1,10 @@
+#!/usr/bin/env nix-shell
+#! nix-shell -i bash -p bash ruby bundler bundix
+
+rm Gemfile.lock
+bundler install
+bundix
+
+if [ "clean" == "$1" ]; then
+  rm -rf ~/.gem
+fi
diff --git a/pkgs/tools/misc/vdirsyncer/default.nix b/pkgs/tools/misc/vdirsyncer/default.nix
index 0655264cc542..c273ef879682 100644
--- a/pkgs/tools/misc/vdirsyncer/default.nix
+++ b/pkgs/tools/misc/vdirsyncer/default.nix
@@ -41,7 +41,7 @@ in pythonPackages.buildPythonApplication rec {
 
   preBuild = ''
     mkdir -p rust/target/release
-    ln -s ${native}/bin/libvdirsyncer_rustext* rust/target/release/
+    ln -s ${native}/lib/libvdirsyncer_rustext* rust/target/release/
   '';
 
   LC_ALL = "en_US.utf8";
diff --git a/pkgs/tools/networking/inadyn/default.nix b/pkgs/tools/networking/inadyn/default.nix
index 8029415a98cf..47352d21c4a2 100644
--- a/pkgs/tools/networking/inadyn/default.nix
+++ b/pkgs/tools/networking/inadyn/default.nix
@@ -3,13 +3,13 @@
 
 stdenv.mkDerivation rec {
   name = "inadyn-${version}";
-  version = "2.4";
+  version = "2.5";
 
   src = fetchFromGitHub {
     owner = "troglobit";
     repo = "inadyn";
     rev = "v${version}";
-    sha256 = "1h24yavp1246zn5isypvxrilp6xj2266qr52w2r24qxicr8b320y";
+    sha256 = "0izhynqfj4xafsrc653wym8arwps0qim203w8l0g5z9vzfxfnvqw";
   };
 
   nativeBuildInputs = [ autoreconfHook pkgconfig ];
diff --git a/pkgs/tools/networking/netsniff-ng/default.nix b/pkgs/tools/networking/netsniff-ng/default.nix
index 60f7b647eea5..8bebe973522b 100644
--- a/pkgs/tools/networking/netsniff-ng/default.nix
+++ b/pkgs/tools/networking/netsniff-ng/default.nix
@@ -4,14 +4,14 @@
 
 stdenv.mkDerivation rec {
   name = "netsniff-ng-${version}";
-  version = "0.6.4";
+  version = "0.6.5";
 
   # Upstream recommends and supports git
   src = fetchFromGitHub rec {
     repo = "netsniff-ng";
     owner = repo;
     rev = "v${version}";
-    sha256 = "0nip1gmzxq5kak41n0y0qzbhk2876fypk83q14ssy32fk49lxjly";
+    sha256 = "0bcbdiik69g6jnravkkid8gxw2akg01i372msc5x1w9fh9wh2phw";
   };
 
   patches = [ ./glibc-2.26.patch ];
diff --git a/pkgs/tools/networking/openssh/default.nix b/pkgs/tools/networking/openssh/default.nix
index 04a77176682d..96bc2c56ece8 100644
--- a/pkgs/tools/networking/openssh/default.nix
+++ b/pkgs/tools/networking/openssh/default.nix
@@ -37,6 +37,13 @@ stdenv.mkDerivation rec {
 
   patches =
     [
+      # Remove on update!
+      (fetchpatch {
+        name = "fix-tunnel-forwarding.diff";
+        url = "https://github.com/openssh/openssh-portable/commit/cfb1d9bc767.diff";
+        sha256 = "1mszj7f1kj6bazr7asbi1bi4238lfpilpp98f6c1dn3py4fbsdg8";
+      })
+
       ./locale_archive.patch
       ./fix-host-key-algorithms-plus.patch
 
diff --git a/pkgs/tools/networking/pcapfix/default.nix b/pkgs/tools/networking/pcapfix/default.nix
index 970844ea6d6d..5e3bf176b2c9 100644
--- a/pkgs/tools/networking/pcapfix/default.nix
+++ b/pkgs/tools/networking/pcapfix/default.nix
@@ -1,11 +1,11 @@
 { stdenv, fetchurl }:
 
 stdenv.mkDerivation rec {
-  name = "pcapfix-1.1.2";
+  name = "pcapfix-1.1.3";
 
   src = fetchurl {
     url = "https://f00l.de/pcapfix/${name}.tar.gz";
-    sha256 = "0dl6pgqw6d8i5rhn6xwdx7sny16lpf771sn45c3p0l8z4mfzg6ay";
+    sha256 = "0f9g6yh1dc7x1n28xs4lcwlk6sa3mpz0rbw0ddhajqidag2k07sr";
   };
 
   postPatch = ''sed -i "s|/usr|$out|" Makefile'';
diff --git a/pkgs/tools/networking/tinc/default.nix b/pkgs/tools/networking/tinc/default.nix
index bf039b653cc6..a17f382557ac 100644
--- a/pkgs/tools/networking/tinc/default.nix
+++ b/pkgs/tools/networking/tinc/default.nix
@@ -1,12 +1,12 @@
 {stdenv, fetchurl, lzo, openssl, zlib}:
 
 stdenv.mkDerivation rec {
-  version = "1.0.34";
+  version = "1.0.35";
   name = "tinc-${version}";
 
   src = fetchurl {
     url = "https://www.tinc-vpn.org/packages/tinc-${version}.tar.gz";
-    sha256 = "1nngdp2x5kykrgh13q5wjry8m82vahqv53csvlb22ifxvrhrnfn0";
+    sha256 = "0pl92sdwrkiwgll78x0ww06hfljd07mkwm62g8x17qn3gha3pj0q";
   };
 
   buildInputs = [ lzo openssl zlib ];
diff --git a/pkgs/tools/networking/tinc/pre.nix b/pkgs/tools/networking/tinc/pre.nix
index 09c737c048ae..0cc1fb99455a 100644
--- a/pkgs/tools/networking/tinc/pre.nix
+++ b/pkgs/tools/networking/tinc/pre.nix
@@ -2,12 +2,12 @@
 
 stdenv.mkDerivation rec {
   name = "tinc-${version}";
-  version = "1.1pre16";
+  version = "1.1pre17";
 
   src = fetchgit {
     rev = "refs/tags/release-${version}";
     url = "git://tinc-vpn.org/tinc";
-    sha256 = "03dsm1kxagq8srskzg649xyhbdqbbqxc84pdwrz7yakpa9m6225c";
+    sha256 = "12abmx9qglchgn94a1qwgzldf2kaz77p8705ylpggzyncxv6bw2q";
   };
 
   outputs = [ "out" "man" "info" ];
diff --git a/pkgs/tools/networking/unbound/default.nix b/pkgs/tools/networking/unbound/default.nix
index a009e76d9e0a..f26cef3e61d3 100644
--- a/pkgs/tools/networking/unbound/default.nix
+++ b/pkgs/tools/networking/unbound/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   name = "unbound-${version}";
-  version = "1.7.3";
+  version = "1.8.0";
 
   src = fetchurl {
     url = "https://unbound.net/downloads/${name}.tar.gz";
-    sha256 = "c11de115d928a6b48b2165e0214402a7a7da313cd479203a7ce7a8b62cba602d";
+    sha256 = "0gxqc4ynd2g1a5dwaazqh9n8injh49a7dz0l9bbxqgv47dnrvxvq";
   };
 
   outputs = [ "out" "lib" "man" ]; # "dev" would only split ~20 kB
diff --git a/pkgs/tools/package-management/packagekit/default.nix b/pkgs/tools/package-management/packagekit/default.nix
index 2acb39c0b732..5ba387a12f82 100644
--- a/pkgs/tools/package-management/packagekit/default.nix
+++ b/pkgs/tools/package-management/packagekit/default.nix
@@ -9,7 +9,7 @@
 
 stdenv.mkDerivation rec {
   name = "packagekit-${version}";
-  version = "1.1.10";
+  version = "1.1.11";
 
   outputs = [ "out" "dev" ];
 
@@ -17,7 +17,7 @@ stdenv.mkDerivation rec {
     owner = "hughsie";
     repo = "PackageKit";
     rev = "PACKAGEKIT_${lib.replaceStrings ["."] ["_"] version}";
-    sha256 = "11drd6ixx75q3w12am3z1npwllq1kxnhbxv0npng92c69kn291zs";
+    sha256 = "0zr4b3ax8lcd3wkgj1cybs2cqf38br2nvl91qkw9g2jmzlq6bvic";
   };
 
   buildInputs = [ glib polkit python gobjectIntrospection vala_0_38 ]
diff --git a/pkgs/tools/system/plan9port/builder.sh b/pkgs/tools/system/plan9port/builder.sh
index 6085e6f841ac..7729bae897c0 100644
--- a/pkgs/tools/system/plan9port/builder.sh
+++ b/pkgs/tools/system/plan9port/builder.sh
@@ -5,7 +5,8 @@ export PLAN9_TARGET=$PLAN9
 
 configurePhase()
 {
-    echo CFLAGS=\"-I${fontconfig_dev}/include -I${libXt_dev}/include -I${freetype_dev}/include\" > LOCAL.config
+    echo CFLAGS=\"-I${fontconfig_dev}/include -I${xproto_exp}/include -I${xextproto_exp}/include -I${libX11_dev}/include -I${libXt_dev}/include -I${libXext_dev}/include -I${freetype_dev}/include -I${zlib_dev}/include\" > LOCAL.config
+    echo LDFLAGS=\"-L${fontconfig_lib}/lib -L${xproto_exp}/lib -L${xextproto_exp}/lib -L${libX11_exp}/lib -L${libXt_exp}/lib -L${libXext_exp}/lib -L${freetype_exp}/lib -L${zlib_exp}/lib\" >> LOCAL.config    
     echo X11=\"${libXt_dev}/include\" >> LOCAL.config
 
     for f in `grep -l -r /usr/local/plan9`; do
diff --git a/pkgs/tools/system/plan9port/default.nix b/pkgs/tools/system/plan9port/default.nix
index dc588e54aea8..c71c70b57a7a 100644
--- a/pkgs/tools/system/plan9port/default.nix
+++ b/pkgs/tools/system/plan9port/default.nix
@@ -2,24 +2,23 @@
 , xproto ? null
 , xextproto ? null
 , libXext ? null
+, zlib ? null
   # For building web manuals
 , perl ? null
 , samChordingSupport ? true #from 9front
 }:
 
 stdenv.mkDerivation rec {
-  name = "plan9port-2016-04-18";
+  name = "plan9port-2018-09-20";
 
   src = fetchgit {
     # Latest, same as on github, google code is old
-    url = "https://plan9port.googlesource.com/plan9";
-    rev = "35d43924484b88b9816e40d2f6bff4547f3eec47";
-    sha256 = "1dvg580rkav09fra2gnrzh271b4fw6bgqfv4ib7ds5k3j55ahcdc";
+    url = "https://github.com/9fans/plan9port.git";
+    rev = "a82a8b6368274d77d42f526e379b74e79c137e26";
+    sha256 = "1icywcnqv0dz1mkm7giakii536nycp0ajxnmzkx4944dxsmhcwq1";
   };
 
-  patches = [
-    ./fontsrv.patch
-  ] ++ stdenv.lib.optionals samChordingSupport [ ./sam_chord_9front.patch ];
+  patches = stdenv.lib.optionals samChordingSupport [ ./sam_chord_9front.patch ];
 
   postPatch = ''
     #hardcoded path
@@ -59,11 +58,24 @@ stdenv.mkDerivation rec {
     homepage = http://swtch.com/plan9port/;
     description = "Plan 9 from User Space";
     license = licenses.lpl-102;
-    maintainers = with maintainers; [ ftrvxmtrx kovirobi ];
+    maintainers = with maintainers; [ bbarker ftrvxmtrx kovirobi ];
     platforms = platforms.unix;
   };
-
+  
+  libX11_dev = libX11.dev;
   libXt_dev = libXt.dev;
+  libXext_dev = libXext.dev;
   fontconfig_dev = fontconfig.dev;
   freetype_dev = freetype.dev;
+  zlib_dev = zlib.dev;
+  
+  xproto_exp = xproto;
+  xextproto_exp = xextproto;
+  libX11_exp = libX11;
+  libXt_exp = libXt;
+  libXext_exp = libXext;
+  freetype_exp = freetype;
+  zlib_exp = zlib;
+
+  fontconfig_lib = fontconfig.lib;
 }
diff --git a/pkgs/tools/system/plan9port/fontsrv.patch b/pkgs/tools/system/plan9port/fontsrv.patch
deleted file mode 100644
index 49fd9c04231b..000000000000
--- a/pkgs/tools/system/plan9port/fontsrv.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -r dc0640f14d07 src/cmd/mkfile
---- a/src/cmd/mkfile	Tue Mar 25 23:23:10 2014 -0400
-+++ b/src/cmd/mkfile	Mon Apr 14 22:36:05 2014 +0530
-@@ -4,8 +4,8 @@
- 
- <$PLAN9/src/mkmany
- 
--BUGGERED='CVS|faces|factotum|fontsrv|lp|ip|mailfs|upas|vncv|mnihongo|mpm|index|u9fs|secstore|smugfs|snarfer'
--DIRS=lex `ls -l |sed -n 's/^d.* //p' |egrep -v "^($BUGGERED)$"|egrep -v '^lex$'` $FONTSRV
-+BUGGERED='CVS|faces|factotum|lp|ip|mailfs|upas|vncv|mnihongo|mpm|index|u9fs|secstore|smugfs|snarfer'
-+DIRS=lex `ls -l |sed -n 's/^d.* //p' |egrep -v "^($BUGGERED)$"|egrep -v '^lex$'`
- 
- <$PLAN9/src/mkdirs
- 
diff --git a/pkgs/tools/text/gnupatch/default.nix b/pkgs/tools/text/gnupatch/default.nix
index e22850a63f01..238dba3a9f1e 100644
--- a/pkgs/tools/text/gnupatch/default.nix
+++ b/pkgs/tools/text/gnupatch/default.nix
@@ -23,7 +23,6 @@ stdenv.mkDerivation rec {
     })
   ];
 
-  buildInputs = stdenv.lib.optional doCheck ed;
   nativeBuildInputs = [ autoreconfHook ];
 
   configureFlags = stdenv.lib.optionals (stdenv.hostPlatform != stdenv.buildPlatform) [
@@ -31,6 +30,7 @@ stdenv.mkDerivation rec {
   ];
 
   doCheck = stdenv.hostPlatform.libc != "musl"; # not cross;
+  checkInputs = [ed];
 
   meta = {
     description = "GNU Patch, a program to apply differences to files";
diff --git a/pkgs/tools/typesetting/scdoc/default.nix b/pkgs/tools/typesetting/scdoc/default.nix
index bdf074b558e7..3a4c7813c695 100644
--- a/pkgs/tools/typesetting/scdoc/default.nix
+++ b/pkgs/tools/typesetting/scdoc/default.nix
@@ -1,12 +1,13 @@
-{ stdenv, fetchurl }:
+{ stdenv, fetchgit }:
 
 stdenv.mkDerivation rec {
   name = "scdoc-${version}";
-  version = "1.4.2";
+  version = "1.5.1";
 
-  src = fetchurl {
-    url = "https://git.sr.ht/~sircmpwn/scdoc/snapshot/scdoc-${version}.tar.xz";
-    sha256 = "1hhvg9cifx1v8b5i91lgq5cjdcskzl3rz7vwmwdq7ad0nqnykz82";
+  src = fetchgit {
+    url = "https://git.sr.ht/~sircmpwn/scdoc";
+    rev = version;
+    sha256 = "0fm3x6ma1pzlajfcy32ayqrcab8lwl64nxfaqgc6019mxw87y1ja";
   };
 
   postPatch = ''
diff --git a/pkgs/tools/typesetting/tex/texlive/combine.nix b/pkgs/tools/typesetting/tex/texlive/combine.nix
index 8a01ac744145..f76b71ced3cf 100644
--- a/pkgs/tools/typesetting/tex/texlive/combine.nix
+++ b/pkgs/tools/typesetting/tex/texlive/combine.nix
@@ -235,6 +235,19 @@ in buildEnv {
         ln -s -t . ../texmf/doc/"$d"/*
       )
     done
+  '' +
+  # MkIV uses its own lookup mechanism and we need to initialize
+  # caches for it. Unsetting TEXMFCNF is needed to let mtxrun
+  # determine it from kpathsea so that the config path is given with
+  # "selfautodir:" as it will be in runtime. This is important because
+  # the cache is identified by a hash of this path.
+  ''
+    if [[ -e "$out/bin/mtxrun" ]]; then
+      (
+        unset TEXMFCNF
+        mtxrun --generate
+      )
+    fi
   ''
     + bin.cleanBrokenLinks
   ;