summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/admin/tigervnc/default.nix14
-rw-r--r--pkgs/tools/filesystems/ntfs-3g/default.nix12
-rw-r--r--pkgs/tools/misc/abduco/default.nix28
-rw-r--r--pkgs/tools/misc/colord-kde/default.nix19
-rw-r--r--pkgs/tools/misc/colord/default.nix6
-rw-r--r--pkgs/tools/misc/execline/default.nix54
-rw-r--r--pkgs/tools/misc/ponysay/default.nix6
-rw-r--r--pkgs/tools/misc/riemann-c-client/default.nix4
-rw-r--r--pkgs/tools/misc/tmux/default.nix6
-rwxr-xr-x[-rw-r--r--]pkgs/tools/networking/mailutils/default.nix4
-rw-r--r--pkgs/tools/networking/speedtest-cli/default.nix4
-rw-r--r--pkgs/tools/networking/stunnel/default.nix4
-rw-r--r--pkgs/tools/package-management/nix/unstable.nix6
-rw-r--r--pkgs/tools/security/chntpw/00-chntpw-build-arch-autodetect.patch25
-rw-r--r--pkgs/tools/security/chntpw/01-chntpw-install-target.patch26
-rw-r--r--pkgs/tools/security/chntpw/default.nix29
-rw-r--r--pkgs/tools/security/hashcat/default.nix2
-rw-r--r--pkgs/tools/security/munge/default.nix6
-rw-r--r--pkgs/tools/security/rhash/default.nix18
-rw-r--r--pkgs/tools/security/stricat/default.nix24
-rw-r--r--pkgs/tools/system/thermald/default.nix36
-rw-r--r--pkgs/tools/text/sgml/openjade/default.nix2
-rw-r--r--pkgs/tools/text/sgml/openjade/msggen.patch34
-rw-r--r--pkgs/tools/text/silver-searcher/default.nix4
-rw-r--r--pkgs/tools/typesetting/tex/texlive/default.nix1
25 files changed, 340 insertions, 34 deletions
diff --git a/pkgs/tools/admin/tigervnc/default.nix b/pkgs/tools/admin/tigervnc/default.nix
index 71e1f29cf1c1..a7ec73f55d73 100644
--- a/pkgs/tools/admin/tigervnc/default.nix
+++ b/pkgs/tools/admin/tigervnc/default.nix
@@ -4,22 +4,18 @@
 , fixesproto, damageproto, xcmiscproto, bigreqsproto, randrproto, renderproto
 , fontsproto, videoproto, compositeproto, scrnsaverproto, resourceproto
 , libxkbfile, libXfont, libpciaccess, cmake, libjpeg_turbo, libXft, fltk, libXinerama
-, xineramaproto, libXcursor, fetchsvn
+, xineramaproto, libXcursor
 }:
 
 with stdenv.lib;
 
 stdenv.mkDerivation rec {
-  # Release version = "1.3.0";
-  revision = 5129;
-  version = "r${toString revision}";
+  version = "1.3.1";
   name = "tigervnc-${version}";
 
-  src = fetchsvn {
-    # Release url = "mirror://sourceforge/tigervnc/${version}/${name}.tar.gz";
-    url = "https://tigervnc.svn.sourceforge.net/svnroot/tigervnc/trunk";
-    rev = revision;
-    sha256 = "1qszlqr8z16iqkm05gbs0knj4fxc3bb6gjayky1abmf8pjazi0j8";
+  src = fetchurl {
+    url = "https://github.com/TigerVNC/tigervnc/archive/v${version}.tar.gz";
+    sha256 = "161bhibic777g47lbjgdnvjhkkdzxrzmxz9rw9sim3q0gcbp0vz3";
   };
 
   inherit fontDirectories;
diff --git a/pkgs/tools/filesystems/ntfs-3g/default.nix b/pkgs/tools/filesystems/ntfs-3g/default.nix
index f6177fd89764..718e941ec648 100644
--- a/pkgs/tools/filesystems/ntfs-3g/default.nix
+++ b/pkgs/tools/filesystems/ntfs-3g/default.nix
@@ -3,7 +3,7 @@
 
 stdenv.mkDerivation rec {
   pname = "ntfs-3g";
-  version = "2012.1.15";
+  version = "2014.2.15";
   name = "${pname}-${version}";
 
   buildInputs = [libuuid] ++ stdenv.lib.optionals crypto [gnutls libgcrypt];
@@ -11,7 +11,7 @@ stdenv.mkDerivation rec {
 
   src = fetchurl {
     url = "http://tuxera.com/opensource/ntfs-3g_ntfsprogs-${version}.tgz";
-    sha256 = "09gvfgvqm4dswzxmwvg3r23bv39cp8y8b6qs2jcwmrqd032i25kg";
+    sha256 = "0mjv98m2j0kdzkjiqd2ra1akhb8milx8nwcx7hd26jxi1i09jc2c";
   };
 
   patchPhase = ''
@@ -34,10 +34,12 @@ stdenv.mkDerivation rec {
       ln -sv mount.ntfs-3g $out/sbin/mount.ntfs
     '';
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = http://www.tuxera.com/community/;
     description = "FUSE-base NTFS driver with full write support";
-    maintainers = [ stdenv.lib.maintainers.urkud ];
-    platforms = stdenv.lib.platforms.linux;
+    maintainers = [ maintainers.urkud ];
+    platforms = platforms.linux;
+    license = licenses.gpl2Plus; # and (lib)fuse-lite under LGPL2+
   };
 }
+
diff --git a/pkgs/tools/misc/abduco/default.nix b/pkgs/tools/misc/abduco/default.nix
new file mode 100644
index 000000000000..a3f5c4a1d61e
--- /dev/null
+++ b/pkgs/tools/misc/abduco/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchurl, writeText, conf? null}:
+
+with stdenv.lib;
+
+stdenv.mkDerivation rec {
+    name = "abduco-0.1";
+
+    meta = {
+        homepage = http://brain-dump.org/projects/abduco;
+        license = licenses.isc;
+        description = "Allows programs to be run independently from its controlling terminal";
+        platforms = with platforms; linux;
+    };
+
+    src = fetchurl {
+        url = "http://www.brain-dump.org/projects/abduco/${name}.tar.gz";
+        sha256 = "b4ef297cb7cc81170dc7edf75385cb1c55e024a52f90c1dd0bc0e9862e6f39b5";
+    };
+
+    configFile = optionalString (conf!=null) (writeText "config.def.h" conf);
+    preBuild = optionalString (conf!=null) "cp ${configFile} config.def.h";
+
+    buildInputs = [];
+
+    installPhase = ''
+      make PREFIX=$out install
+    '';
+}
diff --git a/pkgs/tools/misc/colord-kde/default.nix b/pkgs/tools/misc/colord-kde/default.nix
new file mode 100644
index 000000000000..55260b269c6d
--- /dev/null
+++ b/pkgs/tools/misc/colord-kde/default.nix
@@ -0,0 +1,19 @@
+{ stdenv, fetchurl, cmake, colord, libX11, libXrandr, lcms2, pkgconfig, kdelibs}:
+
+stdenv.mkDerivation {
+  name = "colord-kde-0.3.0";
+
+  src = fetchurl {
+    url = http://download.kde.org/stable/colord-kde/0.3.0/src/colord-kde-0.3.0.tar.bz2;
+    sha256 = "ab3cdb7c8c98aa2ee8de32a92f87770e1fbd58eade6471f3f24d932b50b4cf09";
+  };
+
+  buildInputs = [ cmake colord libX11 libXrandr lcms2 pkgconfig kdelibs ];
+
+  enableParallelBuilding = true;
+
+  meta = {
+    description = "A colord front-end for KDE";
+    license = stdenv.lib.licenses.gpl2Plus;
+  };
+}
diff --git a/pkgs/tools/misc/colord/default.nix b/pkgs/tools/misc/colord/default.nix
index a744adbe05c1..71ec1276c7c9 100644
--- a/pkgs/tools/misc/colord/default.nix
+++ b/pkgs/tools/misc/colord/default.nix
@@ -3,11 +3,11 @@
 , automake, autoconf, libtool, gtk_doc, which, gobjectIntrospection }:
 
 stdenv.mkDerivation rec {
-  name = "colord-1.1.5";
+  name = "colord-1.1.7";
 
   src = fetchurl {
     url = "http://www.freedesktop.org/software/colord/releases/${name}.tar.xz";
-    sha256 = "1638pfv16bdrdxxprk6dp8d706571a8i3nlfv3m0ldx26xpy8z5j";
+    sha256 = "295395526ee0be30917ae9c352e68bfeb20c7fc266a605725bef969f20547f44";
   };
 
   enableParallelBuilding = true;
@@ -23,6 +23,8 @@ stdenv.mkDerivation rec {
 
   postInstall = ''
     rm -fr $out/var/lib/colord
+    mkdir -p $out/etc/bash_completion.d
+    cp -v data/colormgr $out/etc/bash_completion.d
   '';
 
   meta = {
diff --git a/pkgs/tools/misc/execline/default.nix b/pkgs/tools/misc/execline/default.nix
new file mode 100644
index 000000000000..ba0784138b31
--- /dev/null
+++ b/pkgs/tools/misc/execline/default.nix
@@ -0,0 +1,54 @@
+{stdenv, fetchurl, skalibs}:
+
+let
+
+  version = "1.3.1.1";
+
+in stdenv.mkDerivation rec {
+
+  name = "execline-${version}";
+
+  src = fetchurl {
+    url = "http://skarnet.org/software/execline/${name}.tar.gz";
+    sha256 = "1br3qzif166kbp4k813ljbyq058p7mfsp2lj88n8vi4dmj935nzg";
+  };
+
+  buildInputs = [ skalibs ];
+
+  sourceRoot = "admin/${name}";
+
+  configurePhase = ''
+    pushd conf-compile
+
+    printf "$out/bin"     > conf-install-command
+    printf "$out/include" > conf-install-include
+    printf "$out/lib"     > conf-install-library
+    printf "$out/lib"     > conf-install-library.so
+    printf "$out/sysdeps" > conf-install-sysdeps
+
+    printf "${skalibs}/sysdeps" > import
+    printf "${skalibs}/include" > path-include
+    printf "${skalibs}/lib"     > path-library
+
+    # let nix builder strip things, cross-platform
+    truncate --size 0 conf-stripbins
+    truncate --size 0 conf-striplibs
+
+    rm -f flag-slashpackage
+    touch flag-allstatic
+
+    popd
+  '';
+
+  preBuild = ''
+    patchShebangs src/sys
+  '';
+
+  meta = {
+    homepage = http://skarnet.org/software/execline/;
+    description = "A small scripting language, to be used in place of a shell in non-interactive scripts.";
+    platforms = stdenv.lib.platforms.all;
+    license = stdenv.lib.licenses.isc;
+  };
+
+}
diff --git a/pkgs/tools/misc/ponysay/default.nix b/pkgs/tools/misc/ponysay/default.nix
index 031264f1edd0..42495a457560 100644
--- a/pkgs/tools/misc/ponysay/default.nix
+++ b/pkgs/tools/misc/ponysay/default.nix
@@ -1,11 +1,11 @@
 { stdenv, fetchurl, python3, texinfo, makeWrapper }:
 
 stdenv.mkDerivation rec {
-  name = "ponysay-3.0.1";
+  name = "ponysay-3.0.2";
 
   src = fetchurl {
-    url = "https://github.com/erkin/ponysay/archive/3.0.1.tar.gz";
-    sha256 = "ab281f43510263b2f42a1b0a9097ee7831b3e33a9034778ecb12ccb51f6915ee";
+    url = "https://github.com/erkin/ponysay/archive/3.0.2.tar.gz";
+    sha256 = "03avcbl96rv718lgg6yyrq5mvg3xxzccrnnb6brf4g9mcrwqmsb9";
   };
 
   buildInputs = [ python3 texinfo makeWrapper ];
diff --git a/pkgs/tools/misc/riemann-c-client/default.nix b/pkgs/tools/misc/riemann-c-client/default.nix
index 00eaa8aad760..efdc21ad9b79 100644
--- a/pkgs/tools/misc/riemann-c-client/default.nix
+++ b/pkgs/tools/misc/riemann-c-client/default.nix
@@ -3,11 +3,11 @@
 stdenv.mkDerivation rec {
   name = "riemann-c-client-${version}";
 
-  version = "1.2.0";
+  version = "1.2.1";
 
   src = fetchurl {
     url = "https://github.com/algernon/riemann-c-client/archive/${name}.tar.gz";
-    sha256 = "1w3rx0hva605d5vzlhhm4pb43ady0m3s4mz8ix1ycn4b8cq9jsjs";
+    sha256 = "132yd1m523inmv17sd48xf7xdqb7jj36v7is1xw7w9nny6qxkzwm";
   };
 
   buildInputs = [ autoconf automake libtool pkgconfig file protobufc ];
diff --git a/pkgs/tools/misc/tmux/default.nix b/pkgs/tools/misc/tmux/default.nix
index 5b656cc13e72..4acbabb50f98 100644
--- a/pkgs/tools/misc/tmux/default.nix
+++ b/pkgs/tools/misc/tmux/default.nix
@@ -14,6 +14,12 @@ stdenv.mkDerivation rec {
 
   buildInputs = [ ncurses libevent ];
 
+  postInstall =
+    ''
+      mkdir -p $out/etc/bash_completion.d
+      cp -v examples/bash_completion_tmux.sh $out/etc/bash_completion.d/tmux
+    '';
+
   meta = {
     homepage = http://tmux.sourceforge.net/;
     description = "tmux is a terminal multiplexer";
diff --git a/pkgs/tools/networking/mailutils/default.nix b/pkgs/tools/networking/mailutils/default.nix
index 0453567c449b..4c1001310ae1 100644..100755
--- a/pkgs/tools/networking/mailutils/default.nix
+++ b/pkgs/tools/networking/mailutils/default.nix
@@ -1,5 +1,5 @@
 { fetchurl, stdenv, gettext, gdbm, libtool, pam, readline
-, ncurses, gnutls, mysql, guile, texinfo, gnum4, dejagnu }:
+, ncurses, gnutls, mysql, guile, texinfo, gnum4, dejagnu, sendmailPath ? "/var/setuid-wrappers/sendmail" }:
 
 /* TODO: Add GNU SASL, GNU GSSAPI, and FreeBidi.  */
 
@@ -13,6 +13,8 @@ stdenv.mkDerivation rec {
 
   patches = [ ./path-to-cat.patch ./no-gets.patch ];
 
+  configureFlags = "--with-path-sendmail=${sendmailPath}";
+
   buildInputs =
    [ gettext gdbm libtool pam readline ncurses
      gnutls mysql guile texinfo gnum4 ]
diff --git a/pkgs/tools/networking/speedtest-cli/default.nix b/pkgs/tools/networking/speedtest-cli/default.nix
index 7162e29e1eac..f655639ceaf1 100644
--- a/pkgs/tools/networking/speedtest-cli/default.nix
+++ b/pkgs/tools/networking/speedtest-cli/default.nix
@@ -2,11 +2,11 @@
 
 pythonPackages.buildPythonPackage rec {
   name = "speedtest-cli-${version}";
-  version = "0.2.7";
+  version = "0.3.1";
   
   src = fetchurl {
     url = "https://pypi.python.org/packages/source/s/speedtest-cli/speedtest-cli-${version}.tar.gz";
-    sha256 = "00r3mjr8852glwryfj9f86pikqg1v0f0xivy25cj86n526wdpy95";
+    sha256 = "0ln2grbskh39ph79lhcim2axm7hp4xhzbrag8xfqbfihq7jdm6ya";
   };
 
   meta = with stdenv.lib; {
diff --git a/pkgs/tools/networking/stunnel/default.nix b/pkgs/tools/networking/stunnel/default.nix
index 0ea7a948c8d5..15bd74ea387d 100644
--- a/pkgs/tools/networking/stunnel/default.nix
+++ b/pkgs/tools/networking/stunnel/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   name    = "stunnel-${version}";
-  version = "5.01";
+  version = "5.03";
 
   src = fetchurl {
     url    = "http://www.stunnel.org/downloads/${name}.tar.gz";
-    sha256 = "0sw87x7yrgjx43a5x0cy71p2vr5j0l8n5pv49hq159p8zxcbyr95";
+    sha256 = "00yx7r46rad3yhdqfwk4grqs87wc6fiq055i91pnwxgscsa3c7ls";
   };
 
   buildInputs = [ openssl ];
diff --git a/pkgs/tools/package-management/nix/unstable.nix b/pkgs/tools/package-management/nix/unstable.nix
index afcceb30474b..bba53b0002fc 100644
--- a/pkgs/tools/package-management/nix/unstable.nix
+++ b/pkgs/tools/package-management/nix/unstable.nix
@@ -5,11 +5,11 @@
 }:
 
 stdenv.mkDerivation rec {
-  name = "nix-1.8pre3718_51485dc";
+  name = "nix-1.8pre3766_809ca33";
 
   src = fetchurl {
-    url = "http://hydra.nixos.org/build/13025632/download/5/${name}.tar.xz";
-    sha256 = "69f3a0729b6df1adcbfc7c13df405ce7f3f7904b0cbcdd7f6ad3a0af45f4024c";
+    url = "http://hydra.nixos.org/build/13584170/download/5/${name}.tar.xz";
+    sha256 = "e6d91e73aabf8e8912f9701bf87b66089c197c5b8c8fbcc1707b888c88b96dfd";
   };
 
   nativeBuildInputs = [ perl pkgconfig ];
diff --git a/pkgs/tools/security/chntpw/00-chntpw-build-arch-autodetect.patch b/pkgs/tools/security/chntpw/00-chntpw-build-arch-autodetect.patch
new file mode 100644
index 000000000000..9c379adb7dfb
--- /dev/null
+++ b/pkgs/tools/security/chntpw/00-chntpw-build-arch-autodetect.patch
@@ -0,0 +1,25 @@
+diff -urN chntpw-140201.orig/Makefile chntpw-140201/Makefile
+--- chntpw-140201.orig/Makefile	2014-02-01 20:54:37.000000000 +0400
++++ chntpw-140201/Makefile	2014-08-03 20:26:56.497161881 +0400
+@@ -12,14 +12,13 @@
+ 
+ CC=gcc
+ 
+-# Force 32 bit
+-CFLAGS= -DUSEOPENSSL -g -I. -I$(OSSLINC) -Wall -m32 
+-OSSLLIB=$(OSSLPATH)/lib
+-
+-# 64 bit if default for compiler setup
+-#CFLAGS= -DUSEOPENSSL -g -I. -I$(OSSLINC) -Wall
+-#OSSLLIB=$(OSSLPATH)/lib64
+-
++ifeq      '$(shell gcc -dumpmachine)' 'x86_64-unknown-linux-gnu'
++  CFLAGS= -DUSEOPENSSL -g -I. -I$(OSSLINC) -Wall
++  OSSLLIB=$(OSSLPATH)/lib64
++else ifeq '$(shell gcc -dumpmachine)' 'i686-unknown-linux-gnu'
++  CFLAGS= -DUSEOPENSSL -g -I. -I$(OSSLINC) -Wall -m32 
++  OSSLLIB=$(OSSLPATH)/lib
++endif
+ 
+ # This is to link with whatever we have, SSL crypto lib we put in static
+ #LIBS=-L$(OSSLLIB) $(OSSLLIB)/libcrypto.a
diff --git a/pkgs/tools/security/chntpw/01-chntpw-install-target.patch b/pkgs/tools/security/chntpw/01-chntpw-install-target.patch
new file mode 100644
index 000000000000..d3163a026f91
--- /dev/null
+++ b/pkgs/tools/security/chntpw/01-chntpw-install-target.patch
@@ -0,0 +1,26 @@
+diff -urN chntpw-140201.orig/Makefile chntpw-140201/Makefile
+--- chntpw-140201.orig/Makefile	2014-08-03 20:26:56.497161881 +0400
++++ chntpw-140201/Makefile	2014-08-04 12:57:16.563818342 +0400
+@@ -10,6 +10,8 @@
+ OSSLPATH=/usr
+ OSSLINC=$(OSSLPATH)/include
+ 
++PREFIX ?= /usr
++
+ CC=gcc
+ 
+ ifeq      '$(shell gcc -dumpmachine)' 'x86_64-unknown-linux-gnu'
+@@ -24,8 +26,12 @@
+ #LIBS=-L$(OSSLLIB) $(OSSLLIB)/libcrypto.a
+ LIBS=-L$(OSSLLIB)
+ 
++BINARIES := chntpw chntpw.static cpnt reged reged.static samusrgrp samusrgrp.static sampasswd sampasswd.static
+ 
+-all: chntpw chntpw.static cpnt reged reged.static samusrgrp samusrgrp.static sampasswd sampasswd.static
++all: $(BINARIES)
++install: $(BINARIES)
++	mkdir -p $(PREFIX)/bin
++	cp $^ $(PREFIX)/bin
+ 
+ chntpw: chntpw.o ntreg.o edlib.o libsam.o
+ 	$(CC) $(CFLAGS) -o chntpw chntpw.o ntreg.o edlib.o libsam.o $(LIBS)
diff --git a/pkgs/tools/security/chntpw/default.nix b/pkgs/tools/security/chntpw/default.nix
new file mode 100644
index 000000000000..a1aab355a3c3
--- /dev/null
+++ b/pkgs/tools/security/chntpw/default.nix
@@ -0,0 +1,29 @@
+{ stdenv, fetchurl, unzip }:
+
+stdenv.mkDerivation rec {
+  name = "chntpw-${version}";
+
+  version = "140201";
+
+  src = fetchurl {
+    url = "http://pogostick.net/~pnh/ntpasswd/chntpw-source-${version}.zip";
+    sha256 = "1k1cxsj0221dpsqi5yibq2hr7n8xywnicl8yyaicn91y8h2hkqln";
+  };
+
+  buildInputs = [ unzip ];
+
+  patches = [
+    ./00-chntpw-build-arch-autodetect.patch
+    ./01-chntpw-install-target.patch
+  ];
+
+  installPhase = ''
+    make install PREFIX=$out
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = http://pogostick.net/~pnh/ntpasswd/;
+    description = "An utility to reset the password of any user that has a valid local account on a Windows system";
+    license = licenses.gpl2;
+  };
+}
diff --git a/pkgs/tools/security/hashcat/default.nix b/pkgs/tools/security/hashcat/default.nix
index 5e1737241904..699901ad59e9 100644
--- a/pkgs/tools/security/hashcat/default.nix
+++ b/pkgs/tools/security/hashcat/default.nix
@@ -1,5 +1,7 @@
 { stdenv, fetchurl, p7zip, patchelf }:
 
+assert stdenv.isLinux;
+
 let
   bits    = if stdenv.system == "x86_64-linux" then "64" else "32";
   libPath = stdenv.lib.makeLibraryPath [ stdenv.gcc.libc ];
diff --git a/pkgs/tools/security/munge/default.nix b/pkgs/tools/security/munge/default.nix
index 2b6cd2243711..f94eaabd2a4b 100644
--- a/pkgs/tools/security/munge/default.nix
+++ b/pkgs/tools/security/munge/default.nix
@@ -1,18 +1,18 @@
 { stdenv, fetchurl, gnused, perl, libgcrypt, zlib, bzip2 }:
 
 stdenv.mkDerivation rec {
-  name = "munge-0.5.10";
+  name = "munge-0.5.11";
 
   src = fetchurl {
     url = "http://munge.googlecode.com/files/${name}.tar.bz2";
-    sha256 = "1imbmpd70vkcpca8d9yd9ajkhf6ik057nr3jb1app1wm51f15q00";
+    sha256 = "19aijdrjij2g0xpqgl198jh131j94p4gvam047gsdc0wz0a5c1wf";
   };
 
   buildInputs = [ gnused perl libgcrypt zlib bzip2 ];
 
   preConfigure = ''
     # Remove the install-data stuff, since it tries to write to /var
-    sed -i '434,465d' src/etc/Makefile.in
+    sed -i '505,511d' src/etc/Makefile.in
   '';
 
   configureFlags = [
diff --git a/pkgs/tools/security/rhash/default.nix b/pkgs/tools/security/rhash/default.nix
new file mode 100644
index 000000000000..6a2710869bf8
--- /dev/null
+++ b/pkgs/tools/security/rhash/default.nix
@@ -0,0 +1,18 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+  name = "rhash-1.3.3";
+
+  src = fetchurl {
+    url = "mirror://sourceforge/rhash/${name}-src.tar.gz";
+    sha1 = "0981bdc98ba7ef923b1a6cd7fd8bb0374cff632e";
+  };
+
+  installFlags = [ "DESTDIR=$(out)" "PREFIX=/" ];
+
+  meta = with stdenv.lib; {
+    homepage = http://rhash.anz.ru;
+    description = "Console utility for computing and verifying hash sums of files";
+    platforms = platforms.linux;
+  };
+}
diff --git a/pkgs/tools/security/stricat/default.nix b/pkgs/tools/security/stricat/default.nix
new file mode 100644
index 000000000000..64ebb4c0ca26
--- /dev/null
+++ b/pkgs/tools/security/stricat/default.nix
@@ -0,0 +1,24 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+  name    = "stricat-${version}";
+  version = "20140609100300";
+
+  src = fetchurl {
+    url    = "http://www.stribob.com/dist/${name}.tgz";
+    sha256 = "1axg8r4g5n5kdqj5013pgck80nni3z172xkg506vz4zx1zcmrm4r";
+  };
+
+  installPhase = ''
+    mkdir -p $out/bin
+    mv stricat $out/bin
+  '';
+
+  meta = {
+    description = "multi-use cryptographic tool based on the STRIBOB algorithm";
+    homepage    = "https://www.stribob.com/stricat/";
+    license     = stdenv.lib.licenses.bsd3;
+    platforms   = stdenv.lib.platforms.unix;
+    maintainers = [ stdenv.lib.maintainers.thoughtpolice ];
+  };
+}
diff --git a/pkgs/tools/system/thermald/default.nix b/pkgs/tools/system/thermald/default.nix
new file mode 100644
index 000000000000..86d121f0c22f
--- /dev/null
+++ b/pkgs/tools/system/thermald/default.nix
@@ -0,0 +1,36 @@
+{ stdenv, fetchurl, unzip, autoconf, automake, libtool, pkgconfig, dbus_libs, dbus_glib, libxml2 }:
+
+stdenv.mkDerivation rec {
+  version = "1.3";
+  name = "thermald-${version}";
+  src = fetchurl {
+    url = "https://github.com/01org/thermal_daemon/archive/v${version}.zip";
+    sha256 = "0jqxc8vvd4lx4z0kcdisk8lpdf823nysvjcfjxlr5wzla1xysqwc";
+  };
+  buildInputs = [ unzip autoconf automake libtool pkgconfig dbus_libs dbus_glib libxml2 ];
+
+  patchPhase = ''sed -e 's/upstartconfdir = \/etc\/init/upstartconfdir = $(out)\/etc\/init/' -i data/Makefile.am'';
+
+  preConfigure = ''
+                   export PKG_CONFIG_PATH="${dbus_libs}/lib/pkgconfig:$PKG_CONFIG_PATH"
+                   ./autogen.sh #--prefix="$out"
+                 '';
+
+  configureFlags = [
+    "--sysconfdir=$(out)/etc" "--localstatedir=/var"
+    "--with-dbus-sys-dir=$(out)/etc/dbus-1/system.d"
+    "--with-systemdsystemunitdir=$(out)/etc/systemd/system"
+    ];
+
+  preInstall = "sysconfdir=$out/etc";
+
+
+  meta = {
+    description = "Thermal Daemon";
+    longDescription = ''
+         Thermal Daemon
+    '';
+    homepage = https://01.org/linux-thermal-daemon;
+    license = stdenv.lib.licenses.gpl2;
+  };
+}
diff --git a/pkgs/tools/text/sgml/openjade/default.nix b/pkgs/tools/text/sgml/openjade/default.nix
index a2920345afa7..3427f62f15bc 100644
--- a/pkgs/tools/text/sgml/openjade/default.nix
+++ b/pkgs/tools/text/sgml/openjade/default.nix
@@ -8,6 +8,8 @@ stdenv.mkDerivation rec {
     sha256 = "1l92sfvx1f0wmkbvzv1385y1gb3hh010xksi1iyviyclrjb7jb8x";
   };
 
+  patches = [ ./msggen.patch ];
+
   buildInputs = [ opensp perl ];
 
   configureFlags = [
diff --git a/pkgs/tools/text/sgml/openjade/msggen.patch b/pkgs/tools/text/sgml/openjade/msggen.patch
new file mode 100644
index 000000000000..d59573fa49cf
--- /dev/null
+++ b/pkgs/tools/text/sgml/openjade/msggen.patch
@@ -0,0 +1,34 @@
+http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-text/openjade/files/openjade-1.3.2-msggen.pl.patch?revision=1.2
+
+Use Getopt::Std in place of getopts.pl.
+https://bugs.gentoo.org/show_bug.cgi?id=420083
+
+--- a/msggen.pl
++++ b/msggen.pl
+@@ -4,6 +4,7 @@
+ # See the file COPYING for copying permission.
+ 
+ use POSIX;
++use Getopt::Std;
+ 
+ # Package and version.
+ $package = 'openjade';
+@@ -18,8 +19,7 @@
+ undef $opt_l;
+ undef $opt_p;
+ undef $opt_t;
+-do 'getopts.pl';
+-&Getopts('l:p:t:');
++getopts('l:p:t:');
+ $module = $opt_l;
+ $pot_file = $opt_p;
+ 
+@@ -72,7 +72,7 @@
+     else {
+ 	$field[0] =~ /^[IWQXE][0-9]$/ || &error("invalid first field");;
+ 	$type[$num] = substr($field[0], 0, 1);
+-	$argc = int(substr($field[0], 1, 1));
++	$argc = substr($field[0], 1, 1);
+     }
+     $nargs[$num] = $argc;
+     $field[1] =~ /^[a-zA-Z_][a-zA-Z0-9_]+$/ || &error("invalid tag");
diff --git a/pkgs/tools/text/silver-searcher/default.nix b/pkgs/tools/text/silver-searcher/default.nix
index fa780b11f688..ba17d1865db0 100644
--- a/pkgs/tools/text/silver-searcher/default.nix
+++ b/pkgs/tools/text/silver-searcher/default.nix
@@ -1,13 +1,13 @@
 {stdenv, fetchgit, autoreconfHook, pkgconfig, pcre, zlib, lzma}:
 
-let release = "0.21.0"; in
+let release = "0.24.1"; in
 stdenv.mkDerivation {
   name = "silver-searcher-${release}";
 
   src = fetchgit {
     url = "https://github.com/ggreer/the_silver_searcher.git";
     rev = "refs/tags/${release}";
-    sha256 = "bd49c6cadabeaf7bde130e5d2d0083367ae2d19cfedb40e45f5bb1ff9f4a3e51";
+    sha256 = "1cwav217mkbwyg8isiak0wynydiil2j9gy4sx79harbcql0f3nl3";
   };
 
   NIX_LDFLAGS = stdenv.lib.optionalString stdenv.isLinux "-lgcc_s";
diff --git a/pkgs/tools/typesetting/tex/texlive/default.nix b/pkgs/tools/typesetting/tex/texlive/default.nix
index b5589cf943b3..c2840fd843ff 100644
--- a/pkgs/tools/typesetting/tex/texlive/default.nix
+++ b/pkgs/tools/typesetting/tex/texlive/default.nix
@@ -22,6 +22,7 @@ rec {
   setupHook = ./setup-hook.sh;
 
   doMainBuild = fullDepEntry ( stdenv.lib.optionalString stdenv.isDarwin ''
+    export MACOSX_DEPLOYMENT_TARGET=10.9
     export DYLD_LIBRARY_PATH="${poppler}/lib"
   '' + ''
     mkdir -p $out