summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/lldpd/default.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/pkgs/tools/networking/lldpd/default.nix b/pkgs/tools/networking/lldpd/default.nix
index 8e3bd7a82bf3..6b816fc8740a 100644
--- a/pkgs/tools/networking/lldpd/default.nix
+++ b/pkgs/tools/networking/lldpd/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, lib, fetchurl, pkgconfig
+{ stdenv, lib, fetchurl, pkgconfig, removeReferencesTo
 , libevent, readline, net_snmp }:
 
 stdenv.mkDerivation rec {
@@ -16,13 +16,17 @@ stdenv.mkDerivation rec {
     "--with-snmp"
   ];
 
-  nativeBuildInputs = [ pkgconfig ];
+  nativeBuildInputs = [ pkgconfig removeReferencesTo ];
   buildInputs = [ libevent readline net_snmp ];
 
   enableParallelBuilding = true;
 
   outputs = [ "out" "dev" "man" "doc" ];
 
+  preFixup = ''
+    find $out -type f -exec remove-references-to -t ${stdenv.cc} '{}' +
+  '';
+
   meta = with lib; {
     description = "802.1ab implementation (LLDP) to help you locate neighbors of all your equipments";
     homepage = "https://vincentbernat.github.io/lldpd/";