summary refs log tree commit diff
path: root/pkgs/test
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/test')
-rwxr-xr-xpkgs/test/simple/builder.sh7
-rw-r--r--pkgs/test/simple/default.nix2
2 files changed, 3 insertions, 6 deletions
diff --git a/pkgs/test/simple/builder.sh b/pkgs/test/simple/builder.sh
index cfc895ac1392..f97356a55630 100755
--- a/pkgs/test/simple/builder.sh
+++ b/pkgs/test/simple/builder.sh
@@ -6,10 +6,7 @@ export NIX_DEBUG=1
 
 . $stdenv/setup
 
-#echo starting shell
-#/bin/sh < /dev/tty > /dev/tty 2>&1 
-
-#exit 1
+export NIX_ENFORCE_PURITY=1
 
 mkdir $out
 mkdir $out/bin
@@ -25,7 +22,7 @@ int main(int argc, char * * argv)
 EOF
 
 #gcc -I/nix/store/foo -I /nix/store/foo -I/usr/lib -I /usr/lib hello.c -o $out/bin/hello
-gcc -L /nix/store/abcd/lib -isystem /usr/lib hello.c -o $out/bin/hello
+gcc -I`pwd` -L /nix/store/abcd/lib -isystem /usr/lib hello.c -o $out/bin/hello
 
 $out/bin/hello
 
diff --git a/pkgs/test/simple/default.nix b/pkgs/test/simple/default.nix
index 39b0416fc9a1..0201097dc7d3 100644
--- a/pkgs/test/simple/default.nix
+++ b/pkgs/test/simple/default.nix
@@ -6,7 +6,7 @@ let {
     allPackages = import ../../system/all-packages-generic.nix;
   };
 
-  stdenv = stdenvs.stdenvLinuxBoot2;
+  stdenv = stdenvs.stdenvLinux;
 
   test = derivation {
     name = "simple-test";