summary refs log tree commit diff
path: root/pkgs/system/all-packages-generic.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/system/all-packages-generic.nix')
-rw-r--r--pkgs/system/all-packages-generic.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/system/all-packages-generic.nix b/pkgs/system/all-packages-generic.nix
index 3c8ba63a16fc..ebddd7c18f55 100644
--- a/pkgs/system/all-packages-generic.nix
+++ b/pkgs/system/all-packages-generic.nix
@@ -813,6 +813,21 @@ rec {
     inherit fetchurl stdenv x11 libtiff libjpeg libpng;
   };
 
+  gtkmm = import ../development/libraries/gtk-libs-2.6/gtkmm {
+    inherit fetchurl stdenv pkgconfig libsigcxx;
+    inherit (gtkLibs26) gtk atk;
+    inherit glibmm;
+  };
+
+  glibmm = import ../development/libraries/gtk-libs-2.6/glibmm {
+    inherit fetchurl stdenv pkgconfig libsigcxx;
+    inherit (gtkLibs26) glib;
+  };
+
+  libsigcxx = import ../development/libraries/libsigcxx {
+    inherit fetchurl stdenv pkgconfig;
+  };
+
   pangoxsl = (import ../development/libraries/pangoxsl) {
     inherit fetchurl stdenv pkgconfig;
     inherit (gtkLibs) glib pango;
@@ -1427,6 +1442,18 @@ rec {
     inherit (gtkLibs) gtk;
   };
 
+  batik = (import ../applications/graphics/batik) {
+    inherit fetchurl stdenv unzip;
+  };
+
+  inkscape = (import ../applications/graphics/inkscape) {
+    inherit fetchurl stdenv perl perlXMLParser pkgconfig zlib popt libxml2 libxslt libpng boehmgc;
+    inherit (gtkLibs) gtk;
+    inherit gtkmm glibmm libsigcxx;
+    inherit (xlibs) libXft fontconfig;
+    inherit (gnome) glib;
+  };
+
   fspot = (import ../applications/graphics/f-spot) {
     inherit fetchurl stdenv perl perlXMLParser pkgconfig mono
             libexif libjpeg sqlite lcms libgphoto2 monoDLLFixer;