about summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/generic/default.nix3
-rw-r--r--pkgs/stdenv/native/default.nix6
2 files changed, 5 insertions, 4 deletions
diff --git a/pkgs/stdenv/generic/default.nix b/pkgs/stdenv/generic/default.nix
index 15f69c14f0dc..6513c9be7e7b 100644
--- a/pkgs/stdenv/generic/default.nix
+++ b/pkgs/stdenv/generic/default.nix
@@ -75,7 +75,8 @@ let
         isi686 = result.system == "i686-linux"
                || result.system == "i686-darwin"
                || result.system == "i686-freebsd"
-               || result.system == "i686-openbsd";
+               || result.system == "i686-openbsd"
+               || result.system == "i386-sunos";
         is64bit = result.system == "x86_64-linux";
 
         # Utility function: allow stdenv to be easily regenerated with
diff --git a/pkgs/stdenv/native/default.nix b/pkgs/stdenv/native/default.nix
index cc76a88db70f..0cbfb07eb74f 100644
--- a/pkgs/stdenv/native/default.nix
+++ b/pkgs/stdenv/native/default.nix
@@ -4,8 +4,8 @@ rec {
 
   shell = "/bin/bash";
 
-  path = ["/" "/usr" "/usr/local"];
-
+  path = (if system == "i386-sunos" then [ "/usr/gnu" ] else []) ++
+    ["/" "/usr" "/usr/local"];
 
   prehookBase = builtins.toFile "prehook-base.sh" ''
     # Disable purity tests; it's allowed (even needed) to link to
@@ -91,7 +91,7 @@ rec {
     name = "gcc-native";
     nativeTools = true;
     nativeLibc = true;
-    nativePrefix = "/usr";
+    nativePrefix = if system == "i386-sunos" then "/usr/gnu" else "/usr";
     stdenv = stdenvBoot0;
   };