summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/generic/default.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/pkgs/stdenv/generic/default.nix b/pkgs/stdenv/generic/default.nix
index 3a475933d24f..035e15169327 100644
--- a/pkgs/stdenv/generic/default.nix
+++ b/pkgs/stdenv/generic/default.nix
@@ -58,7 +58,16 @@ let
           pos' = if pos != null then "‘" + pos.file + ":" + toString pos.line + "’" else "«unknown-file»";
         in
         if !allowUnfree && (let l = lib.lists.toList attrs.meta.license or []; in lib.lists.elem "unfree" l || lib.lists.elem "unfree-redistributable" l) then
-          throw "package ‘${attrs.name}’ in ${pos'} has an unfree license, refusing to evaluate"
+          throw ''package ‘${attrs.name}’ in ${pos'} has an unfree license, refusing to evaluate.
+                 You can set
+                    { nixpkgs.config.allowUnfree = true; }
+                 in configuration.nix to override this.
+                 If you use nix standalnd, you can add
+                    { config.allowUnfree = true; }
+                 to ~/.nixpkgs/config.nix or pass
+                    --arg config '{ allowUnfree = true; }'
+                 on the command line.
+                ''
         else if !allowBroken && attrs.meta.broken or false then
           throw "you can't use package ‘${attrs.name}’ in ${pos'} because it has been marked as broken"
         else if !allowBroken && attrs.meta.platforms or null != null && !lib.lists.elem result.system attrs.meta.platforms then