summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/generic/default.nix20
-rw-r--r--pkgs/stdenv/generic/setup.sh27
-rw-r--r--pkgs/stdenv/linux/default.nix10
3 files changed, 43 insertions, 14 deletions
diff --git a/pkgs/stdenv/generic/default.nix b/pkgs/stdenv/generic/default.nix
index c4d6a3666d0d..c01f0da93ee1 100644
--- a/pkgs/stdenv/generic/default.nix
+++ b/pkgs/stdenv/generic/default.nix
@@ -91,8 +91,8 @@ let
 
         # Utility flags to test the type of platform.
         isDarwin = result.system == "i686-darwin"
-	       || result.system == "powerpc-darwin"
-	       || result.system == "x86_64-darwin";
+               || result.system == "powerpc-darwin"
+               || result.system == "x86_64-darwin";
         isLinux = result.system == "i686-linux"
                || result.system == "x86_64-linux"
                || result.system == "powerpc-linux"
@@ -100,14 +100,14 @@ let
                || result.system == "mips64-linux";
         isSunOS = result.system == "i386-sunos";
         isCygwin = result.system == "i686-cygwin";
-	isFreeBSD = result.system == "i686-freebsd"
-	       || result.system == "x86_64-freebsd";
-	isOpenBSD = result.system == "i686-openbsd"
-	       || result.system == "x86_64-openbsd";
-	isBSD = result.system == "i686-freebsd"
-	       || result.system == "x86_64-freebsd"
-	       || result.system == "i686-openbsd"
-	       || result.system == "x86_64-openbsd";
+        isFreeBSD = result.system == "i686-freebsd"
+               || result.system == "x86_64-freebsd";
+        isOpenBSD = result.system == "i686-openbsd"
+               || result.system == "x86_64-openbsd";
+        isBSD = result.system == "i686-freebsd"
+               || result.system == "x86_64-freebsd"
+               || result.system == "i686-openbsd"
+               || result.system == "x86_64-openbsd";
         isi686 = result.system == "i686-linux"
                || result.system == "i686-darwin"
                || result.system == "i686-freebsd"
diff --git a/pkgs/stdenv/generic/setup.sh b/pkgs/stdenv/generic/setup.sh
index ba06666ca898..66be38754135 100644
--- a/pkgs/stdenv/generic/setup.sh
+++ b/pkgs/stdenv/generic/setup.sh
@@ -386,6 +386,13 @@ substituteAll() {
 }
 
 
+substituteAllInPlace() {
+    local fileName="$1"
+    shift
+    substituteAll "$fileName" "$fileName" "$@"
+}
+
+
 ######################################################################
 # What follows is the generic builder.
 
@@ -719,6 +726,20 @@ fixupPhase() {
         done;
     fi
 
+    if test -z "$dontGzipMan"; then
+        GLOBIGNORE=.:..:*.gz:*.bz2
+        for f in $out/share/man/*/* $out/share/man/*/*/*; do
+            if test -f $f; then
+                if gzip -c $f > $f.gz; then
+                    rm $f
+                else
+                    rm $f.gz
+                fi
+            fi
+        done
+        unset GLOBIGNORE
+    fi
+
     # TODO: strip _only_ ELF executables, and return || fail here...
     if test -z "$dontStrip"; then
         stripDebugList=${stripDebugList:-lib lib64 libexec bin sbin}
@@ -814,6 +835,9 @@ genericBuild() {
         if test "$curPhase" = fixupPhase -a -n "$dontFixup"; then continue; fi
         if test "$curPhase" = distPhase -a -z "$doDist"; then continue; fi
         
+	echo
+	echo "@ phase-started $out $curPhase"
+
         showPhaseHeader "$curPhase"
         dumpVars
         
@@ -825,6 +849,9 @@ genericBuild() {
             cd "${sourceRoot:-.}"
         fi
         
+	echo
+	echo "@ phase-succeeded $out $curPhase"
+
         stopNest
     done
 
diff --git a/pkgs/stdenv/linux/default.nix b/pkgs/stdenv/linux/default.nix
index 7e0116e342c7..a45e6a718170 100644
--- a/pkgs/stdenv/linux/default.nix
+++ b/pkgs/stdenv/linux/default.nix
@@ -218,13 +218,15 @@ rec {
         static = true;
       };
     };
-    cloogppl = stdenvLinuxBoot3Pkgs.cloogppl.override {
-      inherit ppl;
+    cloog = stdenvLinuxBoot3Pkgs.cloog.override {
+      isl = stdenvLinuxBoot3Pkgs.isl.override {
+        static = true;
+      };
       static = true;
     };
+    cloogppl = null;
   });
 
-
   # 8) Construct a fourth stdenv identical to the second, except that
   #    this one uses the dynamically linked GCC and Binutils from step
   #    5.  The other tools (e.g. coreutils) are still from the
@@ -291,7 +293,7 @@ rec {
       inherit gcc;
       inherit (stdenvLinuxBoot3Pkgs) binutils glibc;
       inherit (stdenvLinuxBoot4Pkgs)
-        gzip bzip2 bash coreutils diffutils findutils gawk
+        gzip bzip2 xz bash coreutils diffutils findutils gawk
         gnumake gnused gnutar gnugrep gnupatch patchelf
         attr acl;
     };