about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/ipython/default.nix58
-rw-r--r--pkgs/shells/zsh/default.nix14
2 files changed, 9 insertions, 63 deletions
diff --git a/pkgs/shells/ipython/default.nix b/pkgs/shells/ipython/default.nix
deleted file mode 100644
index 0283c48add9b..000000000000
--- a/pkgs/shells/ipython/default.nix
+++ /dev/null
@@ -1,58 +0,0 @@
-{ stdenv, fetchurl, buildPythonPackage, pythonPackages, pyqt4 ? null
-, notebookSupport ? true   # ipython notebook
-, qtconsoleSupport ? true  # ipython qtconsole
-, pylabSupport ? true      # '%pylab' magic (backend: agg - no gui, just file)
-, pylabQtSupport ? true    # '%pylab qt' (backend: Qt4Agg - plot to window)
-}:
-
-# ipython qtconsole works with both pyside and pyqt4. But ipython --pylab=qt
-# only works with pyqt4 (at least this is true for ipython 0.13.1). So just use
-# pyqt4 for both.
-
-assert qtconsoleSupport == true -> pyqt4 != null;
-assert pylabQtSupport == true -> pyqt4 != null;
-
-buildPythonPackage rec {
-  name = "ipython-${version}";
-  version = "3.2.1";
-  namePrefix = "";
-
-  src = fetchurl {
-    url = "https://pypi.python.org/packages/source/i/ipython/${name}.tar.gz";
-    sha256 = "c913adee7ae5b338055274c51a7d2b3cea468b5b316046fa520cd8a434b09177";
-  };
-
-  propagatedBuildInputs = [
-    pythonPackages.readline
-    pythonPackages.sqlite3  # required for history support
-  ] ++ stdenv.lib.optionals notebookSupport [
-    pythonPackages.tornado
-    pythonPackages.pyzmq
-    pythonPackages.jinja2
-    pythonPackages.jsonschema
-  ] ++ stdenv.lib.optionals qtconsoleSupport [
-    pythonPackages.pygments
-    pythonPackages.pyzmq
-    pyqt4
-  ] ++ stdenv.lib.optionals pylabSupport [
-    pythonPackages.matplotlib
-  ] ++ stdenv.lib.optionals pylabQtSupport [
-    pythonPackages.matplotlib
-    pyqt4
-  ];
-
-  doCheck = false;
-
-  meta = {
-    homepage = http://ipython.scipy.org/;
-    description = "An interactive computing environment for Python";
-    license = stdenv.lib.licenses.bsd3;
-    longDescription = ''
-      The goal of IPython is to create a comprehensive environment
-      for interactive and exploratory computing. It consists of an
-      enhanced interactive Python shell and an architecture for
-      interactive parallel computing.
-    '';
-    maintainers = with stdenv.lib.maintainers; [ bjornfor jgeerds ];
-  };
-}
diff --git a/pkgs/shells/zsh/default.nix b/pkgs/shells/zsh/default.nix
index b755d28c8511..0e25bba9fe35 100644
--- a/pkgs/shells/zsh/default.nix
+++ b/pkgs/shells/zsh/default.nix
@@ -2,11 +2,11 @@
 
 let
 
-  version = "5.0.8";
+  version = "5.1.1";
 
   documentation = fetchurl {
-    url = "mirror://sourceforge/zsh/zsh-${version}-doc.tar.bz2";
-    sha256 = "0h4y6f0fjb1lf83j4cixl0h5jgyy5q7y1iw7w33flp7s8y60ir8f";
+    url = "mirror://sourceforge/zsh/zsh-${version}-doc.tar.gz";
+    sha256 = "0p99dr7kck0a6im1w9qiiz2ai78mgy53gbbn87bam9ya2885gf05";
   };
 
 in
@@ -15,8 +15,8 @@ stdenv.mkDerivation {
   name = "zsh-${version}";
 
   src = fetchurl {
-    url = "mirror://sourceforge/zsh/zsh-${version}.tar.bz2";
-    sha256 = "08vxw74v8cx6hcynz0cdf7s2z5p6nqmxfsxmhhpz5vwbrc4cyyc0";
+    url = "mirror://sourceforge/zsh/zsh-${version}.tar.gz";
+    sha256 = "11shllzhq53fg8ngy3bgbmpf09fn2czifg7hsb41nxi3410mpvcl";
   };
 
   buildInputs = [ ncurses coreutils pcre ];
@@ -25,6 +25,10 @@ stdenv.mkDerivation {
     configureFlags="--enable-maildir-support --enable-multibyte --enable-zprofile=$out/etc/zprofile --with-tcsetpgrp --enable-pcre"
   '';
 
+  # Some tests fail on hydra, see
+  # http://hydra.nixos.org/build/25637689/nixlog/1
+  doCheck = false;
+
   # XXX: think/discuss about this, also with respect to nixos vs nix-on-X
   postInstall = ''
     mkdir -p $out/share/