about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/oh-my-zsh/default.nix6
-rw-r--r--pkgs/shells/rush/default.nix6
-rw-r--r--pkgs/shells/rush/fix-format-security-error.patch12
3 files changed, 18 insertions, 6 deletions
diff --git a/pkgs/shells/oh-my-zsh/default.nix b/pkgs/shells/oh-my-zsh/default.nix
index b7a122b06834..4e76c7aef335 100644
--- a/pkgs/shells/oh-my-zsh/default.nix
+++ b/pkgs/shells/oh-my-zsh/default.nix
@@ -7,12 +7,12 @@
 
 stdenv.mkDerivation rec {
   name = "oh-my-zsh-${version}";
-  version = "2016-11-03";
+  version = "2016-11-16";
 
   src = fetchgit {
     url = "https://github.com/robbyrussell/oh-my-zsh";
-    rev = "0b340bc3a5c58609a07987b296f773eaea17b274";
-    sha256 = "1ifflqpbsk2gadbl0aqdmnm18bp21i9zcvjzlpldwma6crnfag68";
+    rev = "3477ff25274fa75bd9e6110f391f6ad98ca2af72";
+    sha256 = "07fvxg5jbw41j4nrs31hm0dfrwdh01gf5ik21gb4b4ddig2mjhc9";
   };
 
   phases = "installPhase";
diff --git a/pkgs/shells/rush/default.nix b/pkgs/shells/rush/default.nix
index bbad1f8cdf47..8280897c47ae 100644
--- a/pkgs/shells/rush/default.nix
+++ b/pkgs/shells/rush/default.nix
@@ -1,14 +1,14 @@
 { fetchurl, stdenv }:
 
 stdenv.mkDerivation rec {
-  name = "rush-1.7";
+  name = "rush-1.8";
 
   src = fetchurl {
     url = "mirror://gnu/rush/${name}.tar.gz";
-    sha256 = "0fh0gbbp0iiq3wbkf503xb40r8ljk42vyj9bnlflbz82d6ipy1rm";
+    sha256 = "1vxdb81ify4xcyygh86250pi50krb16dkj42i5ii4ns3araiwckz";
   };
 
-  patches = [ ./gets.patch ];
+  patches = [ ./fix-format-security-error.patch ];
 
   doCheck = true;
 
diff --git a/pkgs/shells/rush/fix-format-security-error.patch b/pkgs/shells/rush/fix-format-security-error.patch
new file mode 100644
index 000000000000..ed3ad0aa4c1f
--- /dev/null
+++ b/pkgs/shells/rush/fix-format-security-error.patch
@@ -0,0 +1,12 @@
+diff -Nur rush-1.8.orig/lib/wordsplit.c rush-1.8/lib/wordsplit.c
+--- rush-1.8.orig/lib/wordsplit.c	2016-08-18 20:11:43.000000000 +0200
++++ rush-1.8/lib/wordsplit.c	2016-11-14 14:37:02.976177414 +0100
+@@ -2330,7 +2330,7 @@
+       break;
+ 
+     default:
+-      wsp->ws_error (wordsplit_strerror (wsp));
++      wsp->ws_error ("%s", wordsplit_strerror (wsp));
+     }
+ }
+