summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/fish/default.nix3
-rw-r--r--pkgs/shells/oh-my-zsh/default.nix6
2 files changed, 5 insertions, 4 deletions
diff --git a/pkgs/shells/fish/default.nix b/pkgs/shells/fish/default.nix
index 6b4a91e90142..8916cca0f044 100644
--- a/pkgs/shells/fish/default.nix
+++ b/pkgs/shells/fish/default.nix
@@ -24,6 +24,7 @@ stdenv.mkDerivation rec {
     sed -e "s|expr|${coreutils}/bin/expr|" \
   '' + stdenv.lib.optionalString (!stdenv.isDarwin) ''
         -e "s|if which unicode_start|if true|" \
+    '' + stdenv.lib.optionalString stdenv.isLinux ''
         -e "s|unicode_start|${kbd}/bin/unicode_start|" \
   '' + ''
         -i "$out/etc/fish/config.fish"
@@ -50,7 +51,7 @@ stdenv.mkDerivation rec {
       --replace "| ul" "| ${utillinux}/bin/ul" 
 
     for cur in $out/share/fish/functions/*.fish; do
-      substituteInPlace "$cur" --replace "/usr/bin/getent" "${glibc}/bin/getent" 
+      substituteInPlace "$cur" --replace "/usr/bin/getent" "${glibc.bin}/bin/getent"
     done
   '' + stdenv.lib.optionalString (!stdenv.isDarwin) ''
     sed -i "s|(hostname\||(${nettools}/bin/hostname\||" "$out/share/fish/functions/fish_prompt.fish"
diff --git a/pkgs/shells/oh-my-zsh/default.nix b/pkgs/shells/oh-my-zsh/default.nix
index 796521b52334..78b112210acf 100644
--- a/pkgs/shells/oh-my-zsh/default.nix
+++ b/pkgs/shells/oh-my-zsh/default.nix
@@ -7,12 +7,12 @@
 
 stdenv.mkDerivation rec {
   name = "oh-my-zsh-git-${version}";
-  version = "2016-04-06";
+  version = "2016-04-20";
 
   src = fetchgit {
     url = "https://github.com/robbyrussell/oh-my-zsh";
-    rev = "d310fac7f65d31f7494532201e02ebf67c9d9555";
-    sha256 = "0kx552b0jf5j8qkk1kixdr1z49ly79cvzhdh27848rj3kwb0z8vq";
+    rev = "1b1315a777328095cd8b5f364fd4345eeae7c4bf";
+    sha256 = "0q3w96a9rjxmqknycxjqjs5mi0q2mark8yrfim7snxrf9ajv0ypk";
   };
 
   phases = "installPhase";