summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/dgsh/default.nix4
-rw-r--r--pkgs/shells/dgsh/glibc-2.26.patch12
2 files changed, 16 insertions, 0 deletions
diff --git a/pkgs/shells/dgsh/default.nix b/pkgs/shells/dgsh/default.nix
index 51319aef90aa..c3c2da329a9b 100644
--- a/pkgs/shells/dgsh/default.nix
+++ b/pkgs/shells/dgsh/default.nix
@@ -15,6 +15,8 @@ stdenv.mkDerivation rec {
     fetchSubmodules = true;
   };
 
+  patches = [ ./glibc-2.26.patch ];
+
   nativeBuildInputs = [ autoconf automake pkgconfig libtool check
     bison git gettext gperf perl texinfo help2man ncurses
   ];
@@ -31,6 +33,8 @@ stdenv.mkDerivation rec {
     make PREFIX=$out config
   '';
 
+  enableParallelBuilding = true;
+
   meta = with stdenv.lib; {
     description = "The Directed Graph Shell";
     homepage = http://www.dmst.aueb.gr/dds/sw/dgsh;
diff --git a/pkgs/shells/dgsh/glibc-2.26.patch b/pkgs/shells/dgsh/glibc-2.26.patch
new file mode 100644
index 000000000000..c66768151316
--- /dev/null
+++ b/pkgs/shells/dgsh/glibc-2.26.patch
@@ -0,0 +1,12 @@
+diff --git a/core-tools/src/dgsh-httpval.c b/core-tools/src/dgsh-httpval.c
+index 8b5dce3..7b43c3d 100644
+--- a/core-tools/src/dgsh-httpval.c
++++ b/core-tools/src/dgsh-httpval.c
+@@ -40,6 +40,7 @@
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include <stdlib.h>
++#include <stdint.h>
+ #include <stdio.h>
+ #include <string.h>
+ #include <ctype.h>