about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/sql/postgresql/9.1.x.nix44
-rw-r--r--pkgs/servers/sql/postgresql/generic.nix2
2 files changed, 8 insertions, 38 deletions
diff --git a/pkgs/servers/sql/postgresql/9.1.x.nix b/pkgs/servers/sql/postgresql/9.1.x.nix
index 87ed9abe6901..b481f292ec54 100644
--- a/pkgs/servers/sql/postgresql/9.1.x.nix
+++ b/pkgs/servers/sql/postgresql/9.1.x.nix
@@ -1,42 +1,10 @@
-{ stdenv, fetchurl, zlib, readline, openssl }:
+{ callPackage, fetchurl, ... } @ args:
 
-let version = "9.1.15"; in
-
-stdenv.mkDerivation rec {
-  name = "postgresql-${version}";
+callPackage ./generic.nix (args // rec {
+  version = "9.1.16";
 
   src = fetchurl {
-    url = "mirror://postgresql/source/v${version}/${name}.tar.bz2";
-    sha256 = "0pyyw0cy91z9wkqf8qzkwsy8cyjps0s94c9czz6mzhyd2npxxmk7";
-  };
-
-  buildInputs = [ zlib readline openssl ];
-
-  enableParallelBuilding = true;
-
-  LC_ALL = "C";
-
-  configureFlags = [ "--with-openssl" ];
-
-  patches = [ ./less-is-more.patch ];
-
-  postInstall =
-    ''
-      mkdir -p $out/share/man
-      cp -rvd doc/src/sgml/man1 $out/share/man
-    '';
-
-  passthru = {
-    inherit readline;
-    psqlSchema = "9.1";
-  };
-
-  meta = with stdenv.lib; {
-    homepage = http://www.postgresql.org/;
-    description = "A powerful, open source object-relational database system";
-    license = licenses.postgresql;
-    maintainers = with maintaiers; [ ocharles ];
-    platforms = platforms.unix;
-    hydraPlatforms = platforms.linux;
+    url = "mirror://postgresql/source/v${version}/postgresql-${version}.tar.bz2";
+    sha256 = "0mllj1r1648iwm0qj3cj9qxizhlyhqmz94iydnwhf48psvvy4r9b";
   };
-}
+})
diff --git a/pkgs/servers/sql/postgresql/generic.nix b/pkgs/servers/sql/postgresql/generic.nix
index b2af6dd53316..06e6d1e79d69 100644
--- a/pkgs/servers/sql/postgresql/generic.nix
+++ b/pkgs/servers/sql/postgresql/generic.nix
@@ -77,6 +77,8 @@ stdenv.mkDerivation rec {
     (mkWith   (optLibxml2 != null)      "libxml"            null)
     (mkWith   (optLibxslt != null)      "libxslt"           null)
     (mkWith   (optZlib != null)         "zlib"              null)
+  ] ++ optionals (versionAtLeast version "9.1.0") [
+    (mkWith   false                     "selinux"           null)
   ];
 
   meta = with stdenv.lib; {