about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/mail/rspamd/default.nix13
-rw-r--r--pkgs/servers/samba/4.x.nix54
-rw-r--r--pkgs/servers/samba/master.nix29
-rw-r--r--pkgs/servers/sql/postgresql/ext/pgjwt.nix3
-rw-r--r--pkgs/servers/sql/postgresql/ext/pgroonga.nix1
-rw-r--r--pkgs/servers/sql/postgresql/ext/pgrouting.nix2
-rw-r--r--pkgs/servers/sql/postgresql/ext/repmgr.nix1
-rw-r--r--pkgs/servers/sql/postgresql/ext/tsearch_extras.nix1
-rw-r--r--pkgs/servers/tvheadend/default.nix2
9 files changed, 42 insertions, 64 deletions
diff --git a/pkgs/servers/mail/rspamd/default.nix b/pkgs/servers/mail/rspamd/default.nix
index 2b3986c412d0..0823ed2fe4b8 100644
--- a/pkgs/servers/mail/rspamd/default.nix
+++ b/pkgs/servers/mail/rspamd/default.nix
@@ -1,10 +1,11 @@
 { stdenv, lib, fetchFromGitHub, cmake, perl
 , file, glib, libevent, luajit, openssl, pcre, pkgconfig, sqlite, ragel, icu
-, hyperscan, libfann, gd, jemalloc, openblas
+, hyperscan, libfann, gd, jemalloc, openblas, lua
 , withFann ? true
 , withGd ? false
 , withBlas ? true
 , withHyperscan ? stdenv.isx86_64
+, withLuaJIT ? stdenv.isx86_64
 }:
 
 assert withHyperscan -> stdenv.isx86_64;
@@ -24,11 +25,12 @@ stdenv.mkDerivation rec {
   };
 
   nativeBuildInputs = [ cmake pkgconfig perl ];
-  buildInputs = [ glib libevent libmagic luajit openssl pcre sqlite ragel icu jemalloc ]
+  buildInputs = [ glib libevent libmagic openssl pcre sqlite ragel icu jemalloc ]
     ++ lib.optional withFann libfann
     ++ lib.optional withGd gd
     ++ lib.optional withHyperscan hyperscan
-    ++ lib.optional withBlas openblas;
+    ++ lib.optional withBlas openblas
+    ++ lib.optional withLuaJIT luajit ++ lib.optional (!withLuaJIT) lua;
 
   cmakeFlags = [
     "-DDEBIAN_BUILD=ON"
@@ -39,10 +41,11 @@ stdenv.mkDerivation rec {
     "-DENABLE_JEMALLOC=ON"
   ] ++ lib.optional withFann "-DENABLE_FANN=ON"
     ++ lib.optional withHyperscan "-DENABLE_HYPERSCAN=ON"
-    ++ lib.optional withGd "-DENABLE_GD=ON";
+    ++ lib.optional withGd "-DENABLE_GD=ON"
+    ++ lib.optional (!withLuaJIT) "-DENABLE_TORCH=OFF";
 
   meta = with stdenv.lib; {
-    homepage = https://rspamd.com;
+    homepage = "https://rspamd.com";
     license = licenses.asl20;
     description = "Advanced spam filtering system";
     maintainers = with maintainers; [ avnik fpletz globin ];
diff --git a/pkgs/servers/samba/4.x.nix b/pkgs/servers/samba/4.x.nix
index 9bec174a58aa..63ac8c53317e 100644
--- a/pkgs/servers/samba/4.x.nix
+++ b/pkgs/servers/samba/4.x.nix
@@ -3,7 +3,7 @@
 , docbook_xml_dtd_42, readline
 , popt, iniparser, libbsd, libarchive, libiconv, gettext
 , krb5Full, zlib, openldap, cups, pam, avahi, acl, libaio, fam, libceph, glusterfs
-, gnutls, ncurses, libunwind, systemd, jansson, lmdb, gpgme
+, gnutls, ncurses, libunwind, systemd, jansson, lmdb, gpgme, libuuid
 
 , enableLDAP ? false
 , enablePrinting ? false
@@ -29,28 +29,27 @@ stdenv.mkDerivation rec {
 
   outputs = [ "out" "dev" "man" ];
 
-  patches =
-    [ ./4.x-no-persistent-install.patch
-      ./patch-source3__libads__kerberos_keytab.c.patch
-      ./4.x-no-persistent-install-dynconfig.patch
-      ./4.x-fix-makeflags-parsing.patch
-    ];
+  patches = [
+    ./4.x-no-persistent-install.patch
+    ./patch-source3__libads__kerberos_keytab.c.patch
+    ./4.x-no-persistent-install-dynconfig.patch
+    ./4.x-fix-makeflags-parsing.patch
+  ];
 
   nativeBuildInputs = optionals stdenv.isDarwin [ rpcgen fixDarwinDylibNames ];
 
-  buildInputs =
-    [ python pkgconfig perl libxslt docbook_xsl docbook_xml_dtd_42 /*
-      docbook_xml_dtd_45 */ readline popt iniparser jansson
-      libbsd libarchive zlib fam libiconv gettext libunwind krb5Full
-    ]
-    ++ optionals stdenv.isLinux [ libaio systemd ]
+  buildInputs = [
+    python pkgconfig perl libxslt docbook_xsl docbook_xml_dtd_42 /*
+    docbook_xml_dtd_45 */ readline popt iniparser jansson
+    libbsd libarchive zlib fam libiconv gettext libunwind krb5Full
+  ] ++ optionals stdenv.isLinux [ libaio systemd ]
     ++ optional enableLDAP openldap
     ++ optional (enablePrinting && stdenv.isLinux) cups
     ++ optional enableMDNS avahi
     ++ optionals enableDomainController [ gnutls gpgme lmdb ]
     ++ optional enableRegedit ncurses
     ++ optional (enableCephFS && stdenv.isLinux) libceph
-    ++ optional (enableGlusterFS && stdenv.isLinux) glusterfs
+    ++ optionals (enableGlusterFS && stdenv.isLinux) [ glusterfs libuuid ]
     ++ optional enableAcl acl
     ++ optional enablePam pam;
 
@@ -67,25 +66,24 @@ stdenv.mkDerivation rec {
        --replace "bld.SAMBA_BINARY('resolvconftest'" "True or bld.SAMBA_BINARY('resolvconftest'"
   '';
 
-  configureFlags =
-    [ "--with-static-modules=NONE"
-      "--with-shared-modules=ALL"
-      "--with-system-mitkrb5"
-      "--with-system-mitkdc" krb5Full
-      "--enable-fhs"
-      "--sysconfdir=/etc"
-      "--localstatedir=/var"
-      "--disable-rpath"
-    ]
-    ++ [(if enableDomainController
+  configureFlags = [
+    "--with-static-modules=NONE"
+    "--with-shared-modules=ALL"
+    "--with-system-mitkrb5"
+    "--with-system-mitkdc" krb5Full
+    "--enable-fhs"
+    "--sysconfdir=/etc"
+    "--localstatedir=/var"
+    "--disable-rpath"
+  ] ++ singleton (if enableDomainController
          then "--with-experimental-mit-ad-dc"
-         else "--without-ad-dc")]
+         else "--without-ad-dc")
     ++ optionals (!enableLDAP) [ "--without-ldap" "--without-ads" ]
     ++ optional (!enableAcl) "--without-acl-support"
     ++ optional (!enablePam) "--without-pam";
 
   preBuild = ''
-      export MAKEFLAGS="-j $NIX_BUILD_CORES"
+    export MAKEFLAGS="-j $NIX_BUILD_CORES"
   '';
 
   # Some libraries don't have /lib/samba in RPATH but need it.
@@ -105,7 +103,7 @@ stdenv.mkDerivation rec {
   '';
 
   meta = with stdenv.lib; {
-    homepage = https://www.samba.org/;
+    homepage = "https://www.samba.org";
     description = "The standard Windows interoperability suite of programs for Linux and Unix";
     license = licenses.gpl3;
     platforms = platforms.unix;
diff --git a/pkgs/servers/samba/master.nix b/pkgs/servers/samba/master.nix
deleted file mode 100644
index 21038a0f2183..000000000000
--- a/pkgs/servers/samba/master.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ fetchFromGitHub
-, samba4
-, nettle
-} :
-
-  (samba4.overrideAttrs(oldAttrs: rec {
-    name = "samba-unstable-${version}";
-    version = "2018-03-09";
-
-    src = fetchFromGitHub {
-      owner = "samba-team";
-      repo = "samba";
-      rev = "9e954bcbf43d67a18ee55f84cda0b09028f96b92";
-      sha256 = "07j1pwm4kax6pq21gq9gpmp7dhj5afdyvkhgyl3yz334mb41q11g";
-    };
-
-    # Remove unnecessary install flags, same as <4.8 patch
-    postPatch = oldAttrs.postPatch + ''
-      sed -i '423,433d' dynconfig/wscript
-    '';
-
-    patches = [ ./4.x-no-persistent-install.patch ];
-    buildInputs = [ nettle ] ++ oldAttrs.buildInputs;
-    meta.branch = "master";
-  })).override {
-    # samba4.8+ removed the ability to disable LDAP.
-    # Enable for base derivation here:
-    enableLDAP = true;
-  }
diff --git a/pkgs/servers/sql/postgresql/ext/pgjwt.nix b/pkgs/servers/sql/postgresql/ext/pgjwt.nix
index 7dcaac07d877..9576c4186118 100644
--- a/pkgs/servers/sql/postgresql/ext/pgjwt.nix
+++ b/pkgs/servers/sql/postgresql/ext/pgjwt.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub }:
+{ stdenv, fetchFromGitHub, postgresql }:
 
 stdenv.mkDerivation {
   pname = "pgjwt";
@@ -23,6 +23,7 @@ stdenv.mkDerivation {
       sign() and verify() functions to create and verify JSON Web Tokens.
     '';
     license = licenses.mit;
+    platforms = postgresql.meta.platforms;
     maintainers = with maintainers; [spinus];
   };
 }
diff --git a/pkgs/servers/sql/postgresql/ext/pgroonga.nix b/pkgs/servers/sql/postgresql/ext/pgroonga.nix
index 7dc70ee976cf..15a220670008 100644
--- a/pkgs/servers/sql/postgresql/ext/pgroonga.nix
+++ b/pkgs/servers/sql/postgresql/ext/pgroonga.nix
@@ -29,6 +29,7 @@ stdenv.mkDerivation rec {
     '';
     homepage = "https://pgroonga.github.io/";
     license = licenses.postgresql;
+    platforms = postgresql.meta.platforms;
     maintainers = with maintainers; [ DerTim1 ];
   };
 }
diff --git a/pkgs/servers/sql/postgresql/ext/pgrouting.nix b/pkgs/servers/sql/postgresql/ext/pgrouting.nix
index 48c41a9ca022..13aa5d942e54 100644
--- a/pkgs/servers/sql/postgresql/ext/pgrouting.nix
+++ b/pkgs/servers/sql/postgresql/ext/pgrouting.nix
@@ -24,7 +24,7 @@ stdenv.mkDerivation rec {
     description = "A PostgreSQL/PostGIS extension that provides geospatial routing functionality";
     homepage    = https://pgrouting.org/;
     maintainers = [ maintainers.steve-chavez ];
-    platforms   = platforms.linux;
+    platforms   = postgresql.meta.platforms;
     license     = licenses.gpl2;
   };
 }
diff --git a/pkgs/servers/sql/postgresql/ext/repmgr.nix b/pkgs/servers/sql/postgresql/ext/repmgr.nix
index 366d98d1b4b1..6dc3be727c65 100644
--- a/pkgs/servers/sql/postgresql/ext/repmgr.nix
+++ b/pkgs/servers/sql/postgresql/ext/repmgr.nix
@@ -25,6 +25,7 @@ stdenv.mkDerivation rec {
     homepage = "https://repmgr.org/";
     description = "Replication manager for PostgreSQL cluster";
     license = licenses.postgresql;
+    platforms = postgresql.meta.platforms;
     maintainers = with maintainers; [ zimbatm ];
   };
 }
diff --git a/pkgs/servers/sql/postgresql/ext/tsearch_extras.nix b/pkgs/servers/sql/postgresql/ext/tsearch_extras.nix
index 9bc556c700dc..77e4cd9df7ae 100644
--- a/pkgs/servers/sql/postgresql/ext/tsearch_extras.nix
+++ b/pkgs/servers/sql/postgresql/ext/tsearch_extras.nix
@@ -23,6 +23,7 @@ stdenv.mkDerivation {
     description = "Provides a few PostgreSQL functions for a lower-level data full text search";
     homepage = https://github.com/zulip/tsearch_extras/;
     license = licenses.postgresql;
+    platforms = postgresql.meta.platforms;
     maintainers = with maintainers; [ DerTim1 ];
   };
 }
diff --git a/pkgs/servers/tvheadend/default.nix b/pkgs/servers/tvheadend/default.nix
index dd66259eed6f..7fad204a0189 100644
--- a/pkgs/servers/tvheadend/default.nix
+++ b/pkgs/servers/tvheadend/default.nix
@@ -25,6 +25,8 @@ in stdenv.mkDerivation {
 
   enableParallelBuilding = true;
 
+  NIX_CFLAGS_COMPILE = "-Wno-error=format-truncation";
+
   # disable dvbscan, as having it enabled causes a network download which
   # cannot happen during build.
   configureFlags = [