summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/http/h2o/default.nix4
-rw-r--r--pkgs/servers/http/hiawatha/default.nix52
-rw-r--r--pkgs/servers/mail/opensmtpd/default.nix13
-rw-r--r--pkgs/servers/mail/opensmtpd/proc_path.diff37
-rw-r--r--pkgs/servers/monitoring/plugins/labs_consol_de.nix19
-rw-r--r--pkgs/servers/sql/mariadb/default.nix4
6 files changed, 56 insertions, 73 deletions
diff --git a/pkgs/servers/http/h2o/default.nix b/pkgs/servers/http/h2o/default.nix
index cd2985960a75..e05624fa46c8 100644
--- a/pkgs/servers/http/h2o/default.nix
+++ b/pkgs/servers/http/h2o/default.nix
@@ -7,13 +7,13 @@ with builtins;
 
 stdenv.mkDerivation rec {
   name = "h2o-${version}";
-  version = "2.2.4";
+  version = "2.2.5";
 
   src = fetchFromGitHub {
     owner  = "h2o";
     repo   = "h2o";
     rev    = "refs/tags/v${version}";
-    sha256 = "0176x0bzjry19zs074a9i5vhncc842xikmx43wj61jky318nq4w4";
+    sha256 = "0jyvbp6cjiirj44nxqa2fi5y473gnc8awfn8zv82hb1y9rlxqfyv";
   };
 
   nativeBuildInputs = [ pkgconfig cmake ];
diff --git a/pkgs/servers/http/hiawatha/default.nix b/pkgs/servers/http/hiawatha/default.nix
index 277fa06a7079..39722c6d831f 100644
--- a/pkgs/servers/http/hiawatha/default.nix
+++ b/pkgs/servers/http/hiawatha/default.nix
@@ -1,50 +1,50 @@
-{ stdenv, fetchurl, cmake,
-  libxslt, zlib, libxml2, openssl,
-  enableSSL ? true,
-  enableMonitor ? false,
-  enableRproxy ? true,
-  enableTomahawk ? false,
-  enableXSLT ? true,
-  enableToolkit ? true
-}:
+{ stdenv
+, fetchFromGitLab
+
+, cmake
+, ninja
+
+, libxslt
+, libxml2
 
-assert enableSSL -> openssl !=null;
+, enableSSL ? true
+, enableMonitor ? false
+, enableRproxy ? true
+, enableTomahawk ? false
+, enableXSLT ? true
+, enableToolkit ? true
+}:
 
 stdenv.mkDerivation rec {
   name = "hiawatha-${version}";
   version = "10.8.1";
 
-  src = fetchurl {
-    url = "https://github.com/hsleisink/hiawatha/archive/v${version}.tar.gz";
-    sha256 = "1f2hlw2lp98b4dx87i7pz7h66vsy2g22b5adfrlij3kj0vfv61w8";
+  src = fetchFromGitLab {
+    owner = "hsleisink";
+    repo = "hiawatha";
+    rev = "v${version}";
+    sha256 = "1428byx0xpzzwyc0j157q70sjx18dykvg6fd5vp70kj85ank0xpa";
   };
 
-  buildInputs =  [ cmake libxslt zlib libxml2 ] ++ stdenv.lib.optional enableSSL openssl ;
+  nativeBuildInputs = [ cmake ninja ];
+  buildInputs = [ libxslt libxml2 ];
 
   prePatch = ''
     substituteInPlace CMakeLists.txt --replace SETUID ""
   '';
 
   cmakeFlags = [
-    ( if enableSSL then "-DENABLE_TLS=on" else "-DENABLE_TLS=off" )
+    (
+      # FIXME: 2018-06-08: Uses bundled library, with external ("-DUSE_SYSTEM_MBEDTLS=on") asks:
+      # ../src/tls.c:46:2: error: #error "The mbed TLS library must be compiled with MBEDTLS_THREADING_PTHREAD and MBEDTLS_THREADING_C enabled."
+      if enableSSL then "-DENABLE_TLS=on" else "-DENABLE_TLS=off" )
     ( if enableMonitor then "-DENABLE_MONITOR=on" else "-DENABLE_MONITOR=off" )
     ( if enableRproxy then "-DENABLE_RPROXY=on" else "-DENABLE_RPROXY=off" )
     ( if enableTomahawk then "-DENABLE_TOMAHAWK=on" else "-DENABLE_TOMAHAWK=off" )
     ( if enableXSLT then "-DENABLE_XSLT=on" else "-DENABLE_XSLT=off" )
     ( if enableToolkit then "-DENABLE_TOOLKIT=on" else "-DENABLE_TOOLKIT=off" )
-    "-DWEBROOT_DIR=/var/www/hiawatha"
-    "-DPID_DIR=/run"
-    "-DWORK_DIR=/var/lib/hiawatha"
-    "-DLOG_DIR=/var/log/hiawatha"
   ];
 
-  # workaround because cmake tries installs stuff outside of nix store
-  makeFlags = [ "DESTDIR=$(out)" "PREFIX=" ];
-  postInstall = ''
-    mv $out/$out/* $out
-    rm -rf $out/{var,run}
-  '';
-
   meta = with stdenv.lib; {
     description = "An advanced and secure webserver";
     license = licenses.gpl2;
diff --git a/pkgs/servers/mail/opensmtpd/default.nix b/pkgs/servers/mail/opensmtpd/default.nix
index d2667597c627..e562fdc88a6c 100644
--- a/pkgs/servers/mail/opensmtpd/default.nix
+++ b/pkgs/servers/mail/opensmtpd/default.nix
@@ -5,28 +5,27 @@
 # see also https://github.com/OpenSMTPD/OpenSMTPD/issues/678
 , unpriviledged_smtpctl_encrypt ? true
 
-# This enables you to override the '+' character which typically separates the user from the tag in user+tag@domain.tld
+# Deprecated: use the subaddressing-delimiter in the config file going forward
 , tag_char ? null
 }:
 
-stdenv.mkDerivation rec {
+if (tag_char != null)
+then throw "opensmtpd: the tag_char argument is deprecated as it can now be specified at runtime via the 'subaddressing-delimiter' option of the configuration file"
+else stdenv.mkDerivation rec {
   name = "opensmtpd-${version}";
-  version = "6.0.2p1";
+  version = "6.0.3p1";
 
   nativeBuildInputs = [ autoconf automake libtool bison ];
   buildInputs = [ libasr libevent zlib openssl db pam ];
 
   src = fetchurl {
     url = "https://www.opensmtpd.org/archives/${name}.tar.gz";
-    sha256 = "1b4h64w45hpmfq5721smhg4s0shs64gbcjqjpx3fbiw4hz8bdy9a";
+    sha256 = "291881862888655565e8bbe3cfb743310f5dc0edb6fd28a889a9a547ad767a81";
   };
 
   patches = [ ./proc_path.diff ];
 
   postPatch = with builtins; with lib;
-    optionalString (isString tag_char) ''
-      sed -i -e "s,TAG_CHAR.*'+',TAG_CHAR '${tag_char}'," smtpd/smtpd-defines.h
-    '' +
     optionalString unpriviledged_smtpctl_encrypt ''
       substituteInPlace smtpd/smtpctl.c --replace \
         'if (geteuid())' \
diff --git a/pkgs/servers/mail/opensmtpd/proc_path.diff b/pkgs/servers/mail/opensmtpd/proc_path.diff
index 9306685e365e..5e1cfd004299 100644
--- a/pkgs/servers/mail/opensmtpd/proc_path.diff
+++ b/pkgs/servers/mail/opensmtpd/proc_path.diff
@@ -1,33 +1,8 @@
-diff --git a/smtpd/parse.y b/smtpd/parse.y
-index ab02719..c1c77d9 100644
---- a/smtpd/parse.y
-+++ b/smtpd/parse.y
-@@ -2534,13 +2534,19 @@ create_filter_proc(char *name, char *prog)
- {
- 	struct filter_conf	*f;
- 	char			*path;
-+	const char		*proc_path;
- 
- 	if (dict_get(&conf->sc_filters, name)) {
- 		yyerror("filter \"%s\" already defined", name);
- 		return (NULL);
- 	}
- 
--	if (asprintf(&path, "%s/filter-%s", PATH_LIBEXEC, prog) == -1) {
-+	proc_path = getenv("OPENSMTPD_PROC_PATH");
-+	if (proc_path == NULL) {
-+		proc_path = PATH_LIBEXEC;
-+	}
-+
-+	if (asprintf(&path, "%s/filter-%s", proc_path, prog) == -1) {
- 		yyerror("filter \"%s\" asprintf failed", name);
- 		return (0);
- 	}
 diff --git a/smtpd/smtpd.c b/smtpd/smtpd.c
-index afc8891..9b0a80f 100644
+index e049f07c..a1bd03a0 100644
 --- a/smtpd/smtpd.c
 +++ b/smtpd/smtpd.c
-@@ -795,6 +795,7 @@ fork_proc_backend(const char *key, const char *conf, const char *procname)
+@@ -1157,6 +1157,7 @@ fork_proc_backend(const char *key, const char *conf, const char *procname)
  	char		path[PATH_MAX];
  	char		name[PATH_MAX];
  	char		*arg;
@@ -35,7 +10,7 @@ index afc8891..9b0a80f 100644
  
  	if (strlcpy(name, conf, sizeof(name)) >= sizeof(name)) {
  		log_warnx("warn: %s-proc: conf too long", key);
-@@ -805,7 +806,12 @@ fork_proc_backend(const char *key, const char *conf, const char *procname)
+@@ -1167,7 +1168,12 @@ fork_proc_backend(const char *key, const char *conf, const char *procname)
  	if (arg)
  		*arg++ = '\0';
  
@@ -50,10 +25,10 @@ index afc8891..9b0a80f 100644
  		log_warn("warn: %s-proc: exec path too long", key);
  		return (-1);
 diff --git a/smtpd/table.c b/smtpd/table.c
-index 21ee237..95b5164 100644
+index 9cfdfb99..24dfcca4 100644
 --- a/smtpd/table.c
 +++ b/smtpd/table.c
-@@ -193,6 +193,7 @@ table_create(const char *backend, const char *name, const char *tag,
+@@ -201,6 +201,7 @@ table_create(const char *backend, const char *name, const char *tag,
  	struct table_backend	*tb;
  	char			 buf[LINE_MAX];
  	char			 path[LINE_MAX];
@@ -61,7 +36,7 @@ index 21ee237..95b5164 100644
  	size_t			 n;
  	struct stat		 sb;
  
-@@ -207,11 +208,16 @@ table_create(const char *backend, const char *name, const char *tag,
+@@ -215,11 +216,16 @@ table_create(const char *backend, const char *name, const char *tag,
  	if (name && table_find(name, NULL))
  		fatalx("table_create: table \"%s\" already defined", name);
  
diff --git a/pkgs/servers/monitoring/plugins/labs_consol_de.nix b/pkgs/servers/monitoring/plugins/labs_consol_de.nix
index 350728d509fb..957aee43691a 100644
--- a/pkgs/servers/monitoring/plugins/labs_consol_de.nix
+++ b/pkgs/servers/monitoring/plugins/labs_consol_de.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchFromGitHub, fetchurl, buildPerlPackage, autoreconfHook, makeWrapper
-, perl, NetSNMP, coreutils, gnused, gnugrep }:
+, perl, DBDsybase, NetSNMP, coreutils, gnused, gnugrep }:
 
 let
   glplugin = fetchFromGitHub {
@@ -9,11 +9,10 @@ let
     sha256 = "0wb55a9pmgbilfffx0wkiikg9830qd66j635ypczqp4basslpq5b";
   };
 
-  generic = { pname, version, sha256, description, ... } @ attrs:
+  generic = { pname, version, sha256, description, buildInputs, ... }:
   let
-    attrs' = builtins.removeAttrs attrs [ "pname" "version" "rev" "sha256"];
     name' = "${stdenv.lib.replaceStrings [ "-" ] [ "_" ] "${pname}"}-${version}";
-  in perl.stdenv.mkDerivation rec {
+  in perl.stdenv.mkDerivation {
     name = "${pname}-${version}";
 
     src = fetchurl {
@@ -21,7 +20,7 @@ let
       inherit sha256;
     };
 
-    buildInputs = [ perl NetSNMP ];
+    buildInputs = [ perl ] ++ buildInputs;
 
     nativeBuildInputs = [ autoreconfHook makeWrapper ];
 
@@ -54,11 +53,20 @@ let
   };
 
 in {
+  check-mssql-health = generic {
+    pname       = "check_mssql_health";
+    version     = "2.6.4.14";
+    sha256      = "0w6gybrs7imx169l8740s0ax3adya867fw0abrampx59mnsj5pm1";
+    description = "Check plugin for Microsoft SQL Server.";
+    buildInputs = [ DBDsybase ];
+  };
+
   check-nwc-health = generic {
     pname       = "check_nwc_health";
     version     = "7.0.1.3";
     sha256      = "0rgd6zgd7kplx3z72n8zbzwkh8vnd83361sk9ibh6ng78sds1sl5";
     description = "Check plugin for network equipment.";
+    buildInputs = [ NetSNMP ];
   };
 
   check-ups-health = generic {
@@ -66,5 +74,6 @@ in {
     version     = "2.8.2.2";
     sha256      = "1gc2wjsymay2vk5ywc1jj9cvrbhs0fs851x8l4nc75df2g75v521";
     description = "Check plugin for UPSs.";
+    buildInputs = [ NetSNMP ];
   };
 }
diff --git a/pkgs/servers/sql/mariadb/default.nix b/pkgs/servers/sql/mariadb/default.nix
index e22e3a64fac1..fea5583ea591 100644
--- a/pkgs/servers/sql/mariadb/default.nix
+++ b/pkgs/servers/sql/mariadb/default.nix
@@ -15,11 +15,11 @@ mariadb = everything // {
 };
 
 common = rec { # attributes common to both builds
-  version = "10.2.14";
+  version = "10.2.15";
 
   src = fetchurl {
     url    = "https://downloads.mariadb.org/f/mariadb-${version}/source/mariadb-${version}.tar.gz";
-    sha256 = "0zizf3q0hdkmsn6rpwdbfm5xkj21cwpnnzq9knjfpwcadqnyqhrl";
+    sha256 = "04ds6vkb7k2lqpcdz663z4ll1jx1zz2hqxz5nj7gs8pwb18j1pik";
     name   = "mariadb-${version}.tar.gz";
   };