summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/manual-config.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/pkgs/os-specific/linux/kernel/manual-config.nix b/pkgs/os-specific/linux/kernel/manual-config.nix
index 777b33a84731..59fb1a6cd4c8 100644
--- a/pkgs/os-specific/linux/kernel/manual-config.nix
+++ b/pkgs/os-specific/linux/kernel/manual-config.nix
@@ -51,6 +51,7 @@ in
   # The kernel .config file
   config,
   # Manually specified features the kernel supports
+  # If unspecified, this will be autodetected from the .config
   features ? readFeatures config
 }:
 
@@ -100,7 +101,7 @@ stdenv.mkDerivation ({
   buildNativeInputs = [ perl nettools kmod ];
 
   makeFlags = commonMakeFlags;
-} // optionalAttrs features.modular {
+} // optionalAttrs (features ? modular && features.modular) {
   makeFlags = commonMakeFlags ++ [
     "MODLIB=\"$(out)/lib/modules/${modDirVersion}\""
   ];