summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/manual-config.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/pkgs/os-specific/linux/kernel/manual-config.nix b/pkgs/os-specific/linux/kernel/manual-config.nix
index e2cee9c23e7c..6238509e8fa6 100644
--- a/pkgs/os-specific/linux/kernel/manual-config.nix
+++ b/pkgs/os-specific/linux/kernel/manual-config.nix
@@ -50,7 +50,7 @@ in
   # The kernel source (tarball, git checkout, etc.)
   src,
   # Any patches
-  patches ? [],
+  kernelPatches ? [],
   # The kernel .config file
   configfile,
   # Manually specified nixexpr representing the config
@@ -86,10 +86,12 @@ stdenv.mkDerivation {
   enableParallelBuilding = true;
 
   passthru = {
-    inherit version modDirVersion config;
+    inherit version modDirVersion config kernelPatches;
   };
 
-  inherit patches src;
+  inherit src;
+
+  patches = map (p: p.patch) kernelPatches;
 
   prePatch = ''
     for mf in $(find -name Makefile -o -name Makefile.include -o -name install.sh); do