summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/emulators/wine/unstable.nix4
-rw-r--r--pkgs/misc/emulators/wine/winetricks.nix4
-rw-r--r--pkgs/misc/emulators/zsnes/default.nix24
-rw-r--r--pkgs/misc/themes/qtcurve/default.nix37
-rw-r--r--pkgs/misc/themes/qtcurve/qtcurve-1.8.17-install-paths.patch25
5 files changed, 87 insertions, 7 deletions
diff --git a/pkgs/misc/emulators/wine/unstable.nix b/pkgs/misc/emulators/wine/unstable.nix
index 0cb81a8185a4..f19ef0fcc7f3 100644
--- a/pkgs/misc/emulators/wine/unstable.nix
+++ b/pkgs/misc/emulators/wine/unstable.nix
@@ -7,12 +7,12 @@ assert stdenv.isLinux;
 assert stdenv.gcc.gcc != null;
 
 let 
-    version = "1.7.8";
+    version = "1.7.10";
     name = "wine-${version}";
 
     src = fetchurl {
       url = "mirror://sourceforge/wine/${name}.tar.bz2";
-      sha256 = "010qa6xn0b0161kcmm43yr0bp39iddb6d5i27mpl229shrgpzq9h";
+      sha256 = "1nybsp4pga0jhx6rm6ngpa2ixsbj75p8w22r9d70x4zgjx5hw9s4";
     };
 
     gecko = fetchurl {
diff --git a/pkgs/misc/emulators/wine/winetricks.nix b/pkgs/misc/emulators/wine/winetricks.nix
index e3fe48ec8a3c..f47902cd0bf1 100644
--- a/pkgs/misc/emulators/wine/winetricks.nix
+++ b/pkgs/misc/emulators/wine/winetricks.nix
@@ -2,13 +2,13 @@
 , cabextract, unzip, p7zip, gnused, gnugrep, bash } :
 
 stdenv.mkDerivation rec {
-  rev = "1078";
+  rev = "1083";
   name = "winetricks-${rev}";
 
   src = fetchsvn {
     url = "http://winetricks.googlecode.com/svn/trunk";
     inherit rev;
-    sha256 = "0ipvld0r5h6x2pgqkqa82q0w9flx6fn9aha8fd7axf5ji2gzmidm";
+    sha256 = "0zakwn7g2ni6xw92i1y3pngyaxsr93714s4jy11adf7rxdkj0a32";
   };
 
   buildInputs = [ perl which ];
diff --git a/pkgs/misc/emulators/zsnes/default.nix b/pkgs/misc/emulators/zsnes/default.nix
index a2896e70d174..6ee57e0cddfe 100644
--- a/pkgs/misc/emulators/zsnes/default.nix
+++ b/pkgs/misc/emulators/zsnes/default.nix
@@ -15,11 +15,29 @@ stdenv.mkDerivation {
     patch -p0 < ${./zsnes-1.51-libpng15.patch}
   '';
 
+  buildInputs = [ nasm SDL zlib libpng ncurses mesa ];
+
   preConfigure = ''
     cd src
-  '';
 
-  buildInputs = [ nasm SDL zlib libpng ncurses mesa ];
+    sed -i "/^STRIP/d" configure
+    
+    # Fix for undefined strncasecmp()
+    echo '#include <strings.h>' > tmp.cpp 
+    cat tmp.cpp tools/strutil.h > tools/strutil.h.new
+    mv tools/strutil.h.new tools/strutil.h
+    
+    # Fix for undefined system()
+    echo '#include <stdlib.h>' > tmp.cpp
+    cat tmp.cpp tools/depbuild.cpp > tools/depbuild.cpp.new
+    mv tools/depbuild.cpp.new tools/depbuild.cpp
+    
+    # Fix for lots of undefined strcmp, strncmp etc.
+    echo '#include <string.h>' > tmp.cpp 
+    cat tmp.cpp parsegen.cpp > parsegen.cpp.new
+    mv parsegen.cpp.new parsegen.cpp
+  '';
+  
 
   configureFlags = "--enable-release";
 
@@ -29,4 +47,4 @@ stdenv.mkDerivation {
     maintainers = [ stdenv.lib.maintainers.sander ];
     homepage = http://www.zsnes.com;
   };
-}
\ No newline at end of file
+}
diff --git a/pkgs/misc/themes/qtcurve/default.nix b/pkgs/misc/themes/qtcurve/default.nix
new file mode 100644
index 000000000000..017a47349a9c
--- /dev/null
+++ b/pkgs/misc/themes/qtcurve/default.nix
@@ -0,0 +1,37 @@
+{ stdenv, fetchurl, cmake, gettext, gtk2, kde_workspace, kdelibs, libpthreadstubs, libXdmcp
+, libxcb, pkgconfig, xlibs }:
+
+stdenv.mkDerivation {
+  name = "qtcurve-1.8.17";
+  src = fetchurl {
+    url = "https://github.com/QtCurve/qtcurve/archive/1.8.17.tar.gz";
+    sha256 = "1ixgill9lfhmcfsk5csk6ww3ljzbvb4x48m73apprv949xgr4wyn";
+  };
+
+  buildInputs = [
+    cmake
+    gettext
+    gtk2
+    kde_workspace
+    kdelibs
+    libpthreadstubs
+    libXdmcp
+    libxcb
+    pkgconfig
+    xlibs.xcbutilimage
+  ];
+
+  patches = [ ./qtcurve-1.8.17-install-paths.patch ];
+
+  cmakeFlags = ''
+    -DENABLE_QT5=OFF
+    -DQTC_QT4_ENABLE_KWIN=ON
+  '';
+
+  meta = {
+    homepage = https://github.com/QtCurve/qtcurve;
+    description = "Widget styles for Qt4/KDE4 and gtk2";
+    platforms = stdenv.lib.platforms.linux;
+    license = "LGPLv2.1+";
+  };
+}
diff --git a/pkgs/misc/themes/qtcurve/qtcurve-1.8.17-install-paths.patch b/pkgs/misc/themes/qtcurve/qtcurve-1.8.17-install-paths.patch
new file mode 100644
index 000000000000..bb8fd185c77a
--- /dev/null
+++ b/pkgs/misc/themes/qtcurve/qtcurve-1.8.17-install-paths.patch
@@ -0,0 +1,25 @@
+diff -ur qtcurve-1.8.17-a/CMakeLists.txt qtcurve-1.8.17-b/CMakeLists.txt
+--- qtcurve-1.8.17-a/CMakeLists.txt	2013-10-18 07:35:20.000000000 -0500
++++ qtcurve-1.8.17-b/CMakeLists.txt	2013-12-30 10:58:43.303808246 -0600
+@@ -135,8 +135,9 @@
+ if(ENABLE_GTK2)
+   find_package(PkgConfig REQUIRED)
+   pkg_check_modules(GTK2 REQUIRED gtk+-2.0)
++  set(GTK2_THEME_PREFIX "${CMAKE_INSTALL_PREFIX}")
+   if(GTK2_THEME_PREFIX)
+-    set(GTK2_PREIX "${GTK2_THEME_PREFIX}")
++    set(GTK2_PREFIX "${GTK2_THEME_PREFIX}")
+   elseif(NOT GTK2_PREFIX)
+     set(GTK2_PREFIX "${CMAKE_INSTALL_PREFIX}")
+   endif()
+diff -ur qtcurve-1.8.17-a/gtk2/style/CMakeLists.txt qtcurve-1.8.17-b/gtk2/style/CMakeLists.txt
+--- qtcurve-1.8.17-a/gtk2/style/CMakeLists.txt	2013-10-18 07:35:20.000000000 -0500
++++ qtcurve-1.8.17-b/gtk2/style/CMakeLists.txt	2013-12-30 11:23:41.370548328 -0600
+@@ -88,6 +88,6 @@
+   m ${QTC_X11_LIBRARIES} qtcurve-utils)
+ 
+ install(TARGETS qtcurve-gtk2 LIBRARY DESTINATION
+-  ${GTK2_LIBDIR}/gtk-2.0/${GTK2_BIN_VERSION}/engines)
++  lib/gtk-2.0/${GTK2_BIN_VERSION}/engines)
+ install(FILES gtkrc icons3 icons4 map_kde_icons.pl kdeglobals
+   DESTINATION ${GTK2_THEME_DIR}/gtk-2.0)