summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/emulators/wine/winetricks.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/pkgs/misc/emulators/wine/winetricks.nix b/pkgs/misc/emulators/wine/winetricks.nix
index 71cc2767f698..e3fe48ec8a3c 100644
--- a/pkgs/misc/emulators/wine/winetricks.nix
+++ b/pkgs/misc/emulators/wine/winetricks.nix
@@ -1,19 +1,20 @@
-{ stdenv, fetchsvn, wine, perl, which, coreutils, zenity, curl, cabextract, unzip, p7zip } :
+{ stdenv, fetchsvn, wine, perl, which, coreutils, zenity, curl
+, cabextract, unzip, p7zip, gnused, gnugrep, bash } :
 
 stdenv.mkDerivation rec {
-  rev = "939";
+  rev = "1078";
   name = "winetricks-${rev}";
 
   src = fetchsvn {
     url = "http://winetricks.googlecode.com/svn/trunk";
     inherit rev;
-    sha256 = "01v13qw4sxmfm09g9amqycnzy743gdrhvv23rjr9255dzlrj1s8f";
+    sha256 = "0ipvld0r5h6x2pgqkqa82q0w9flx6fn9aha8fd7axf5ji2gzmidm";
   };
 
   buildInputs = [ perl which ];
 
   pathAdd = stdenv.lib.concatStringsSep "/bin:" # coreutils is for sha1sum
-    [ wine perl which coreutils zenity curl cabextract unzip p7zip ]
+    [ wine perl which coreutils zenity curl cabextract unzip p7zip gnused gnugrep bash ]
     + "/bin";
 
   patch = ./winetricks.patch;
@@ -24,6 +25,7 @@ stdenv.mkDerivation rec {
     description = "A script to install DLLs needed to work around problems in Wine";
     license = "LGPLv2.1";
     homepage = http://code.google.com/p/winetricks/;
+    maintainers = with stdenv.lib.maintainers; [ the-kenny ];
   };
 }