summary refs log tree commit diff
path: root/pkgs/lib
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/lib')
-rw-r--r--pkgs/lib/types.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/lib/types.nix b/pkgs/lib/types.nix
index c806e922e357..d71cb9df097c 100644
--- a/pkgs/lib/types.nix
+++ b/pkgs/lib/types.nix
@@ -135,7 +135,7 @@ rec {
       name = "option set";
       # merge is done in "options.nix > addOptionMakeUp > handleOptionSets"
       merge = lib.id;
-      check = x: lib.traceValIfNot builtins.isAttrs x;
+      check = x: isAttrs x || builtins.isFunction x;
       hasOptions = true;
       delayOnGlobalEval = true;
     };