summary refs log tree commit diff
path: root/pkgs/lib
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/lib')
-rw-r--r--pkgs/lib/lists.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/lib/lists.nix b/pkgs/lib/lists.nix
index 36fa236304da..a843addaf9e5 100644
--- a/pkgs/lib/lists.nix
+++ b/pkgs/lib/lists.nix
@@ -131,7 +131,7 @@ rec {
   zipListsWith = f: fst: snd:
     if fst != [] && snd != [] then
       [ (f (head fst) (head snd)) ]
-      ++ zipLists (tail fst) (tail snd)
+      ++ zipListsWith f (tail fst) (tail snd)
     else [];
 
   zipLists = zipListsWith (fst: snd: { inherit fst snd; });