summary refs log tree commit diff
path: root/pkgs/lib/types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/lib/types.nix')
-rw-r--r--pkgs/lib/types.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/lib/types.nix b/pkgs/lib/types.nix
index 956368138aa2..38ae7b43630a 100644
--- a/pkgs/lib/types.nix
+++ b/pkgs/lib/types.nix
@@ -157,7 +157,7 @@ rec {
     uniq = elemType: mkOptionType {
       inherit (elemType) name check iter fold docPath hasOptions;
       merge = list:
-        if tail list == [] then
+        if length list == 1 then
           head list
         else
           throw "Multiple definitions. Only one is allowed for this option.";