summary refs log tree commit diff
path: root/pkgs/lib/debug.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/lib/debug.nix')
-rw-r--r--pkgs/lib/debug.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/lib/debug.nix b/pkgs/lib/debug.nix
index e452151add6b..b78f946c5d44 100644
--- a/pkgs/lib/debug.nix
+++ b/pkgs/lib/debug.nix
@@ -66,7 +66,7 @@ rec {
     let testsToRun = if tests ? tests then tests.tests else [];
     in if (substring 0 4 name == "test" ||  elem name testsToRun)
        && ((testsToRun == []) || elem name tests.tests)
-       && (!lib.eqStrict test.expr test.expected)
+       && (test.expr != test.expected)
 
       then [ { inherit name; expected = test.expected; result = test.expr; } ]
       else [] ) tests));