about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/chiaki/default.nix31
-rw-r--r--pkgs/games/klavaro/default.nix2
-rw-r--r--pkgs/games/tdm/default.nix2
-rw-r--r--pkgs/games/tome2/default.nix50
-rw-r--r--pkgs/games/tome4/default.nix5
5 files changed, 88 insertions, 2 deletions
diff --git a/pkgs/games/chiaki/default.nix b/pkgs/games/chiaki/default.nix
new file mode 100644
index 000000000000..7a9ac7d381c1
--- /dev/null
+++ b/pkgs/games/chiaki/default.nix
@@ -0,0 +1,31 @@
+{ lib, mkDerivation, fetchFromGitHub
+, cmake, ffmpeg, libopus, qtbase, qtmultimedia, qtsvg, pkgconfig, protobuf
+, python3Packages, SDL2 }:
+
+mkDerivation rec {
+  pname = "chiaki";
+  version = "1.0.3";
+
+  src = fetchFromGitHub {
+    rev = "v${version}";
+    owner = "thestr4ng3r";
+    repo = "chiaki";
+    fetchSubmodules = true;
+    sha256 = "09c6izprqqvhn1vbr2897ql05w5c7iqakm6jn795a5faghjm1mah";
+  };
+
+  nativeBuildInputs = [
+    cmake pkgconfig protobuf python3Packages.python python3Packages.protobuf
+  ];
+  buildInputs = [ ffmpeg libopus qtbase qtmultimedia qtsvg protobuf SDL2 ];
+
+  doCheck = true;
+
+  meta = with lib; {
+    homepage = "https://github.com/thestr4ng3r/chiaki";
+    description = "Free and Open Source PS4 Remote Play Client";
+    license = licenses.gpl3Plus;
+    maintainers = with maintainers; [ delroth ];
+    platforms = platforms.all;
+  };
+}
diff --git a/pkgs/games/klavaro/default.nix b/pkgs/games/klavaro/default.nix
index e2a4cff291ba..f58f86cd8fba 100644
--- a/pkgs/games/klavaro/default.nix
+++ b/pkgs/games/klavaro/default.nix
@@ -25,6 +25,6 @@ stdenv.mkDerivation rec {
     homepage = http://klavaro.sourceforge.net/;
     license = stdenv.lib.licenses.gpl3Plus;
     platforms = stdenv.lib.platforms.linux;
-    maintainers = [stdenv.lib.maintainers.mimadrid];
+    maintainers = [stdenv.lib.maintainers.mimame];
   };
 }
diff --git a/pkgs/games/tdm/default.nix b/pkgs/games/tdm/default.nix
index 136bac8800ed..f0a89adab572 100644
--- a/pkgs/games/tdm/default.nix
+++ b/pkgs/games/tdm/default.nix
@@ -96,7 +96,7 @@ EOF
     description = "The Dark Mod - stealth FPS inspired by the Thief series";
     homepage = "http://www.thedarkmod.com";
     license = licenses.gpl3;
-    maintainers = with maintainers; [ cf6b88f ];
+    maintainers = with maintainers; [ cizra ];
     platforms = with platforms; [ "x86_64-linux" ];  # tdm also supports x86, but I don't have a x86 install at hand to test.
   };
 }
diff --git a/pkgs/games/tome2/default.nix b/pkgs/games/tome2/default.nix
new file mode 100644
index 000000000000..a632e523aaa8
--- /dev/null
+++ b/pkgs/games/tome2/default.nix
@@ -0,0 +1,50 @@
+{ stdenv, fetchFromGitHub, makeDesktopItem, ncurses, libX11, boost, cmake }:
+
+let
+  pname = "tome2";
+  description = "A dungeon crawler similar to Angband, based on the works of Tolkien";
+
+  desktopItem = makeDesktopItem {
+    desktopName = pname;
+    name = pname;
+    exec = "${pname}-x11";
+    icon = pname;
+    terminal = "False";
+    comment = description;
+    type = "Application";
+    categories = "Game;RolePlaying;";
+    genericName = pname;
+  };
+
+in stdenv.mkDerivation {
+  inherit pname;
+  version = "2.4";
+
+  src = fetchFromGitHub {
+    owner = "tome2";
+    repo = "tome2";
+    rev = "4e6a906c80ff07b75a6acf4ff585b47303805e46";
+    sha256 = "06bddj55y673d7bnzblk8n01z32l6k2rad3bpzr8dmw464hx4wwf";
+  };
+
+  buildInputs = [ ncurses libX11 boost ];
+
+  nativeBuildInputs = [ cmake ];
+
+  cmakeFlags = [
+    "-DSYSTEM_INSTALL=ON"
+  ];
+
+  postInstall = ''
+    mkdir -p $out/share/applications
+    cp ${desktopItem}/share/applications/*.desktop $out/share/applications
+  '';
+
+  meta = with stdenv.lib; {
+    inherit description;
+    license = licenses.unfree;
+    maintainers = with maintainers; [ cizra ];
+    platforms = platforms.all;
+    homepage = "https://github.com/tome2/tome2";
+  };
+}
diff --git a/pkgs/games/tome4/default.nix b/pkgs/games/tome4/default.nix
index c04920d7aa2c..c4d5dcb41e71 100644
--- a/pkgs/games/tome4/default.nix
+++ b/pkgs/games/tome4/default.nix
@@ -25,6 +25,11 @@ in stdenv.mkDerivation rec {
     sha256 = "0mc5dgh2x9nbili7gy6srjhb23ckalf08wqq2amyjr5rq392jvd7";
   };
 
+  prePatch = ''
+    # http://forums.te4.org/viewtopic.php?f=42&t=49478&view=next#p234354
+    sed -i 's|#include <GL/glext.h>||' src/tgl.h
+  '';
+
   nativeBuildInputs = [ makeWrapper unzip premake4 ];
 
   # tome4 vendors quite a few libraries so someone might want to look