summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/quake3/wrapper/builder.sh5
-rw-r--r--pkgs/games/quake3/wrapper/default.nix6
2 files changed, 8 insertions, 3 deletions
diff --git a/pkgs/games/quake3/wrapper/builder.sh b/pkgs/games/quake3/wrapper/builder.sh
index 6162adfa824c..3042e7548f09 100644
--- a/pkgs/games/quake3/wrapper/builder.sh
+++ b/pkgs/games/quake3/wrapper/builder.sh
@@ -12,8 +12,13 @@ done
 ensureDir $out/bin
 
 cat >$out/bin/quake3 <<EOF
+mesa=$mesa
+
+$(cat $mesaSwitch)
+
 exec $game/ioquake3.i386 \
     +set fs_basepath $out \
+    +set r_allowSoftwareGL 1 \
     "\$@"
 EOF
 
diff --git a/pkgs/games/quake3/wrapper/default.nix b/pkgs/games/quake3/wrapper/default.nix
index 512ff21d7ce4..315516f037f4 100644
--- a/pkgs/games/quake3/wrapper/default.nix
+++ b/pkgs/games/quake3/wrapper/default.nix
@@ -1,7 +1,7 @@
-{stdenv, fetchurl, game, paks}:
+{stdenv, fetchurl, game, paks, mesa, name}:
 
 stdenv.mkDerivation {
-  name = "quake3";
   builder = ./builder.sh;
-  inherit game paks;
+  inherit game paks mesa name;
+  mesaSwitch = ../../../build-support/opengl/mesa-switch.sh;
 }