summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/gnugo/default.nix24
-rw-r--r--pkgs/games/six/default.nix34
-rw-r--r--pkgs/games/six/gcc43-includes.patch38
-rw-r--r--pkgs/games/super-tux/default.nix28
-rw-r--r--pkgs/games/super-tux/g++4.patch13
5 files changed, 137 insertions, 0 deletions
diff --git a/pkgs/games/gnugo/default.nix b/pkgs/games/gnugo/default.nix
new file mode 100644
index 000000000000..21c4195b28b8
--- /dev/null
+++ b/pkgs/games/gnugo/default.nix
@@ -0,0 +1,24 @@
+{ stdenv, fetchurl }:
+
+let
+
+    versionNumber = "3.8";
+
+in
+
+stdenv.mkDerivation {
+
+  name = "gnugo-${versionNumber}";
+
+  src = fetchurl {
+    url = "mirror://gnu/gnugo/gnugo-${versionNumber}.tar.gz";
+    sha256 = "0wkahvqpzq6lzl5r49a4sd4p52frdmphnqsfdv7gdp24bykdfs6s";
+  };
+
+  meta = {
+    description = "GNU Go - A computer go player";
+    homepage = "http://http://www.gnu.org/software/gnugo/";
+    license = "GPLv3";
+  };
+
+}
diff --git a/pkgs/games/six/default.nix b/pkgs/games/six/default.nix
new file mode 100644
index 000000000000..2f11eab3ceaf
--- /dev/null
+++ b/pkgs/games/six/default.nix
@@ -0,0 +1,34 @@
+{ stdenv, fetchurl, arts, kdelibs, libX11, libXext, libXt, perl, qt3, zlib }:
+
+let
+
+    versionNumber = "0.5.3";
+
+in
+
+stdenv.mkDerivation {
+
+  name = "six-${versionNumber}";
+
+  src = fetchurl {
+    url = "http://six.retes.hu/download/six-${versionNumber}.tar.gz";
+    sha256 = "0hialm0kxr11rp5z452whjmxp2vaqqj668d0dfs32fd10ggi8wj4";
+  };
+
+  meta = {
+    description = "Six - A Hex playing program for KDE";
+    homepage = http://six.retes.hu/;
+    license = "GPLv2";
+  };
+
+  buildInputs = [ arts kdelibs libX11 libXext libXt perl qt3 zlib ];
+
+  # Supress some warnings which are less useful to us when making packages.
+  NIX_CFLAGS_COMPILE = "-Wno-conversion -Wno-parentheses";
+
+  # Without "--x-libraries=", we get the error
+  # "impure path `/usr/lib' used in link".
+  configureFlags = "--x-libraries=";
+
+  patches = [ ./gcc43-includes.patch ];
+}
diff --git a/pkgs/games/six/gcc43-includes.patch b/pkgs/games/six/gcc43-includes.patch
new file mode 100644
index 000000000000..83096bb0da2b
--- /dev/null
+++ b/pkgs/games/six/gcc43-includes.patch
@@ -0,0 +1,38 @@
+This patch makes six compile with gcc 4.3 by including more header files.  It
+is based on the advice at <http://gcc.gnu.org/gcc-4.3/porting_to.html>.
+
+--- a/six/carrier.h
++++ b/six/carrier.h
+@@ -2,6 +2,7 @@
+ #ifndef CARRIER_H
+ #define CARRIER_H
+
++#include <cstring>
+ #include <iostream>
+ #include <vector>
+
+diff --git a/six/hexgame.cpp b/six/hexgame.cpp
+index 720e977..5d0dafe 100644
+--- a/six/hexgame.cpp
++++ b/six/hexgame.cpp
+@@ -3,6 +3,7 @@
+ #include <cassert>
+ #include <cctype>
+ #include <cstdio>
++#include <cstdlib>
+
+ #include <string>
+
+diff --git a/six/main.cpp b/six/main.cpp
+index 7fb5c21..b925a0c 100644
+--- a/six/main.cpp
++++ b/six/main.cpp
+@@ -4,6 +4,8 @@
+ #include "carrier.h"
+ #include "misc.h"
+
++#include <cstdlib>
++
+ #include <kapp.h>
+ #include <dcopclient.h>
+ #include <kaboutdata.h>
diff --git a/pkgs/games/super-tux/default.nix b/pkgs/games/super-tux/default.nix
new file mode 100644
index 000000000000..60e9cc537bf0
--- /dev/null
+++ b/pkgs/games/super-tux/default.nix
@@ -0,0 +1,28 @@
+{ fetchurl, stdenv, SDL, SDL_image, SDL_mixer, curl, gettext, libogg, libvorbis, mesa, openal }:
+
+let
+
+    version = "0.1.3";
+
+in
+
+stdenv.mkDerivation {
+  name = "supertux-${version}";
+
+  src = fetchurl {
+    url = "http://download.berlios.de/supertux/supertux-${version}.tar.bz2";
+    sha256 = "15xdq99jy4hayr96jpqcp15rbr9cs5iamjirafajcrkpa61mi4h0";
+  };
+
+  buildInputs = [ SDL SDL_image SDL_mixer curl gettext libogg libvorbis mesa openal ];
+
+  patches = [ ./g++4.patch ];
+
+  meta = {
+    description = "SuperTux is a classic 2D jump'n run sidescroller game in a style similar to the original Super Mario games covered under the GPL.";
+
+    homepage = http://supertux.lethargik.org/index.html;
+
+    license = "GPLv2";
+  };
+}
diff --git a/pkgs/games/super-tux/g++4.patch b/pkgs/games/super-tux/g++4.patch
new file mode 100644
index 000000000000..a7378c80a29b
--- /dev/null
+++ b/pkgs/games/super-tux/g++4.patch
@@ -0,0 +1,13 @@
+diff --git a/src/menu.h b/src/menu.h
+index 3c67c45..7c7ab8e 100644
+--- a/src/menu.h
++++ b/src/menu.h
+@@ -207,7 +207,7 @@ public:
+
+   bool isToggled(int id);
+
+-  void Menu::get_controlfield_key_into_input(MenuItem *item);
++  void get_controlfield_key_into_input(MenuItem *item);
+
+   void draw   ();
+   void draw_item(int index, int menu_width, int menu_height);