about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/gambit/bootstrap.nix2
-rw-r--r--pkgs/development/compilers/gambit/default.nix31
-rw-r--r--pkgs/development/compilers/gerbil/default.nix14
-rw-r--r--pkgs/development/guile-modules/guile-fibers/default.nix28
-rw-r--r--pkgs/development/guile-modules/guile-lib/default.nix8
-rw-r--r--pkgs/development/python-modules/ephem/default.nix32
6 files changed, 92 insertions, 23 deletions
diff --git a/pkgs/development/compilers/gambit/bootstrap.nix b/pkgs/development/compilers/gambit/bootstrap.nix
index 65fb20aa2603..e645ecb41bd2 100644
--- a/pkgs/development/compilers/gambit/bootstrap.nix
+++ b/pkgs/development/compilers/gambit/bootstrap.nix
@@ -13,7 +13,7 @@ stdenv.mkDerivation rec {
   buildInputs = [ autoconf ];
 
   configurePhase = ''
-    ./configure --prefix=$out --enable-single-host
+    ./configure --prefix=$out
   '';
 
   buildPhase = ''
diff --git a/pkgs/development/compilers/gambit/default.nix b/pkgs/development/compilers/gambit/default.nix
index 58b08ebd4fb7..79f57c42c50d 100644
--- a/pkgs/development/compilers/gambit/default.nix
+++ b/pkgs/development/compilers/gambit/default.nix
@@ -1,19 +1,16 @@
 { stdenv, fetchurl, fetchgit, git, openssl, autoconf, pkgs }:
 
+# TODO: distinct packages for gambit-release and gambit-devel
+
 stdenv.mkDerivation rec {
   name    = "gambit-${version}";
-  version = "4.8.8-f3ffeb6";
+  version = "4.8.8-300db59";
   bootstrap = import ./bootstrap.nix ( pkgs );
 
-#  devver  = "4_8_8";
-#  src = fetchurl {
-#    url    = "http://www.iro.umontreal.ca/~gambit/download/gambit/v4.8/source/gambit-v${version}-devel.tgz";
-#    sha256 = "0j3ka76cfb007rlcc3nv5p1s6vh31cwp87hwwabawf16vs1jb7bl";
-#  };
   src = fetchgit {
     url = "https://github.com/feeley/gambit.git";
-    rev = "f3ffeb695aeea80c18c1b9ef276b57898c780dca";
-    sha256 = "1lqixsrgk9z2gj6z1nkys0pfd3m5zjxrp3gvqn2wpr9h7hjb8x06";
+    rev = "300db59e1d3b66bcd597f617849df0274d2a4472";
+    sha256 = "1mhy49lasakgvdaswkxasdssik11lx3hfx4h1gs2b6881488ssdp";
   };
 
   buildInputs = [ openssl git autoconf bootstrap ];
@@ -28,6 +25,8 @@ stdenv.mkDerivation rec {
       --enable-absolute-shared-libs # Yes, NixOS will want an absolute path, and fix it.
       --enable-poll
       --enable-openssl
+      --enable-default-runtime-options="f8,-8,t8" # Default to UTF-8 for source and all I/O
+      #--enable-debug # Nope: enables plenty of good stuff, but also the costly console.log
 
       #--enable-multiple-versions # Nope, NixOS already does version multiplexing
       #--enable-guide
@@ -49,15 +48,15 @@ stdenv.mkDerivation rec {
 
   buildPhase = ''
     # Make bootstrap compiler, from release bootstrap
-    mkdir -p boot/wip-compiler &&
-    cp -rp ${bootstrap}/. boot/wip-compiler/. &&
+    mkdir -p boot &&
+    cp -rp ${bootstrap}/. boot/. &&
     chmod -R u+w boot &&
-    cd boot/wip-compiler && \
-    cp ../../gsc/makefile.in ../../gsc/*.scm gsc && \
-    (cd gsc && make bootclean ) &&
-    make bootstrap &&
-    cd ../.. &&
-    cp boot/wip-compiler/gsc/gsc gsc-boot &&
+    cd boot &&
+    cp ../gsc/makefile.in ../gsc/*.scm gsc && # */
+    ./configure &&
+    for i in lib gsi gsc ; do (cd $i ; make ) ; done &&
+    cd .. &&
+    cp boot/gsc/gsc gsc-boot &&
 
     # Now use the bootstrap compiler to build the real thing!
     make -j2 from-scratch
diff --git a/pkgs/development/compilers/gerbil/default.nix b/pkgs/development/compilers/gerbil/default.nix
index 22047b663d04..59cafee3b3a9 100644
--- a/pkgs/development/compilers/gerbil/default.nix
+++ b/pkgs/development/compilers/gerbil/default.nix
@@ -2,23 +2,27 @@
   coreutils, rsync, bash,
   openssl, zlib, sqlite, libxml2, libyaml, libmysql, lmdb, leveldb }:
 
+# TODO: distinct packages for gerbil-release and gerbil-devel
+
 stdenv.mkDerivation rec {
   name    = "gerbil-${version}";
 
-  version = "0.12-DEV";
+  version = "0.12-DEV-777-gd855915";
   src = fetchgit {
     url = "https://github.com/vyzo/gerbil.git";
-    rev = "3657b6e940ea248e0b312f276590e38ff68997e7";
-    sha256 = "11ys7082ghkm4yikz4qxmv3jpxcr42jfi0jhjw1mpzbqdg6004w2";
+    rev = "9db6187dc996eec4087f83b86339e7b17bb69bad";
+    sha256 = "1hqmsy77d62dvil3az4vdr0rmwvxhinjl1dbcxzamz2c2kcjv1jg";
   };
 
   buildInputs = [
-    gambit openssl
+    gambit
     coreutils rsync bash
-    zlib openssl zlib sqlite libxml2 libyaml libmysql lmdb leveldb
+    openssl zlib sqlite libxml2 libyaml libmysql lmdb leveldb
   ];
 
   postPatch = ''
+    echo '(define (gerbil-version-string) "v${version}")' > src/gerbil/runtime/gx-version.scm
+
     patchShebangs .
 
     find . -type f -executable -print0 | while IFS= read -r -d ''$'\0' f; do
diff --git a/pkgs/development/guile-modules/guile-fibers/default.nix b/pkgs/development/guile-modules/guile-fibers/default.nix
new file mode 100644
index 000000000000..5f82a93c513a
--- /dev/null
+++ b/pkgs/development/guile-modules/guile-fibers/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchFromGitHub, autoreconfHook, pkgconfig, guile, texinfo }:
+
+let
+  version = "1.0.0";
+  name = "guile-fibers-${version}";
+in stdenv.mkDerivation {
+  inherit name;
+
+  src = fetchFromGitHub {
+    owner = "wingo";
+    repo = "fibers";
+    rev = "v${version}";
+    sha256 = "1r47m1m112kxf23xny99f0qkqsk6626iyc5jp7vzndfiyp5yskwi";
+  };
+
+  nativeBuildInputs = [ autoreconfHook pkgconfig ];
+  buildInputs = [ guile texinfo ];
+
+  autoreconfPhase = "./autogen.sh";
+
+  meta = with stdenv.lib; {
+    description = "Concurrent ML-like concurrency for Guile";
+    homepage = https://github.com/wingo/fibers;
+    license = licenses.lgpl3Plus;
+    maintainers = with maintainers; [ vyp ];
+    platforms = platforms.all;
+  };
+}
diff --git a/pkgs/development/guile-modules/guile-lib/default.nix b/pkgs/development/guile-modules/guile-lib/default.nix
index de456b4983ad..62482cec7e6c 100644
--- a/pkgs/development/guile-modules/guile-lib/default.nix
+++ b/pkgs/development/guile-modules/guile-lib/default.nix
@@ -1,4 +1,4 @@
-{stdenv, fetchurl, guile, texinfo}:
+{stdenv, fetchurl, guile, texinfo, pkgconfig}:
 
 assert stdenv ? cc && stdenv.cc.isGNU;
 
@@ -10,8 +10,14 @@ stdenv.mkDerivation rec {
     sha256 = "1f9n2b5b5r75lzjinyk6zp6g20g60msa0jpfrk5hhg4j8cy0ih4b";
   };
 
+  nativeBuildInputs = [pkgconfig];
   buildInputs = [guile texinfo];
 
+  # One test doesn't seem to be compatible with guile_2_2
+  patchPhase = ''
+    sed -i -e '/sxml.ssax.scm/d' unit-tests/Makefile*
+  '';
+
   doCheck = true;
 
   preCheck =
diff --git a/pkgs/development/python-modules/ephem/default.nix b/pkgs/development/python-modules/ephem/default.nix
new file mode 100644
index 000000000000..231a52c9d7a7
--- /dev/null
+++ b/pkgs/development/python-modules/ephem/default.nix
@@ -0,0 +1,32 @@
+{ stdenv, buildPythonPackage, fetchPypi, isPy3k
+, glibcLocales, pytest }:
+
+buildPythonPackage rec {
+  pname = "ephem";
+  name = "${pname}-${version}";
+  version = "3.7.6.0";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "7a4c82b1def2893e02aec0394f108d24adb17bd7b0ca6f4bc78eb7120c0212ac";
+  };
+
+  patchFlags = "-p0";
+  checkInputs = [ pytest glibcLocales ];
+  # JPLTest uses assets not distributed in package
+  checkPhase = ''
+    LC_ALL="en_US.UTF-8" py.test --pyargs ephem.tests -k "not JPLTest"
+  '';
+
+  # Unfortunately, the tests are broken for Python 3 in 3.7.6.0. They have been
+  # fixed in https://github.com/brandon-rhodes/pyephem/commit/c8633854e2d251a198b0f701d0528b508baa2411
+  # but there has not been a new release since then.
+  doCheck = !isPy3k;
+
+  meta = with stdenv.lib; {
+    description = "Compute positions of the planets and stars";
+    homepage = https://pypi.python.org/pypi/ephem/;
+    license = licenses.lgpl3;
+    maintainers = with maintainers; [ chrisrosset ];
+  };
+}